Contribute
Register

[Guide] Booting the OS X installer on LAPTOPS with Clover

Joined
Dec 7, 2012
Messages
5
Motherboard
Mac OS X
CPU
2600K
Graphics
HD5770
Mac
Classic Mac
Mobile Phone
Hi. My case is installing 10.13 and dual boot windows 7 on a single drive where windows (uefi) was there before macos was installed. I am now at the point where I'm installing clover locally to throw out USB stick.

So now my drive has 4 parts
  • Windows EFI
  • Windows reserved partition
  • NTFS with Windows
  • APFS with MacOS

If I understand correctly APFS is a container that holds both the MacOS EFI volume and "system" volume.
When I run clover from USB stick, I correctly see 2 boot options
  • macos installer (from the very same usb stick)
  • macOS system (from the APFS volume)
but I'm puzzled about why there are 2 windows entries, where one is just Windows and other one Microsoft EFI. If I try to boot just Windows, it'll not boot (there'll be black screen with cursor caret blinking) but if I select Microsoft EFI, the windows is going to boot properly.

Now to the merit.
This seems important to me because when I installed clover on APFS parition, the BIOS doesn't recognize it as bootable volume. Is it even possible that BIOS "unpacks" APFS to even see the EFI volume?
Another question is, if I'd make 5th partition on the drive, an EFI parition, and install clover there, could I eventually replace Windows EFI parition and boot both MacOS and Windows from this new EFI parition with clover? Is it supported? What would then happen to EFI volume in APFS?
I'm happy to read more on this topic if you could please link to an article.

Thank you
 
Last edited:
Joined
Oct 2, 2019
Messages
10
Motherboard
HP dv6 2142sl-Clover Legacy
CPU
i5-430M / PM55
Graphics
GT 320M
Classic Mac
iMac
Mobile Phone
iOS
Hi Guys,
after too many days I'm able to boot my mackintosh.

Wifi ok, Ethernet ok, Audio Ok... only the graphic card I'm not able to unlock.

Someone have any idea about the issue? OS X uses always standard drive, despite Nvidia Web Driver.
 
Joined
Oct 24, 2019
Messages
4
CPU
i5-6200u
Graphics
HD 520
Mobile Phone
iOS
Hi,

I am having some issues booting to the installer and I have attached some images regarding the same plus I have attached my efi folder too could someone please look into it thanks in advance.

Machine: HP 348 G3
CPU: Core i5-6200u
Gpu: Intel HD 520
Motherboard Model: 8193
 

Attachments

Joined
Oct 2, 2019
Messages
10
Motherboard
HP dv6 2142sl-Clover Legacy
CPU
i5-430M / PM55
Graphics
GT 320M
Classic Mac
iMac
Mobile Phone
iOS
If you use the bootflag "cpus=1", are you able to reach the installer?
The problem I think could be on Kernel Lapic patch, even if you've enabled it
 
Joined
Oct 24, 2019
Messages
4
CPU
i5-6200u
Graphics
HD 520
Mobile Phone
iOS
Hey thanks for the reply it helped a bit i guess since the installer moved forward but it crashed again and restarted every time. I have attached the images below although i guess that i missed the error point so i have also linked a video file too.

Here is the video link
 

Attachments

Last edited:
Joined
Oct 2, 2019
Messages
10
Motherboard
HP dv6 2142sl-Clover Legacy
CPU
i5-430M / PM55
Graphics
GT 320M
Classic Mac
iMac
Mobile Phone
iOS
Have you tried disabling all video injects? Your kernel panic shows on Intel video driver, on Framebuffer. It's not visible in your screenshot but it's in your video.
I hope someone could give you a technical feedback, but in my experience, I'm not sure :)
 
Joined
Oct 24, 2019
Messages
4
CPU
i5-6200u
Graphics
HD 520
Mobile Phone
iOS
Have you tried disabling all video injects? Your kernel panic shows on Intel video driver, on Framebuffer. It's not visible in your screenshot but it's in your video.
I hope someone could give you a technical feedback, but in my experience, I'm not sure :)
Hey thanks for the reply i’ll try this too and maybe someone else could help.
 
Joined
Nov 21, 2016
Messages
12
Motherboard
HP Probook 450G1
CPU
Intel Core i5 4210M
Graphics
AMD Radeon 8750M, Intel HD Graphics 4600
Mac
MacBook Pro
Mobile Phone
iOS
I created the installer and it stopped here
Help me?

74580682_2255722951206361_7492919753267216384_n.jpg
 
Joined
Nov 1, 2019
Messages
7
Motherboard
Lenovo ThinkPad Yoga 370-1.34-Clover
CPU
i7-7500U
Graphics
HD 620
Mac
Mac mini
Mobile Phone
iOS
Hi, could anyone help, I follow this guide and made my way to booting after 2 nights doing CLOVER workaround. But my keyboard & ELAN touchpad doesn't work during Os Install, USB mouse is working. What do I need to add in CLOVER?
 

Attachments

Top