Contribute
Register

[Guide] Booting the OS X installer on LAPTOPS with Clover

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@RehabMan asking it here as it didn't seem much of an issue to start a new thread,

CLOVER is unable to initialize in absence of EmuVariableUEFI. Tried with both OSXAptioFix and AptioFixPkg, results are same.

If I remove EmuVariableUEFI, it gets stuck forever at initializing screen, I don't even get the CLOVER UI, just my OEM logo.

If I put it back, everything works fine (but not native NVRAM)

Can you provide any insights on this?

Regards
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I see that in droptables xh_rvp10 is being dropped.
Would you mind explaining the full reasoning behind it?

That particular SSDT has been known to cause KP in the XHCI kexts.

In my laptop xh_rvp10 does not exist but I have xh_rvp07, so I assume I had to change it to that.

Bad assumption. If you have no issue keeping the SSDT, don't drop it.
 
Joined
Nov 3, 2011
Messages
2
Motherboard
GA-Z68MA-D2H-B3
CPU
i7-2600
Installing to the HDD/SSD after installation is very similar to installing to the USB, except that the install target will be your macOS/OS X system volume. Refer back to this section when you get to that stage.

I was following this guide and a doubt cross my mind. Supposly I have to install Clover in HDD/SDD, why is this? if when I'll boot up and install macOS in the ssd will rewrite clover isn't?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,855
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I was following this guide and a doubt cross my mind. Supposly I have to install Clover in HDD/SDD, why is this? if when I'll boot up and install macOS in the ssd will rewrite clover isn't?
you need to install clover to the hard drive after you have installed macOS so the laptop can boot up without the need for a usb stick

when you install clover, it installs to the EFI partition on the hard drive
 
Joined
Nov 29, 2018
Messages
1
I have completed all the step and my Hackintosh sierra is working great but when I plug or unplug the charger, press f11 or f12 key it got a freeze.
My laptop specification is
Dell Vostro 3568
8gb ram DDR4
2gb graphics card AMD
i5 7th gen
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have completed all the step and my Hackintosh sierra is working great but when I plug or unplug the charger, press f11 or f12 key it got a freeze.
My laptop specification is
Dell Vostro 3568
8gb ram DDR4
2gb graphics card AMD
i5 7th gen
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

Also, your profile has no hardware details. Please fix as per FAQ. Before your next reply.
 
Joined
Dec 18, 2018
Messages
2
Hi guys!

I want to create the boot USB on a Mojave 10.14.2 and can't use Rehabmans Clover because the package installer fails. I should say that I'm very new in this MacOS world so maybe I'm overlooking something simple. Is there a workaround for this or should I go with official Clover?

I tried going with this from Rehabmans Bitbucket: Clover_v2.4k_r4701.RM-4963.ca6cca7c.zip
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I want to create the boot USB on a Mojave 10.14.2 and can't use Rehabmans Clover because the package installer fails.

You will need to provide details.
 
Joined
May 2, 2010
Messages
68
Motherboard
HP Probook 4530s-Clover
CPU
i5-2430M
Graphics
HD 3000
Hello I used to run El Capitan on my Probook HP 4530s, the hard drive simply failed and I have installed a brand new SSD.
So I am trying to install Sierra on my laptop.
I have created a USB 2.0 key with one partition EFI, and installed the installer on the other Mac HFS+ partition.
I have used this guide : https://www.tonymacx86.com/threads/...book-zbook-using-clover-uefi-hotpatch.261719/
And for the USB this: https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
I have used this config file renamed config.plist which I think is suitable for my system:
config_HD3000_1366x768

When I see the apple logo I then get a no entry sign straight away

I have used different config files the one that gets me the furthest is an old config files used to boot Yosemite on my laptop (still no success I get to grey screen and beachball, so I can't get to the Sierra installer)

I have attached a screen capture and mi EFI folder. What am I doing wrong? Hope somebody can help!
 

Attachments

  • 48392215_652478561849711_111522248929574912_n.jpg
    48392215_652478561849711_111522248929574912_n.jpg
    117.7 KB · Views: 36
  • CLOVER EFI.zip
    2.5 MB · Views: 37

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello I used to run El Capitan on my Probook HP 4530s, the hard drive simply failed and I have installed a brand new SSD.
So I am trying to install Sierra on my laptop.
I have created a USB 2.0 key with one partition EFI, and installed the installer on the other Mac HFS+ partition.
I have used this guide : https://www.tonymacx86.com/threads/...book-zbook-using-clover-uefi-hotpatch.261719/
And for the USB this: https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
I have used this config file renamed config.plist which I think is suitable for my system:
config_HD3000_1366x768

When I see the apple logo I then get a no entry sign straight away

I have used different config files the one that gets me the furthest is an old config files used to boot Yosemite on my laptop (still no success I get to grey screen and beachball, so I can't get to the Sierra installer)

I have attached a screen capture and mi EFI folder. What am I doing wrong? Hope somebody can help!

As mentioned in post #1, try OsxAptioFixDrv-64.efi instead of AptioMemoryFix-64.efi.
 
Top