Contribute
Register

[Guide] ASUS Zenbook UX305FA El Capitan with ACPI patching

Joined
Jul 24, 2016
Messages
23
Motherboard
Asus UX305FA
CPU
Intel Core M 5Y10
Graphics
Intel HD 5300, 1920x1080
Hi folks,

during the last days I tried to install OS X El Capitan to my ASUS Zenbook UX305FA. As I had major trouble with the hot patching method (from a different guide) I want to start a new thread, hoping that it's useful to somebody else as well.

This thread is based upon two previous threads, so credits to the people who started those threads (and RehabMan for his hints):

El capitan guide:
[Guide] ASUS ZENBOOK UX305FA for El Capitane
I obtained the drivers/kexts from this guide.

Yosemite guide:
[Guide] ASUS ZENBOOK UX305FA using Clover UEFI
I used the installation method from this guide.

This installation here was performed on:
ASUS Zenbook UX305FA, BIOS version 213
This BIOS should be the same globally for ever UX305FA, as I got it from the ASUS global download site.

Hardware details of this notebook:
Intel Core M 5Y10
Intel HD 5300
8 GB Ram
128 GB SSD (exchanged for a larger model)
FullHD (1920 x 1080)

The following steps are based upon the Yosemite guide linked above. This guide is separated into three sections (see respective headline).

Creating a bootable USB stick

First of all you have to create USB stick containing OS X El Capitan. This is done using another Mac or Hackintosh. RehabMan wrote a great guide for doing this: [Guide] Booting the OS X installer on LAPTOPS with CloverGuide.

Installing OS X to the notebook

Some BIOS settings have to be performed at first. To start the BIOS (here version 213) you have to press ESC at boot and form select the settings menu from the boot menu that is shown. In the BIOS you'll see several tabs:

Main:
no settings/modifications

Advanced:
Intel Virtualization Technology -> disable
VT-d -> disable
SATA Configuration:
SATA Mode Selection: AHCI
Graphics Configuration:
DVMT Pre-Allocation: 64M (128M didn't work for this guide)
Network Stack Configuration:
Network Stack -> disabled
USB Configuration:
Legacy USB Support -> enabled
XHCI Pre-Boot Mode -> enabled
USB Mass Storage Driver -> enabled

Boot:
Boot Configuration:
Launch CSM -> enabled
Boot Option Priorities:
select the USB stick, see next line
Add New Boot Option:
you might want to add your USB stick here

Security:
Secure Boot Mode:
Secure Boot Mode -> disabled

Save settings and reboot. Insert installation USB stick with El Capitan and press ESC during boot. Select the UEFI entry for your USB stick and boot from the OS X installtion entry. After a while you'll see the GUI for installing OS X. If you're asked to attach bluetooth keyboard or mice just click the space bar. Partition your disk as desired and start the installation. Installation will take approx. 15 min (even if the time displayed says something else).
The system will reboot by itself. Leave the USB stick in side the USB port. Perhaps - but not necessarily - you have to make the system boot form the USB stick again selecting it after pressing ESC during the ASUS logo is displayed. Boot again from the installation medium. The installation will continue by itself, this will take again approx. 15 min. The system will reboot by itself.
Boot again from the USB stick. Now you'll see an additional entry in the boot menu of Clover for the newly installed system. Select this entry and boot (this is the name you gave to the partition where you installed OS X onto). OS X will display the normal post installation process, like language selection and user creation.
This finishes the installation. But the system is not functional yet. You'll have to use the USB stick to boot and the hardware is not fully supported yet.

Postinstalltion steps for "fully functional" hardware

To get OS X to boot from the hard disk (SSD drive) you'll have to install Clover to the disk. You should select the following settings during Clover installation:

- select the OS X system partition as destination
Select "Custom Install" with the following settings:
- Install for UEFI booting only
- Install Clover in the ESP (will automatically select with the previous selection)
- Themes: one of your choice
- Drivers64UEFI: OsxAptioFixDrv-64
- Install RC scripts on target volume
- Install all RC scripts on all other bootable OSX vo...
- Install Clover Preference Pane

Now you've to copy some files to the Clover installation or UEFI partition. Therefore this partition has to be mounted (during Clover installation it might be automatically mounted). I use command line tools for this:

sudo su
cd /Volumes
mkdir EFI_disk
mount -t msdos /dev/disk_name_of_EFI_partition ./EFI_disk


Open Finder and go to the now mounted EFI partition: /Volumes/EFI_disk/EFI/CLOVER. You'll have to copy some files there:

HFSPlus.efi to .../EFI/CLOVER/drivers64UEFI/HFSPlus.efi
config.plist to .../EFI/CLOVER/config.plist
DSDT and SSDT files to .../EFI/CLOVER/ACPI/patched/
kexts to .../EFI/CLOVER/kexts/Other/

Those files are attached to this thread. You'll have to use different config.plist for the installed system, not the one you used to create the USB stick!

You might want to patch your own DSDT and SSDT files. I used MaciASL for patching and added two patch sources. Adding sources is done by MaciASL -> Preferences -> Sources (button)
Name: URL:
Debugger Patches -> htpp://raw.github.com/RehabMan/OS-X-ACPI-Debug/master
Laptop Patches -> http://raw.github.com/RehabMan/Laptop-DSDT-Patch/master

DSDT:
[sys] Fix _WAK Arg0 v2
[sys] HPET Fix
[sys] SMBUS Fix
[sys] IRQ Fix
[sys] RTC Fix
[sys] OS Check fix (Windows 8)
[sys] Fix Mutex with non-zero SyncLevel
[sys] Add IMEI
[sys] Fix ADBG Error
[igpu] Brightness Fix
[bat] ASUS N55SL/VivoBook
FnKeyPatch.zip manual patch from the Yosemite thread
[igpu] Rename GFX0 to IGPU (needs config.plist with dropOEM=true, and SSDT patches)
[usb] USB3 _PRW 0x0D (instant wake) or [usb] USB3 _PRW 0x6D (instant wake) (both worked for me)

Every SSDT is patched with:
[igu] Rename GFX0 to IGPU

SSDT-2 is patched with:
[syn] Remove _PSS placeholders

I use SSDT-0, SSDT-1, SSDT-2, SSDT-3, SSDT-7, SSDT-8, SSDT-9, SSDT-10, SSDT-11.

This gives me a system with:
- battery
- sleep
- sound (manual switching to headphones)
- FN keys
- brigthness setting

Hope this is helpful to others.

Have fun hacking!
 

Attachments

Joined
Jul 24, 2016
Messages
23
Motherboard
Asus UX305FA
CPU
Intel Core M 5Y10
Graphics
Intel HD 5300, 1920x1080
I just saw, that jhawk also offers an El Capitan package in his Asus UX305FA Yosemite thread. I had not seen this package before. So you could essentially just use his package also.

Stupid me! But better having one extra thread for El Capitan in the right forum.
 
Joined
Jul 31, 2012
Messages
28
Motherboard
Asus P8 Z68 -V
CPU
Intel i7 2600K
Graphics
Zotac GTX 570
Mobile Phone
Android, iOS
Thank you for your guide and files!
I have a good El Capitan installation but
- iCloud and iMessage doesn't work
- When I reach login screen at startup it seems that touchpad is not recognized well, I have to wait 5 sec more or less, is this right?
- I follow all the steps of this guide but I don't understand if now I have a cpu management or not
- Do you have working ALS? I don't see the option to activate the automatic light in display option
- What resolution do you use for the monitor?

Thank you for all and sorry for all these questions!
Francesco
 
Joined
Jul 24, 2016
Messages
23
Motherboard
Asus UX305FA
CPU
Intel Core M 5Y10
Graphics
Intel HD 5300, 1920x1080
Sorry have not checked this thread, as I wrote it more for documentational purpose. As this question is quite old I'll the answer is probably not to usefull anymore, but none the less:

- I don't use iCloud or iMesage, actually I used the Apple Autonomous System Number to block all Apple IPs in the firewall. I don't want to any unknow communication to their network.
- My touchpad works right out of the box.
- CPU works perfectly fine, including power states.
- I don't have ALS as well. I even didn't know that this laptop has this functionality, does it? I perfer using FN-keys for brightness anyways.
- I used to use 1920x1080, now it's most of the time set to 1600x900.
 
Joined
Jul 24, 2016
Messages
23
Motherboard
Asus UX305FA
CPU
Intel Core M 5Y10
Graphics
Intel HD 5300, 1920x1080
Applying the security update: SecUpd2018-001ElCapitan


I just installed the latest security update, SecUpd2018-001ElCapitan.dmg, and want to share my experience, as I ran into some trouble. Actually I consider this an very important update as this fixes serveral critical bugs:
- WLAN security fix for the KRACK attack (Key Reinstallation Attack)
- Meltdown CPU security bug
- Spectre CPU security bug

When applying updates you should always create a Time Machine backup first! I was very glad I did, as my system didn't boot anymore after applying the update. I received the following error message directly after reboot:

OsxAptioFixDrv: Starting overrides for System\Library\CoreServices\boot.efi
Using reloc block: yes, hibernate wake: no
++++++++++++++++++++++++++++++++++++++++++++


So here the Time Machine backup saved my day and the pervious working state was easily restored.

So what do you have to to do prevent the boot error?
It's very easy to fix. Actually the only thing you have to do is install a new version of Clover before applying the update. In my case it's been:

Clover_v2.4k_r4380

In Clover I applyed the following settings (I have to retranslate it to English, so it may sound a little different):
  • Installation for UEFI motherboards
  • Install Clover to ESP
  • Themes: choose what ever you want, I didn't choose any which. Thereby my previous BootCamp theme stayed. Only thing I did select was the "CloverThemeManager.app".
  • Drivers64UEFI: OsxAptioFixDrv-64
  • Install RC scripts on target volume
  • Install all RC scripts on all other boot volumes
  • Install Clover Preference Pane
Before applying the update you might want to reboot, to verify a working Clover installation.

Finally you can apply the security update: SecUpd2018-001ElCapitan.dmg.

After a reboot your system should now be up to date again.
 
Top