Contribute
Register

[Guide] Asus ZenBook UX303LA (Broadwell Edition)

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi guys. I've been following the thread for long time, read a lot and tried tons of times to make my laptop work as expected, but I haven't found how to fix some errors that appear even when compiling without applying any patch. Can someone give me a hand with this issue?

My computer is an Asus UX303LA-US51T (reported as UX303LAB under CPU-Z or AIDA) equipped with Intel Core i5 5200U Broadwell processor, Intel HD Graphics 5500, Intel wireless card (will replace it after getting OS X working), 3200x1800 touchscreen LED screen.

I'm getting these errors with patches or without:
7160, 6126, syntax error, unexpected PARSEOP_NAMESEG, expecting '('
7204, 6126, syntax error, unexpected PARSEOP_DEVICE, expecting $end and premature End-Of-File

I can't figure it out how to solve the problem. Already tried different versions of IASL or ACPI specs. The files extracted with Clover are attached and the decompiled ones.

Here's the decompiled DSDT lines that give errors:

Lines 7156 to 7170:
Method (_CRS, 0, NotSerialized) // _CRS: Current Resource Settings
{
Name (SBFI, ResourceTemplate ()
{
I2cSerialBusV2 (0x0060, ControllerInitiated, 0x00061A80,
AddressingMode7Bit, "\\_SB.PCI0.I2C0",
0x00, ResourceConsumer, , Exclusive,
)
Interrupt (ResourceConsumer, Level, ActiveLow, Exclusive, ,, )
{
0x0000001C,
}
})
Return (SBFI)
}

Lines 7204 to 7214:
Device (TPD9)
{
Method (_HID, 0, NotSerialized) // _HID: Hardware ID
{
If (And (SDS0, 0x10))
{
Return ("06CB2846")
}

Return ("SYNA2393")
}

Thank you very much!! And congrats on the amazing work done here.

Use refs.txt as per guide (your refs.txt is wrong/incomplete).
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
 
Joined
Jun 11, 2017
Messages
2
Motherboard
Asus UX303LAB BIOS 210
CPU
Intel Core i5 5200U (Broadwell-U)
Graphics
Intel HD Graphics 5500

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thank you for your kind help. I tried by following that guide and got a different result. I'm getting exactly the same two errors, but now they're on different lines. Any other ideas you can help me with?

Make sure you're using the correct version of iasl and MaciASL (and ACPI 6.1).
The correct tools are linked from the ACPI guide.
If you need help, provide details.
 
Joined
Apr 4, 2011
Messages
77
Motherboard
Dell 15 3568
CPU
Intel i5-7200U
Graphics
Intel HD 620
Mac
  1. iMac
Any positive feedback about the audio on Sierra? (Conexant CX20751/2)
I've tried AppleALC.kext with several layoutID (3,13,28) but I can't get it working.

Thanx
 
Joined
Jul 3, 2012
Messages
1
Motherboard
Dell 7548 Inspiron15
CPU
i5-5200u, chipset???
Graphics
HD5500, 1920x1080
Mac
  1. MacBook
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
First, download the "Patches.zip" in this post and extract it as a "Patches" folder on the desktop.

I'm a newbie trying out my first hackintosh with this post here. I can follow instruction verbatim pretty good, but I cannot find "Patches.zip" anywhere in this post (in post #1, this thread). I'm sure my question is a dumb one but it seems I cannot go on without it.
Please help...

Thank you.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm a newbie trying out my first hackintosh with this post here. I can follow instruction verbatim pretty good, but I cannot find "Patches.zip" anywhere in this post (in post #1, this thread). I'm sure my question is a dumb one but it seems I cannot go on without it.
Please help...

Thank you.

There is a Patches folder inside UX303LA.zip that is attached to post #1.
 
Joined
Aug 10, 2015
Messages
9
Motherboard
Zenbook UX303LA
CPU
Intel Core i5 4210U 1.7 GHz
Graphics
Intel HD 4400 mobile
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android

Hi again :) my "Zenbook to Hackintosh project" was lying around a long time because lack of time .. shame on me ..:)
So after all this time i tried again to get it done, but failed and now i am short before giving up. :banghead:

Ok what do i have .. i have OSX 10.11.2 booting from USB via Clover.
Yesterday i tried to get the wifi (DW1560) to run ..after reading toledos summary and finding some video on youtube .. it was working but only on 2.4 ghz(showing countrycode us) , then i found some more patches and after creating new kexts and installing it looked better - was even connecting on 5 ghz but was not usable (network access stuck). So i went back to the old kext files and now it is up again showing "US countrycode" but connected and is working.

So what is missing/not working:
1) No sound (although i patched everything as described in the feed)
2) No backlight (s.a.)
3) Functionkeys seems to work only partly ??
4) ACPI seems not to work (sleepmode..)
5) Still did not manage to understand how to move from clover USB boot - to my harddisc (also i want to install w10 parallel)

So frankly speaking now i am a bit stuck .. i was trying to understand which tools to use for all the different tasks ..
before i used iasl/MaciASl and Clover 2.3 ..
Now i also downloadeed KextBeast / DPCI Manager / MacKextLight ...

I am missing some compilation, answering the questions like:
1) What to do in general
2) Which Tools i need on which tasks
(i.e. if i have some textfile like arpt3-bcm4352_v3.0.txt - which tools to use for patching ?, how is this patching process)

Maybe someone can invest a bit time to point to the usefull feeds - because with just sending 1 link its mostly not done :confused:
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi again :) my "Zenbook to Hackintosh project" was lying around a long time because lack of time .. shame on me ..:)
So after all this time i tried again to get it done, but failed and now i am short before giving up. :banghead:

Ok what do i have .. i have OSX 10.11.2 booting from USB via Clover.
Yesterday i tried to get the wifi (DW1560) to run ..after reading toledos summary and finding some video on youtube .. it was working but only on 2.4 ghz(showing countrycode us) , then i found some more patches and after creating new kexts and installing it looked better - was even connecting on 5 ghz but was not usable (network access stuck). So i went back to the old kext files and now it is up again showing "US countrycode" but connected and is working.

So what is missing/not working:
1) No sound (although i patched everything as described in the feed)
2) No backlight (s.a.)
3) Functionkeys seems to work only partly ??
4) ACPI seems not to work (sleepmode..)
5) Still did not manage to understand how to move from clover USB boot - to my harddisc (also i want to install w10 parallel)

So frankly speaking now i am a bit stuck .. i was trying to understand which tools to use for all the different tasks ..
before i used iasl/MaciASl and Clover 2.3 ..
Now i also downloadeed KextBeast / DPCI Manager / MacKextLight ...

I am missing some compilation, answering the questions like:
1) What to do in general
2) Which Tools i need on which tasks
(i.e. if i have some textfile like arpt3-bcm4352_v3.0.txt - which tools to use for patching ?, how is this patching process)

Maybe someone can invest a bit time to point to the usefull feeds - because with just sending 1 link its mostly not done :confused:

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Aug 10, 2015
Messages
9
Motherboard
Zenbook UX303LA
CPU
Intel Core i5 4210U 1.7 GHz
Graphics
Intel HD 4400 mobile
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the tool mentioned in the FAQ, that way it is less likely you'll omit something.

OK thank you .. so hopefully i could create all what is needed, i included the efi folder but took it directly from the partition (F2/F4) did not work for me ..

Thank your for investigations :thumbup:
 

Attachments

  • Errorlogs.zip
    3.5 MB · Views: 63
Top