Contribute
Register

[Guide] Asus ROG G551/552, GL551/552 Series (Skylake, i7-6700HQ, HD 530) Using Clover UEFI

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Please let me know if I am doing this right. I was able to get all the way to Step G in the guide.

To boot this laptop into OSX I need to use the USB created (boot into clover). So when I use F4 to extract the DSDT and SSDT files, they get placed on the USB's origin folder(USB/EFI/CLOVER/ACPI/origin). Then I extract and patch as per post#1. Then I place the patched aml files in the Internal System patched folder(SYSTEM/EFI/CLOVER/ACPI/patched). Is that the right way to do this?

My Hard drive has both Windows 10 and OSX El Capitan on it. I feel like I may be getting the wrong DSDT and SSDT files since they end up on the USB's origin folder and not on the Internal HD's origin folder.

ACPI patching guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
 
Joined
Aug 16, 2017
Messages
10
Motherboard
ASUS GL552VW-DH71 (Clover)
CPU
i7-6700HQ
Graphics
HD 530/GTX 960M (1920x1080)

I found the issue. My patching was good. Problem was I was still booting from the USB. You need to install the Clover bootloader on the system and boot with that. Installing Clover bootloader and getting the laptop to boot from it right away (not via USB) should be part of the instructions.

Even the patching guide does not really state this. Probably no issue when the hard drive is only for mac. Issue comes up when the initial partition is windows.

Have a great one!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I found the issue. My patching was good. Problem was I was still booting from the USB. You need to install the Clover bootloader on the system and boot with that. Installing Clover bootloader and getting the laptop to boot from it right away (not via USB) should be part of the instructions.

The guide in post #1 uses Multibeast, which installs Clover in section E.

Even the patching guide does not really state this.

My ACPI patching guide assumes you followed the laptop Clover guide.
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Probably no issue when the hard drive is only for mac. Issue comes up when the initial partition is windows.

Important dual boot information is in post #2 of the laptop Clover guide (linked above).
You should definitely read it.
 
Joined
Aug 16, 2017
Messages
10
Motherboard
ASUS GL552VW-DH71 (Clover)
CPU
i7-6700HQ
Graphics
HD 530/GTX 960M (1920x1080)
I got mostly everything working on El Capitan. I used Mirone's AppleHDAPatcher to get the speakers working but I have no microphone working. Internal or (plugged in) external. Anyone get these to work? (VoodooHDA gets everything to work but it is analog and the sound quality isnt good).

Also is it possible to get the "Nvidia 960M" graphics card working on our Rogs 552VW with the Nvidia web drivers? I know the Web drivers say they support the 960 but not sure if they support the mobile 960M version.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I got mostly everything working on El Capitan. I used Mirone's AppleHDAPatcher to get the speakers working but I have no microphone working. Internal or (plugged in) external.

Problem is in the patched AppleHDA XML (layout, pathmaps, pinconfigs) that you're using.

Also is it possible to get the "Nvidia 960M" graphics card working on our Rogs 552VW with the Nvidia web drivers? I know the Web drivers say they support the 960 but not sure if they support the mobile 960M version.

Nvidia in Optimus configuration not supported.
Details in FAQ.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Aug 16, 2017
Messages
10
Motherboard
ASUS GL552VW-DH71 (Clover)
CPU
i7-6700HQ
Graphics
HD 530/GTX 960M (1920x1080)
Yes, it does, but they use El Capitan instead of Sierra, so I would like to know if anyone has tried to follow it in order to install Sierra.
I have tried but failed, and I don't know if I did anything wrong, or if it's just that this guide only works with El Capitan, that's why I'm asking
Did you ever get Sierra working? I tried a direct upgrade and I tried following this guide using the newer Unibeast. Cannot get the initial installer to boot up. Maybe you had better luck.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Did you ever get Sierra working? I tried a direct upgrade and I tried following this guide using the newer Unibeast. Cannot get the initial installer to boot up. Maybe you had better luck.

Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Although you should read the FAQ for an overview of issues, the Clover guide is linked from the first question: "Q. Where do I start?", just after the bold face "Clover Guide".
Here is a direct link, just to be clear:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also, your profile must be filled out with complete details as requested in the FAQ, again under "Q. Where do I start?". All seven details requested are equally important.

And if you have an issue (after following the guide), or on any other problem, you must provide a detailed description of the problem including information that helps us understand what you're doing. Always attach "Problem Reporting" files as per FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
The required files and data are fully detailed in the last question in the FAQ:
"Q. What are typical "Problem Reporting" files?"
 
Joined
Dec 27, 2017
Messages
1
Motherboard
ASUS GL552VW Intel HM170 (Skylake PCH-H)
CPU
Intel Core i5-6300HQ
Graphics
Intel HD Graphics 530 (Skylake-H GT2) + NVIDIA GeForce GTX 960M
Will it work with a Gl552 with i5-6300HQ?
 
Joined
Jan 15, 2014
Messages
5
Motherboard
Y540
CPU
i7-9750H
Graphics
Intel HD630 + Nvidia RTX2060 (1920x1080)
Mobile Phone
  1. Android
Hello,

First time hackintoshing, and I need help.

I followed the guide exactly (also read the guides and tips) and everything worked fine, installing, ACPI patching and all, but now I have a problem.

USB 3.0 drives are not recognised and do not connect at all. 2.0 drives work fine. It just shows me a message that device needs power. Any suggestions?
 
Last edited:
Top