Contribute
Register

[Guide] ASRock Fatal1ty Z370 Gaming-ITX/ac (UHD 630)

ammulder

Moderator
Joined
Sep 1, 2014
Messages
3,468
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
I wanted to keep my old High Sierra install just in case, so I put in a new drive and did a fresh install and then restored my user data with the Migration Assistant.

Hardware:
  • ASRock Fatal1ty Z370 Gaming-ITX/ac
  • i7-8700 (not K; I have a small case with a small CPU cooler and prefer the 65W chip)
  • Sapphire Pulse RX 580 8192 MB (with two fans, about all that can fit in the case) I ended up taking this card out, and got the machine working with integrated graphics
  • Samsung 970 Evo m.2 NVMe
  • Some working Broadcom Wireless mini card -- frankly I don't remember the model, but it might have been one of these. It was frightfully difficult to replace the Intel card that the board shipped with due to the odd enclosure and very fragile connectors on those cards. I busted one of the antenna mounts off the Intel card, and couldn't get the mount out of the cable end without breaking that too and had to replace it with one I had lying around. While the wireless now works is macOS, I don't recommend this unless you have a pretty delicate touch and some spare parts just in case.
  • An Acer 43" 4K monitor (ET430K). To avoid the black-screen-with-HDMI problem, I'm using a DisplayPort connection, though there are troubleshooting directions here if you prefer HDMI.
Install:

I could not get the 10.14.2 install to work with a default UniBeast install drive -- I had to customize config.plist, kexts, and etc. to avoid reboots and hangs during installation and the first boot. So I've ended up with a boot drive that looks a lot like the installed system. But it works.
  1. Back up old data (with Time Machine, SuperDuper, whatever)
    1. Since I was doing a clean install and copying data over, I deauthorized iTunes and signed out of iCloud and iMessage from my old High Sierra install
  2. Create a USB drive with UniBeast 9 as described here. NOTE: if reusing an old USB install drive, make sure to clear off the EFI partition. If erasing in Disk Utility, make sure you erase the whole USB drive not just the existing partition. If using Disk Utility in Mojave on another machine, use View / Show All Devices in order to be able to do that.
    1. After the UniBeast drive is done, run RehabMan's Clover package (I used v4701), making sure to select the USB drive as the destination. Customize to install for UEFI booting only, and under UEFI drivers add EmuVariableUefi-64
    2. After upgrading Clover, your EFI partition should still be mounted; check whether HFSPlus.efi is in EFI/CLOVER/drivers64UEFI -- if not, get it and put it there.
    3. You can remove all the kexts from EFI/CLOVER/kexts/Other. Then put in these kexts (this will get current versions):
    4. Get Clover Configurator and the attached config.plist (should work with 8xxx or 9xxx CPUs). Open the config.plist with Clover Configurator.
      1. Go to the SMBIOS screen, and hit Generate New under the Serial Number and under the SMUUID.
      2. Hit the Check Coverage button to the right. Enter the CAPTCHA on the Web page that comes up and ensure that it says the serial number is invalid (NOTE: you WANT it to be invalid -- as in, not used by a real Mac! If it shows machine data go back to Clover Configurator and hit the Generate New buttons again and then Check Coverage again).
      3. If you know what your system drive will be named, go to the Boot screen and enter the name over Default Boot Volume
      4. Save the file
    5. Copy the config.plist customized above to EFI/CLOVER/config.plist on the USB drive
    6. If installing from a USB3 drive, copy aaron-usb-config.aml (download and unzip the attachment below) to EFI/CLOVER/ACPI/patched/ which will enable all the USB3 ports on the board EXCEPT the one to the right of the HDMI port. If installing from a USB2 drive it should work anywhere.
  3. Boot to the install drive.
    • It's easy if it's the only bootable device. If not, I don't have luck with the F11 boot list; I instead go into the BIOS and rearrange the boot list to put the USB on top and then save and exit.
    • Once booted, it takes a while to get to the initial install screen.
  4. If needed, run Disk Utility from there to clear off the target partition (or initialize the drive, if it's new).
  5. Proceed with the Mojave installer
  6. It rebooted at least twice for me.
    • It ran an initial progress bar until it said "2 minutes remaining" and then suddenly rebooted
    • On reboot, select to boot to the system drive from the Clover menu
    • It took a long time to come up to a GUI here, then showed a progress bar with no progress completed and "13 minutes remaining", then rebooted
    • Select to boot to the system drive again. This time after the long wait it came up to the progress bar ad immediately completed a small fraction ("12 minutes remaining") and then did the rest of the install.
    • It got to a 10-second countdown to reboot with a "reboot now" button, but there was no mouse pointer or anything so I just waited it out.
  7. At this point I could get into Mojave with working Ethernet by booting off the UniBeast drive. I did the user migration here, though you can do it later (if you plan to do it later, I recommend not creating a first user account with the same name during the installation)
Post-Install Configuration:
  1. Using the same Clover installer you used for the flash drive, install Clover to the system drive. Select the same options as before, but this time also check Install RC scripts on target volume.
    • It again leaves the EFI partition (on the system drive) mounted.
  2. Also mount the EFI partition from the flash drive. I identify the EFI partition from Terminal with "diskutil list" and mount it with "sudo diskutil mount /dev/diskNs1" where diskN is the identifier for the USB drive, as shown by "diskutil list". After that a second "EFI" shows up in the Finder sidebar. The one with the eject symbol and the same icon as "Install macOS Mojave" is the flash drive, the other is the system drive.
  3. Replace the config.plist that Clover generated on the system drive with the one from the flash drive.
  4. Copy the kexts IntelMausiEthernet, FakeSMC, Lilu, WhateverGreen, and USBInjectAll from the flash drive EFI/CLOVER/kexts/Other to the system drive EFI/CLOVER/kexts/Other
  5. Add the AppleALC kext to that directory on the system drive for audio support
  6. If you did the wireless swap, also add the AirportBrcmFixup kext to that directory on the system drive
  7. Eject the USB flash drive and Reboot
  8. You should boot into Mojave successfully, with Audio working (and Wireless as well, if you did that)
iMessage Configuration:
  1. This should be pretty much working already. I set the name of my machine under System Preferences / Sharing before activating anything.
  2. If you have any questions, follow the iMessage guide. It never hurts to run the iMessageDebugv2 provided in that guide, save the result, reboot, run it again, and compare to make sure all the values are the same.
  3. After confirming that the iMessageDebugv2 output does not change across reboots, sign into iCloud and iMessage.
After that, things seem to be working in Mojave. Yay! :)

Addeddum: USB Support

I did not get the port-limit patch working in 10.14.2.

This board has a total of 8 USB3 ports (which also count as 8 USB2 ports) plus 2 USB2-only case ports and a USB2-only port for the internal Bluetooth... for a total of 19.

To keep this under the 15-port limit, I chose to disable the case USB2 ports (since I'm using the USB3 ones anyway) and the back USB port to the right of the HDMI port (I just taped over it to remind myself). The attached aaron-usb-config.aml uses this configuration. If you want a different USB configuration, you'll need to generate your own AML for it using RehabMan's procedure.
 

Attachments

Last edited:

ammulder

Moderator
Joined
Sep 1, 2014
Messages
3,468
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Is the Intel® Thunderbolt™ 3 (USB 3.1 Gen 2 and USB-C Display) working in Mojave
I'm not sure how to test that. I'm using the Radeon graphics, so I assume the TB3 graphics wouldn't work. I think the only TB3 device I have is a video adapter. I have some meant-for-a-laptop USB-C dongles I could try with USB2 and Ethernet ports -- would that tell you what you want to know?

Dual monitor works?
I haven't tested that either (I just use a big 4K TV), though I can find another monitor to connect at some point and see.

Finally, FWIW, I had problems with intermittent crashing so I swapped back to my 10.13 drive for now. I'm planning to swap back when 10.14.1 comes out and see if that makes any difference.
 

ammulder

Moderator
Joined
Sep 1, 2014
Messages
3,468
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Another follow-up: I got a USB-C adapter for a 2.5" SSD and tried it under High Sierra. It did not work when hot-plugged (lit up but drive was not accessible), but worked when plugged in at boot. I'll try it again when I'm back in Mojave.
 
Joined
Sep 8, 2011
Messages
49
Motherboard
Asus Rampage VI Extreme
CPU
i9-7960X
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
I´m interested in similar config to create a DAS over Thunderbolt 3... did you try if it work?
 
Joined
Dec 22, 2018
Messages
18
Motherboard
ASRock Fatal1ty Z370 Gaming-ITX/ac
CPU
i5-8500T
Graphics
UHD 630
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
@ammulder:

I have the almost configuration:
  • ASRock Fatal1ty Z370 Gaming-ITX/ac
  • i5-8500T with using internal GPU
  • Samsung 970 Evo m.2 NVMe
  • 16GB RAM
Prepared the USB stick exactly from your description above with UniBeast 9.0.0. Clover will boot into the Install screen but if I then try to boot into the Mojave Installer the System will freeze/ not booting forward.
IMG-0515.JPG

IMG-0514.JPG

I also tool a screenshot from starting by verbose mode, but I have no idea where to look for.
IMG-0516.JPG

Do you have any idea what may cause the freeze?
 

ammulder

Moderator
Joined
Sep 1, 2014
Messages
3,468
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Most likely it is a USB problem. If you do a regular verbose boot and wait a while, see if it goes to the "prohibited" sign, and try to see if the text at the very bottom of the screen says something like "Still waiting on root device". Often the text gets garbled, but you might be able to make out whether that's the message.

Another clue to a USB problem is if the scrolling text at some point says something along the lines of "too many USB devices, not creating the remaining ones".

If that's the problem, you'd be able to complete the installation from a USB 2 thumb drive but not a USB 3 one.

Normally UniBeast creates an installation with the correct settings to avoid this, except they keep changing, so UniBeast might be putting the wrong patch in config.plist on the thumb drive if you're using a newer release of macOS than the one at the time it was built. Here's one for 10.14.1 that I think might work for 10.14.2 as well (this post also has the older 10.14.0 one, so you could verify if that's what's in your config.plist):

https://www.tonymacx86.com/threads/solved-mojave-10-14-1-update-lost-usb-3-0.264125/
 
Joined
Dec 22, 2018
Messages
18
Motherboard
ASRock Fatal1ty Z370 Gaming-ITX/ac
CPU
i5-8500T
Graphics
UHD 630
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Thanks for the super quick answer. I have only USB2 Sticks where I installed Clover with Mojave 10.14.1.
Is there any way to stop the log scree in verbose mode as its scrolling so fast down.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,679
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
@Snowpro, please update your profile (personal details) with your Motherboard, CPU and iGPU or Graphics Card(s).
If you have a prebuilt computer enter make and model instead of motherboard.
The Rules said:
Profiles are mandatory so that others can assist you.
Try at Clover Boot Screen to select Options > PCI devices > USB Ownership and USB Injection

For permanent solution check Inject USB + FixOwnership in Clover's config.plist
Code:
  <key>USB</key>
        <dict>
            <key>FixOwnership</key>
            <true/>
            <key>Inject</key>
            <true/>
        </dict>
 
Top