Contribute
Register

(Guide) All New ATI Radeon 5450 Clover Hotpatch Injection

Joined
Jun 9, 2013
Messages
10,809
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
So I decided to move the DSDT injection over to a SSDT to go along with Clover Hotpatch. This is experimental although it works on my old Core 2 Quad System. In order to get this to work you're ATI 5450 will need to be under GFX0 instead of PEGP or IOPP. You will need Clover Bootloader for this to work. No need for (inject ATIi/True) in config.plist.

Old Guide. [Guide] Enabling ATI Radeon HD 5450

First thing you will need to do is rename PEGP to GFX0. Add patch under ACPI, DSDT, Patches use Xcode or a Plist editor not Clover Configurator as it will destroy the config.plist.

Code:
Change PEGP to GFX0
Find <50454750>
Replace <47465830>
You will also need to add,
Code:
Change _DSM to XDSM
Find <5f44534d>
Replace <5844534d>
Without Change _DSM to XDSM SSDT injection will not work neither will it work without Graphics coming under GFX0.

To Fix Graphics coming under IOPP add FixDisplay_0100/Yes to the config under ACPI, DSDT, Fixes.

Now for the SSDT Injection, Add to MacIASL as a template save it as SSDT-GFX0.aml. (Use Rehabmans version) RehabMan / OS-X-MaciASL-patchmatic / Downloads — Bitbucket

Code:
DefinitionBlock ("", "SSDT", 2, "hack", "GFX0_HDA", 0x00000000)
{
    External (_SB_.PCI0.GFX0, DeviceObj)    // (from opcode)
    External (_SB_.PCI0.PEG0.GFX0, DeviceObj)    // (from opcode)
    External (GFX0, DeviceObj)    // (from opcode)

    Scope (_SB.PCI0.PEG0.GFX0)
    {
        Scope (GFX0)
        {
            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LNot (Arg2))
                {
                    Return (Buffer (One)
                    {
                         0x03                                          
                    })
                }

                Return (Package ()
                {
                    "device-id",
                    Buffer ()
                    {
                         0xE0, 0x68, 0x00, 0x00                        
                    },

                    "ATY,DeviceID",
                    Buffer (0x04)
                    {
                         0xE0, 0x68, 0x00, 0x00                        
                    },

                    "vendor-id",
                    Buffer ()
                    {
                         0x02, 0x10, 0x00, 0x00                        
                    },

                    "ATY,VendorID",
                    Buffer ()
                    {
                         0x02, 0x10, 0x00, 0x00                        
                    },

                    "AAPL,slot-name",
                    Buffer ()
                    {
                        "Slot-1"
                    },

                    "@0,AAPL,boot-display",
                    Buffer ()
                    {
                         0x00, 0x08, 0x00, 0x00                        
                    },

                    "hda-gfx",
                    Buffer ()
                    {
                        "onboard-2"
                    }
                })
            }
        }

        Device (HDAU)
        {
            Name (_ADR, One)  // _ADR: Address
            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LNot (Arg2))
                {
                    Return (Buffer (One)
                    {
                         0x03                                          
                    })
                }

                Return (Package ()
                {
                    "hda-gfx",
                    Buffer ()
                    {
                        "onboard-2"
                    }
                })
            }
        }
    }
}
After following this guide your ATI 5450 should be working.

Problem reporting.

Post ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Also, press F4 at the main Clover screen, then compress and attach the EFI/CLOVER folder in use. And please, in order to reduce the size, omit EFI/Clover/themes.
 
Last edited:
Joined
Mar 16, 2012
Messages
46
Motherboard
GA-X58A-UD3R rev 2.0
CPU
Xeon X5670@4.46GHz
Graphics
GeForce GTX 760
Mac
Mac Pro
Hello VioletDragon, I tried best to follow but it doesn't work still. It simply gives me "3 MB Display".... Here enclosed ioreg & clover folder. Thanks for helping.

My hackintosh build spec:
P5K-E/WIFI-AP
Xeon L5408
HD5450 512MB
 

Attachments

Last edited:
Joined
Jun 9, 2013
Messages
10,809
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
Hello VioletDragon, I tried best to follow but it doesn't work still. It simply gives me "3 MB Display".... Here enclosed ioreg & clover folder. Thanks for helping.

My hackintosh build spec:
P5K-E/WIFI-AP
Xeon L5408
HD5450 512MB
You are using a DSDT. Just add ATY edits to DSDT. I wouldn't recommend using a DSDT with Clover Hotpatch. It's either one or the other.
 
Joined
Sep 13, 2017
Messages
2
Motherboard
Intel® Q87 (Optiplex 9020 SFF)
CPU
I5-4570
Graphics
ATI Radeon HD 5450

Attachments

Last edited:
Joined
Sep 13, 2017
Messages
2
Motherboard
Intel® Q87 (Optiplex 9020 SFF)
CPU
I5-4570
Graphics
ATI Radeon HD 5450

Attachments

Joined
Jun 9, 2013
Messages
10,809
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
Update : I was able to make the ATI Radeon HD 5450 work but the display is flickering from normal color to bluish color.
And the USB 3.0 still does not work.
ATI 5450 works fine with SSDT injection? Its experimental. USB 3 is off-topic.
 
Joined
Jun 9, 2013
Messages
10,809
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
Joined
Oct 20, 2017
Messages
2
Motherboard
HP Elite 410it
CPU
i5-750
Graphics
8800GT
Mac
MacBook Pro
Mobile Phone
Android
Hi, I'm to the forum and to Hackintosh. I'm trying to get working my HD5450 under El Capitan on my older i3-550 based system. It's a custom motherboard from HP.
I tried faking the ID of the card and dumping and editing the DSDT, but I'm still stuck to an unidentified card.
From the DSDT, I saw that the card is under the P0P1 method, and there's no PEGP: how can I edit the file in order to patch the SSDT table?
 
Joined
Jun 9, 2013
Messages
10,809
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
Hi, I'm to the forum and to Hackintosh. I'm trying to get working my HD5450 under El Capitan on my older i3-550 based system. It's a custom motherboard from HP.
I tried faking the ID of the card and dumping and editing the DSDT, but I'm still stuck to an unidentified card.
From the DSDT, I saw that the card is under the P0P1 method, and there's no PEGP: how can I edit the file in order to patch the SSDT table?
Read Post #1. Need Problem Reporting Files.
 
Top