Contribute
Register

[Guide] Airport - PCIe Half Mini v2

Status
Not open for further replies.

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,879
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@RehabMan,

Hi RM, i think i got an issue with my AW123Ch ... bluetooth works fine, 5GH wifi works fine connecting to my AC router at 867Bps ...


Software Versions:
CoreWLAN: 11.0 (1101.20)
CoreWLANKit: 11.0 (1101.20)
Menu Extra: 11.0 (1121.34.2)
System Information: 12.0 (1100.2)
IO80211 Family: 11.1 (1110.26)
Diagnostics: 5.1 (510.88)
AirPort Utility: 6.3.6 (636.5)
Interfaces:

en1:
Card Type: AirPort Extreme (0x14E4, 0x2123)
Firmware Version: Broadcom BCM43xx 1.0 (7.21.95.175.1a6)
MAC Address: 6c:71:d9:46:b5:5c
Locale: FCC
Country Code: US
Supported PHY Modes: 802.11 a/b/g/n/ac
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 144, 149, 153, 157, 161, 165
Wake On Wireless: Supported
AirDrop: Supported, Channel 149
Status: Connected
Current Network Information:

CMMP-5G:
PHY Mode: 802.11ac
BSSID: e0:3f:49:f1:6a:dc
Channel: 52
Country Code: US
Network Type: Infrastructure
Security: WPA2 Personal
Signal / Noise: -53 dBm / -89 dBm
Transmit Rate: 867 <-----------------------
MCS Index: 9


But after a disconnect and reconnect it will only connect at 300bps.

Software Versions:

CoreWLAN: 11.0 (1101.20)
CoreWLANKit: 11.0 (1101.20)
Menu Extra: 11.0 (1121.34.2)
System Information: 12.0 (1100.2)
IO80211 Family: 11.1 (1110.26)
Diagnostics: 5.1 (510.88)
AirPort Utility: 6.3.6 (636.5)
Interfaces:

en1:
Card Type: AirPort Extreme (0x14E4, 0x2123)
Firmware Version: Broadcom BCM43xx 1.0 (7.21.95.175.1a6)
MAC Address: 6c:71:d9:46:b5:5c
Locale: FCC
Country Code: US
Supported PHY Modes: 802.11 a/b/g/n/ac
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165
Wake On Wireless: Supported
AirDrop: Supported, Channel 149
Status: Connected
Current Network Information:

CMMP-5G:
PHY Mode: 802.11ac
BSSID: e0:3f:49:f1:6a:dc
Channel: 52,1
Country Code: US
Network Type: Infrastructure
Security: WPA2 Personal
Signal / Noise: -54 dBm / -93 dBm
Transmit Rate: 300 <--------------------------- ?????????
MCS Index: 7


Above was triggered via turning wifi off and back on but any form of sleep/wake will also produce the same result. It does it with out fail every time, the only way to get system to reconnect at 867bps is to reboot or live with 300 bps.

Wake for network access unchecked in energy saver ..

I using your latest fork of BrcmPatchRAM (BrcmPatchRAM2.kext & BrcmFirmwareRepo.kext both in /S/L/E) and your fakepci kexts ( FakePCIID.kext & FakePCIID_Broadcom_WiFi.kext also in /S/L/E ) all other patches applied by clover, all works (wifi & BT) except for this issue of 5G WiFi reconnecting at 300bps after first disconnect. I think the issue may be the firmware that my AW123CH is using. 2.4Ghz wifi is unaffected and always connects at 145bps.

As you can see from above Sys info dumps firmware is Broadcom BCM43xx 1.0 (7.21.95.175.1a6) which i think is quite old, i believe that most hacks are now using version Broadcom BCM43xx 1.0 (7.21.149.34.1a7) or later ....

I think something odd is going on with BrcmPatchRAM during boot/kext load ...

cat /var/log/system.log | grep -i brcm[fp] produces following from log file ....

Sep 29 16:22:32 localhost kernel[0]: BrcmPatchRAM2: Version 2.2.7 starting on OS X Darwin 15.6.
Sep 29 16:22:32 localhost kernel[0]: BrcmPatchRAM2: Published new IOKit personality for BrcmFirmwareStore.
Sep 29 16:22:32 localhost kernel[0]: BrcmPatchRAM2: Published new IOKit personality for BrcmPatchRAMResidency.
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM: Loaded firmware "BCM20702A1_001.002.014.1443.1479_v5575.zhx" from resources.
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM: Decompressed firmware (29713 bytes --> 70105 bytes).
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM: Firmware is valid IntelHex firmware.
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM2: [13d3:3404]: USB [6C71D949489A v274] "BCM20702A0" by "Broadcom Corp"
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: readCompletion - Unknown error (0xe00002bc)
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Firmware upgrade failed.
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Published new IOKit personality.
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: Processing time 6.421 seconds.
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: Version 2.2.7 starting on OS X Darwin 15.6.
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: USB [6C71D949489A v274] "BCM20702A0" by "Broadcom Corp"
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Firmware upgrade completed successfully.
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Found existing IOKit personality "com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport".
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: Processing time 0.519 seconds.
MacBook-Pro:~ Jay$

Not sure if this indicates an issue or not as at first it fails but then says it's successful ?
Any thoughts or suggestions much appreciated ?
IO Reg attached ....

Cheers
Jay
 

Attachments

  • Jay_MacBook Pro.ioreg.zip
    474.1 KB · Views: 82

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,306
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@RehabMan,

Hi RM, i think i got an issue with my AW123Ch ... bluetooth works fine, 5GH wifi works fine connecting to my AC router at 867Bps ...


Software Versions:
CoreWLAN: 11.0 (1101.20)
CoreWLANKit: 11.0 (1101.20)
Menu Extra: 11.0 (1121.34.2)
System Information: 12.0 (1100.2)
IO80211 Family: 11.1 (1110.26)
Diagnostics: 5.1 (510.88)
AirPort Utility: 6.3.6 (636.5)
Interfaces:

en1:
Card Type: AirPort Extreme (0x14E4, 0x2123)
Firmware Version: Broadcom BCM43xx 1.0 (7.21.95.175.1a6)
MAC Address: 6c:71:d9:46:b5:5c
Locale: FCC
Country Code: US
Supported PHY Modes: 802.11 a/b/g/n/ac
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 144, 149, 153, 157, 161, 165
Wake On Wireless: Supported
AirDrop: Supported, Channel 149
Status: Connected
Current Network Information:

CMMP-5G:
PHY Mode: 802.11ac
BSSID: e0:3f:49:f1:6a:dc
Channel: 52
Country Code: US
Network Type: Infrastructure
Security: WPA2 Personal
Signal / Noise: -53 dBm / -89 dBm
Transmit Rate: 867 <-----------------------
MCS Index: 9


But after a disconnect and reconnect it will only connect at 300bps.

Software Versions:

CoreWLAN: 11.0 (1101.20)
CoreWLANKit: 11.0 (1101.20)
Menu Extra: 11.0 (1121.34.2)
System Information: 12.0 (1100.2)
IO80211 Family: 11.1 (1110.26)
Diagnostics: 5.1 (510.88)
AirPort Utility: 6.3.6 (636.5)
Interfaces:

en1:
Card Type: AirPort Extreme (0x14E4, 0x2123)
Firmware Version: Broadcom BCM43xx 1.0 (7.21.95.175.1a6)
MAC Address: 6c:71:d9:46:b5:5c
Locale: FCC
Country Code: US
Supported PHY Modes: 802.11 a/b/g/n/ac
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165
Wake On Wireless: Supported
AirDrop: Supported, Channel 149
Status: Connected
Current Network Information:

CMMP-5G:
PHY Mode: 802.11ac
BSSID: e0:3f:49:f1:6a:dc
Channel: 52,1
Country Code: US
Network Type: Infrastructure
Security: WPA2 Personal
Signal / Noise: -54 dBm / -93 dBm
Transmit Rate: 300 <--------------------------- ?????????
MCS Index: 7


Above was triggered via turning wifi off and back on but any form of sleep/wake will also produce the same result. It does it with out fail every time, the only way to get system to reconnect at 867bps is to reboot or live with 300 bps.

Wake for network access unchecked in energy saver ..

I using your latest fork of BrcmPatchRAM (BrcmPatchRAM2.kext & BrcmFirmwareRepo.kext both in /S/L/E) and your fakepci kexts ( FakePCIID.kext & FakePCIID_Broadcom_WiFi.kext also in /S/L/E ) all other patches applied by clover, all works (wifi & BT) except for this issue of 5G WiFi reconnecting at 300bps after first disconnect. I think the issue may be the firmware that my AW123CH is using. 2.4Ghz wifi is unaffected and always connects at 145bps.

As you can see from above Sys info dumps firmware is Broadcom BCM43xx 1.0 (7.21.95.175.1a6) which i think is quite old, i believe that most hacks are now using version Broadcom BCM43xx 1.0 (7.21.149.34.1a7) or later ....

I think something odd is going on with BrcmPatchRAM during boot/kext load ...

cat /var/log/system.log | grep -i brcm[fp] produces following from log file ....

Sep 29 16:22:32 localhost kernel[0]: BrcmPatchRAM2: Version 2.2.7 starting on OS X Darwin 15.6.
Sep 29 16:22:32 localhost kernel[0]: BrcmPatchRAM2: Published new IOKit personality for BrcmFirmwareStore.
Sep 29 16:22:32 localhost kernel[0]: BrcmPatchRAM2: Published new IOKit personality for BrcmPatchRAMResidency.
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM: Loaded firmware "BCM20702A1_001.002.014.1443.1479_v5575.zhx" from resources.
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM: Decompressed firmware (29713 bytes --> 70105 bytes).
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM: Firmware is valid IntelHex firmware.
Sep 29 16:22:34 localhost kernel[0]: BrcmPatchRAM2: [13d3:3404]: USB [6C71D949489A v274] "BCM20702A0" by "Broadcom Corp"
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: readCompletion - Unknown error (0xe00002bc)
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Firmware upgrade failed.
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Published new IOKit personality.
Sep 29 16:22:39 MacBook-Pro kernel[0]: BrcmPatchRAM2: Processing time 6.421 seconds.
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: Version 2.2.7 starting on OS X Darwin 15.6.
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: USB [6C71D949489A v274] "BCM20702A0" by "Broadcom Corp"
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Firmware upgrade completed successfully.
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: [13d3:3404]: Found existing IOKit personality "com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport".
Sep 29 16:22:40 MacBook-Pro kernel[0]: BrcmPatchRAM2: Processing time 0.519 seconds.
MacBook-Pro:~ Jay$

Not sure if this indicates an issue or not as at first it fails but then says it's successful ?
Any thoughts or suggestions much appreciated ?
IO Reg attached ....

Cheers
Jay

Open a separate thread in the appropriate laptop forum.

Provide all details...

Attach ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Provide output (in Terminal):
Code:
kextstat|grep -y acpiplat
kextstat|grep -y appleintelcpu
kextstat|grep -y applelpc
kextstat|grep -y applehda

Attach EFI/Clover folder as ZIP (press F4 at main Clover screen before collecting). Please eliminate 'themes' directory. Provide only EFI/Clover, not the entire EFI folder.

Attach output of (in Terminal):
Code:
sudo touch /System/Library/Extensions && sudo kextcache -u /

Compress all files as ZIP. Do not use external links. Attach all files using site attachments only.
 
Joined
Jul 23, 2014
Messages
30
Mac
Classic Mac
Mobile Phone
So my wifi is working, and while it initially appeared that my bluetooth was working, it seems it is no longer. At first, bt devices seem to pair, but then almost immediately they lose connection. On my Iphone I get the following "CONNECTION UNSUCCESSFUL IMAC IS NOT SUPPORTED" on occassion.

I have an ASUS Z97i Plus.

I installed the following kexts:
  1. BrcmFirmwareRepo.kext
  2. BrcmPatchRAM2.kext
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,306
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
So my wifi is working, and while it initially appeared that my bluetooth was working, it seems it is no longer. At first, bt devices seem to pair, but then almost immediately they lose connection. On my Iphone I get the following "CONNECTION UNSUCCESSFUL IMAC IS NOT SUPPORTED" on occassion.

I have an ASUS Z97i Plus.

I installed the following kexts:
  1. BrcmFirmwareRepo.kext
  2. BrcmPatchRAM2.kext

The iPhone is not intended to be paired. It uses BT4LE instead.
 
Joined
Jul 5, 2016
Messages
125
Motherboard
eGlobal S200
CPU
i7-8850h
Graphics
uhd630
Mobile Phone
  1. iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,306
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
ab

Because the WIFI and Bluetooth are at the same device,

They are not the "same device" at all. WiFi is on PCIe. Bluetooth is on USB. Just because they are on the same PCB is meaningless and irrelevant.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,306
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
So how do you connect the iPhone? I also have a keyboard that BT4LE.

The iPhone you just use the various features (AirDrop, handoff, etc.) ... to the extent they work. No need to pair it.
 
Joined
Jan 11, 2012
Messages
41
Motherboard
Intel Server S5520HCR
CPU
Intel Xeon E5620 2.4 Ghz - 16GB DDR3
Graphics
Zotac GTX 970 4GB DDR5
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
Classic Mac
  1. LC
Mobile Phone
  1. Android
  2. iOS
These are the models that I buy in my city.

Atheros AR9281
Atheros Ar5bhb63
Atheros Ar5bhb92-h
Atheros AR5B95
Broadcom BCM94313HMGB
Broadcom BCM94313HMG2L
Broadcom BCM94312HMG
Broadcom BCM943225HM
CPWL802P041T
Intel WiFi Link 5100

What do you recomend buy? Some have native support?
My laptop is an HP DV6875SE

Sorry for my bad inglesh
 
Status
Not open for further replies.
Top