Contribute
Register

[Guide] Airport - PCIe Half Mini v2

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi rehabman! Do you mean provide us with a full troubleshooting file? I read the guide and followed every step I tought it was significant for my hardware configuration. Do you think I'm missing something so obvious? I will appreciate furthure hint to get rid of the issue.
Thanks
You should follow the ProBook Guide. And if something isn't working, post troubleshooting files as the requested by the guide. Do not post here, post in the ProBook forum.

Note: Best to use quoted replies in long/busy threads like this one.
 
Joined
May 1, 2010
Messages
391
Motherboard
MacPNT
CPU
CoreDuo 1,66 GHz
Graphics
Intel GMA 950
Mac
Mac mini
Classic Mac
Mobile Phone
iOS
Ok so now I understand why there is so few reactions about CountryCode Change :
Country code is easily replaceable in the patch
this had already been discovered earlier ... (many weeks earlier ... ;) ).
Warning: Depending on the country you live in this may be a departure from local regulations so use with caution...
This feature was important for this exact reason, thats why I wanted my CC to be the one of my country.

Unaware of @the-darkvoid's works on CC, I gave a closer look to the US/FCC patch, I otooled AirPortBrcm4360 and I compared d binaries and AirPortBrcm4360.c.

And I came across the same results as @the-darkvoid ... :
you can patch the CC you want as long as it is present in AirPortBrcm4360 : you just have to replace the 2-letters code with the corresponding Hex values.
Use Terminal to convert (replace CC with the country code of your choice from AirPortBrcm4360)
Code:
echo CC| xxd -p -l 2

This feature is a HUGE step forward for me (even more than 5 GHz, as I don't own a "ac" router).

And I really think this should be put in the first post, because not everybody comes from the US on this forum !



BTW

GB (Not sure if this is a working code) -> seems OK (output is "GO" ?!?)
UK (Not sure if this a working code)-> not working
DE (Untested)->OK
 
Joined
Nov 23, 2014
Messages
8
Motherboard
Gigabyte Z270X Gaming K5
CPU
i7-7700K
Graphics
RX 5700 XT
Mac
MacBook
Mobile Phone
Android, iOS
Thank you sooooo much! I can confirm that country code "HK" is working.


Not related to country code:
I am using a 2.4GHz dual band wireless N router. I have 3 issues now.

1: PHY mode on my hackintosh is 802.11ac, not N.
2: Dual band seems to be not working. Cannot connect to 40MHz. Does bcm94352 supports dualband Wireless N?
3. Speed is very low. Normal speed in Windows but not in Mac. Am i using wrong drivers?

Any help is appreciated! Thanks!

 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,295
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Just to be sure, check it. Updates tend to turn it back on.

Seems like it is an unpatched code path in the kext, but that code path only matters in a specific scenario on your machine.
@RM,

Have checked Hibernation and can confirm that it is disabled.

Today I built a new dev system based on ASUS Z97i-Plus ITX mobo which has AW-CE123H fitted as standard, it works great but suffers from the same issue, switching SSID causes CC to be reset to XT as does long sleep.

Have also updated one of my other hacks to 10.10.3 (GA-Z87N-WiFi with AW-CE123H) and that does the same, 10.10.2 was fine .... This system was using my older method of using BTFirmware Uploader and Toledia's enabler kexts .... switched it to using the new FakePCIID method but issue remains.

So three completely different systems on 10.10.3 are all suffering from the same issue, the only common dominators are that they are all on 10.10.3 and using AW-CE123H. My Laptop and the Z87N system are using AW-CE123H WiFi/BT cards which i bought from the states via Ebay, the Asus mobo came fitted with one as standard.

All three systems use the following kexts :-

BrcmPatchRAM.kext
FakePCIID_BCM94352Z_as_BCM94360CS2.kext
FakePCIID.kext

With the Darkvoids CC Clover Patch:-

Code:
Find:    E8510E00 0085C074 
Replace: 66C70623 619090EB
Above patch is for CC as #a but have also tried US, GB, DE ... etc

All systems reset country code to XT after changing SSID or long sleep.

So either i'm doing something wrong or missing something ...

However since the behaviour was the same using the older BT & WiFi kexts and patches i can only assume that its a result of the 10.10.3 update ....

I've tried updating the firmware on my Router and changing the CC code on that but it makes no difference, 5Ghz works without issue on my tablet.

Have tried disabling 802.11d protocol but again makes no difference.

All Three systems have the same VID/PID (14E4/43B1) and work fine under Windows 7

Totally stumped now ...

Cheers
Jay
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
...
With the Darkvoids CC Clover Patch:-

Code:
Find:    E8510E00 0085C074 
Replace: 66C70623 619090EB
I'm using only the-darkvoid's 5Ghz US/FCC patch:
Code:
find: <4183fcff 742c48>
repl: <66c70655 53eb2b>
Seems to be quite a different patch than the one you mention using...
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,458
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
And I really think this should be put in the first post, because not everybody comes from the US on this forum !
Agree, need User confirmation. XT patch removed from Post #1 for 10.10.3; your post suggests XT is no longer valid.
DE is confirmed, Post #1171.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,458
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Above patch is for CC as #a but have also tried US, GB, DE ... etc
Try:
Post #1
BCM94352 5 GHz/BT Handoff (10.10 and newer)
2. Patches ​(Select one)
1. 10.10.3 and newer, 5GHz​
1. Binary patch: AirPortBrcm4360​
1. US/FCC the-darkvoid #981​
2. ROW: Sebinouse #1162​
1. [Guide] Airport - PCIe Half Mini v2 - Page 117

find: 41 83 FC FF 74 2C 48
replace:
US: 55 53/repl: 66 C7 06 55 53 EB 2B
GB: 47 42/repl: 66 C7 06 47 42 EB 2B
DE: 44 45/repl: 66 C7 06 44 45 EB 2B
FR: 46 52/repl: 66 C7 06 46 52 EB 2B

Edit - 5.14.15: fixed GB/DE typos
 
Joined
May 1, 2010
Messages
391
Motherboard
MacPNT
CPU
CoreDuo 1,66 GHz
Graphics
Intel GMA 950
Mac
Mac mini
Classic Mac
Mobile Phone
iOS
Agree, need User confirmation. XT patch removed from Post #1 for 10.10.3; your post suggests XT is no longer valid.
DE is confirmed, Post #1171.
Thank you !
I do confirm XT not valid post#1161 and FR valid post#1162.
Code:
FR Replace	66 C7 06 46 52 EB 2B
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,295
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
I'm using only the-darkvoid's 5Ghz US/FCC patch:

Seems to be quite a different patch than the one you mention using...

@RM,

Hummmm ...... I didn't notice that, The DarkVoid sent me the #a (super country) patch as I have been trying to enable channels 12 & 13, i just assumed that the two CC bytes where different .. but as you point out that is not the case.

Strangely it was the only patch that did the job ..... except that didn't stick after a SSID change or long sleep ... I will contact him and try and get his input on this.

Try: Post #1
find: 41 83 FC FF 74 2C 48
US: 55 53/repl: 66 C7 06 55 53 EB 2B
GB: 47 42/repl: 66 C7 47 42 53 EB 2B
DE: 44 45/repl: 66 C7 44 45 53 EB 2B
@Toleda,

The only patch that works for me is the US one ... but that does not enable the upper 2.4Ghz channels (12 & 13) setting the country code to anything other than US/FCC results in a boot loop or lockup during boot. Have tried repair permissions .... rebuild caches ... etc.

Very strange ....

Have gone back to using CC=US along with the disable 802.11d patch which continues to work after a long sleep and SSID change, but i have to reconfigure my router to use lower 2.4Ghz channels which are unfortunately flooded by 14 other networks around me resulting in very poor 2.4Ghz performance.

Guess your cant have everything .....

I cant help but think that the Firmware on my AC router could be at fault, as the 5Ghz Channels have a CC of DE and the 2.4Ghz channels have a CC of Null. Ive tried changing the CC codes on the router but it randomly overrides the settings and go back to factory defaults.

I live on a military helicopter flight path (they fly low) so i think the radar causes wifi devices to fall back to some sort of safe mode which it doesn't recover from ... mix that with the odd SSID country codes and the flooded 2.4Ghz channels = a wifi nightmare ....

I think it might be time to take a look at the Merlin open source firmware ....

http://www.lostrealm.ca/tower/node/79

Seems this is a well known issue Asus are bowing down to FCC regulations and enforcing them in the firmware even if the router is not bought or used in the US ... sigh

Thanks for your help guys, will continue to investigate, if i figure it out i'll post feedback.

Cheers
Jay
 
Joined
Apr 30, 2015
Messages
1
Motherboard
Dell Lattitude E6430
CPU
core i5
Graphics
nvs 5200
Mac
Classic Mac
Mobile Phone
I have gotten my [FONT=Arial, sans-serif]AzureWave Broadcom BCM94352HMB to work by doing the following according to this guide[/FONT]
[FONT=Arial, sans-serif]Installed the toledaARPT.kext [/FONT]
[FONT=Arial, sans-serif]Installed the BRCMPatchRAM_v1.7 to get the bluetooth working[/FONT]

[FONT=Arial, sans-serif]So now I can see networks in the 2.4GHz range but I can't see anything in the 5GHz range.[/FONT]
[FONT=Arial, sans-serif]I ran the wireless_bcm94352-100-v2.0.command as pointed out in this guide and installed the kext but it has not worked.[/FONT]

[FONT=Arial, sans-serif]I am using the latest chameleon boot loader[/FONT]

[FONT=Arial, sans-serif]my system info shows the following:
[/FONT] Card Type: Third-Party Wireless Card
MAC Address: 00:6b:9e:06:13:ed
Supported PHY Modes: 802.11 a/b/g/n/ac
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14
Wake On Wireless: Supported
AirDrop: Supported

Any help would be appreciated.
 
Status
Not open for further replies.
Top