Contribute
Register

[Guide] Aero 15X V8 (High Sierra + Nvidia Graphics, and Mojave)

Joined
Jun 29, 2016
Messages
18
Motherboard
ASUS Rampage V Extreme
CPU
5960X
Graphics
SLI Titan X
Hey, thanks for your guide! I have the new Areo 15 Y9, and I'm having trouble booting into the High Sierra installer I created, using Unibeast then mounting EFI partition and pasting in your EFI folder (I figured other than the GPU and the very small difference in CPU -- 8750H vs 8950HK -- the hardware would be identical). Is there anything you'd recommend removing/disabling that might not translate across laptops? Mine's hanging at "PTIDSensors: started" although it seems to be related to some earlier ACPI errors (sorry for the potato-cam quality lol). Any ideas? What other threads did you use to put together this guide that I might want to check out?
 
Joined
Apr 7, 2017
Messages
1
Motherboard
Gigabyte Aero 15X V8
CPU
i7-8750H
Graphics
UHD 630, GTX 1070
Hi, I have used the same clover files from your git but i am not able to boot in, It's struct with black display.
I can only boot in if i use wrong *soundsAAPL,ig-platform-id*
I can hear the sounds if i use keyboard with the files provided on github.
 
Joined
May 31, 2019
Messages
1
Hey Zac, are you able to do a BruceX benchmark?
And apologies for the completely stupid question, but is NVIDIA graphics working? As in, works to benefit apps such as fcpx?

Cheers
 
Joined
Jul 25, 2018
Messages
7
Motherboard
Laptop: Aero 15x-Clover
CPU
i7-8750H
Graphics
UHD630, GTX 1070
Hey zacmks,

I have the Aero 15x 4k, i7-8750H, Nvidia GTX 1070, 512GB Toshiba.

Thanks to your post, I got motivated to try Hackintosh my Aero 15x.

After working on it for two weeks on it, I am pretty happy with it.

Everything works fine: Sleep/Restart/Shutdown, WLAN, BT, Sound, Touchpad, CPU PM.

The only thing I can't get better is my battery runtime. No matter what I try, I can't get it over 4-5h.

First I tried to get everything work. Then I tried optimising my CPU PM. Seems to work pretty good. On Idle I have something around 1.3-1.7W. While browsing or writing this text in Safari I am at 2.1W Package Power.

I also replaced my m2 NVME with a 1TB Crucial SATA SSD I had laying around.

Yesterday I also tried removing all internal SSDs and installed Mojave on external 3.5" HDD with its own power source.

Didn't affect the battery runtime.

Brightness is reduced as well (60-70%). Bluetooth is turned off. Tried also shutting down all programs. Normally I only have iStat Running.

But no matter what I do, don't get over 4-5h. On Windows 10 I had battery runtimes around 8h.

How is your battery runtime and do you have some tips for me?

Attached is my EFI. Running on Mojave 10.14.5.
I am pretty happy with it. I am also in contact with Headkaze, the founder of Hackintool. He has the same laptop as me.

Best,
Chris
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,051
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Hey zacmks,

I have the Aero 15x 4k, i7-8750H, Nvidia GTX 1070, 512GB Toshiba.

Thanks to your post, I got motivated to try Hackintosh my Aero 15x.

After working on it for two weeks on it, I am pretty happy with it.

Everything works fine: Sleep/Restart/Shutdown, WLAN, BT, Sound, Touchpad, CPU PM.

The only thing I can't get better is my battery runtime. No matter what I try, I can't get it over 4-5h.

First I tried to get everything work. Then I tried optimising my CPU PM. Seems to work pretty good. On Idle I have something around 1.3-1.7W. While browsing or writing this text in Safari I am at 2.1W Package Power.

I also replaced my m2 NVME with a 1TB Crucial SATA SSD I had laying around.

Yesterday I also tried removing all internal SSDs and installed Mojave on external 3.5" HDD with its own power source.

Didn't affect the battery runtime.

Brightness is reduced as well (60-70%). Bluetooth is turned off. Tried also shutting down all programs. Normally I only have iStat Running.

But no matter what I do, don't get over 4-5h. On Windows 10 I had battery runtimes around 8h.

How is your battery runtime and do you have some tips for me?

Attached is my EFI. Running on Mojave 10.14.5.
I am pretty happy with it. I am also in contact with Headkaze, the founder of Hackintool. He has the same laptop as me.

Best,
Chris
MacBookPro15,2 may be a better choice in smbios

InjectKexts should be set to Detect

all your kext should be installed to /Library/Extensions

next time:
Use this tool and upload your problem reporting files:
 
Joined
Jul 25, 2018
Messages
7
Motherboard
Laptop: Aero 15x-Clover
CPU
i7-8750H
Graphics
UHD630, GTX 1070
Use this tool and upload your problem reporting files:
Alright.

MacBookPro15,2 may be a better choice in smbios

InjectKexts should be set to Detect
Just did that. Didn't change anything.

I already tried 15,2 before and because 15,1 has the i7-8750H I thought this might be the better choice. But honestly I don't notice any differences between both.

Anything else to try?

Edit: Attached output of the install.sh
 

Attachments

Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,051
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Alright.



Just did that. Didn't change anything.

I already tried 15,2 before and because 15,1 has the i7-8750H I thought this might be the better choice. But honestly I don't notice any differences between both.

Anything else to try?

Edit: Attached output of the install.sh
kexts are not installed /L/E
How and where to install kexts:
 
Joined
Jul 25, 2018
Messages
7
Motherboard
Laptop: Aero 15x-Clover
CPU
i7-8750H
Graphics
UHD630, GTX 1070
Will try that.

I thought it is part of the vanilla method to not install any kexts in L/E or S/L/E, to keep the system clean and as Mac-like as possible, and to only inject Kexts via Clover.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,051
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Will try that.

I thought it is part of the vanilla method to not install any kexts in L/E or S/L/E, to keep the system clean and as Mac-like as possible, and to only inject Kexts via Clover.
read post 2 of the laptop guide:
 
Joined
Jul 25, 2018
Messages
7
Motherboard
Laptop: Aero 15x-Clover
CPU
i7-8750H
Graphics
UHD630, GTX 1070
Read the thread and installed the Kexts in /L/E.

Didn’t change anything. Still battery runtime around 4h-5h on Idle.

I have also noticed, that the battery percentage jumps after reboot of around +-5%.

But this was the case from the beginning and is not due those changes.
 
Top