Contribute
Register

[GUIDE 4530s] Lion --> Mountain Lion Upgrade Method - WiFi, Bluetooth, more!

Status
Not open for further replies.
Joined
Feb 14, 2012
Messages
24
Motherboard
Gigabyte GA-X58-USB3, 2x 8GB DDR3 @1600 MHz, OS X 10.10.2
CPU
i7 920 D0 @3.60 GHz
Graphics
EVGA Geforce GTX 770 SC 2GB
Mac
Classic Mac
Mobile Phone
  1. iOS
OS X Partition Disappeared

Hi guys, I need your help.

Following this guide I've already did a Fresh Install and a update from 10.7.3 with two Probooks 4530s (XU015UT) here.
I've had success on these two installations, but today I've tried to update a third one Probook. All of these three are the same model and bios (XU015UT, F09 bios).

This third one was installed with Lion 10.7.3 and fully functional as the second one, same everything. Also they are dual booted with Windows 7, the HD is configured to GUID to work fine with OS X.

So I've booted from my Installer and installed over the Mac partition, without doing anything in Disk Utility, as the guide says.

The installation took about 30 minutes. After reboot the OS X partition has disappeared from Chimera. Neither the USB Chimera or my default Chimera are showing the OS X partition. They are showing only Windows 7 or USB. OS X has totally disappeared and can't be booted.

So I've booted again in the USB Installer and it detects my OS X partition. I've tried installing ML over the partition again, same problem.

The Installer shows my OS X partition as 10.8 installed, but I can't boot it.
Also, in Windows 7, the MacDrive shows my OS X partition with everything installed and my files.

I really can't install it from scratch again, please guys, I need help.
So, anybody knows how to make it bootable and appear in Chimera?
 
Joined
Jul 4, 2011
Messages
57
Motherboard
macBook Pro 10,1 Retina, MacBook Pro 9,1. Probook 4530s
CPU
i7, i7, i7, i3
Graphics
Nivida GeForce GT 650M, HD 4000, HD 3000
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Hi guys, I need your help.

Following this guide I've already did a Fresh Install and a update from 10.7.3 with two Probooks 4530s (XU015UT) here.
I've had success on these two installations, but today I've tried to update a third one Probook. All of these three are the same model and bios (XU015UT, F09 bios).

This third one was installed with Lion 10.7.3 and fully functional as the second one, same everything. Also they are dual booted with Windows 7, the HD is configured to GUID to work fine with OS X.

So I've booted from my Installer and installed over the Mac partition, without doing anything in Disk Utility, as the guide says.

The installation took about 30 minutes. After reboot the OS X partition has disappeared from Chimera. Neither the USB Chimera or my default Chimera are showing the OS X partition. They are showing only Windows 7 or USB. OS X has totally disappeared and can't be booted.

So I've booted again in the USB Installer and it detects my OS X partition. I've tried installing ML over the partition again, same problem.

The Installer shows my OS X partition as 10.8 installed, but I can't boot it.
Also, in Windows 7, the MacDrive shows my OS X partition with everything installed and my files.

I really can't install it from scratch again, please guys, I need help.
So, anybody knows how to make it bootable and appear in Chimera?

The easiest way is to remove your HDD and connect it via external USB drive on one of your working probook. Run chimera and install targeting the external USB drive. Or if choose, you can also do the post install at the same time and target the USB.
 
Joined
Jul 4, 2011
Messages
57
Motherboard
macBook Pro 10,1 Retina, MacBook Pro 9,1. Probook 4530s
CPU
i7, i7, i7, i3
Graphics
Nivida GeForce GT 650M, HD 4000, HD 3000
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
There is one issue with this. Since I don't have my wireless card yet (its being shipped me to) I am using the ethernet connection and I am finding that when I leave it unplugged for a few minutes and plug the cable back in the laptop won't reconnect. Even after I do a shutdown/power on it won't connect, its not until I push the Ethernet Kext files from the HP Installer v4 and do a reboot does it come back. :(

A.

Your router probably change your IP after you disconnect and osx trying to use ip from cache. Try flushing your DNS cache and deleting your sleep image and reboot. You can find instruction on how to do this several post back.
 
Joined
Jul 4, 2011
Messages
57
Motherboard
macBook Pro 10,1 Retina, MacBook Pro 9,1. Probook 4530s
CPU
i7, i7, i7, i3
Graphics
Nivida GeForce GT 650M, HD 4000, HD 3000
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
I have finally given up with the dual boot idea and will just run ML on my 4530s. :)

Has there been any kind of fix for the optical drive?

Thanks
Optical DVD drive work out of the box. There is no extra kext need for this. Try checking your setting, power down and reseat your optical drive. Also check your bios setting to make sure it is not disable in bios.
 
Joined
Feb 10, 2012
Messages
5
Motherboard
Hp Probook 4530s
CPU
i5-2450
Graphics
Intel HD 3000
Mac
Classic Mac
Mobile Phone
Work with MBR?

Hi everyone

First of all, I would like to thank all the members responsible for making such a wonderful and thorough guide. Really appreciate work hard work.

On to my question. I have an installed Lion partition on my Probook which dual boots with windows. I had previously installed it on a MBR HDD instead of changing it to GUID since i did not want to lose my data from the windows partition. So is it possible to upgrade using this guide onto the MBR partion or will I have to completely reformat the HDD into GUID?

Thanks
 
Joined
Feb 14, 2012
Messages
24
Motherboard
Gigabyte GA-X58-USB3, 2x 8GB DDR3 @1600 MHz, OS X 10.10.2
CPU
i7 920 D0 @3.60 GHz
Graphics
EVGA Geforce GTX 770 SC 2GB
Mac
Classic Mac
Mobile Phone
  1. iOS
The easiest way is to remove your HDD and connect it via external USB drive on one of your working probook. Run chimera and install targeting the external USB drive. Or if choose, you can also do the post install at the same time and target the USB.

I've just tried it, no luck. The Chimera is now the v1.11 but the OS X partition still doesn't appear.

What should I do?
 
Joined
Nov 15, 2011
Messages
2
Motherboard
HP Probook 4530s
CPU
i3 2330m
Graphics
Intel HD 3000
Mac
Classic Mac
Mobile Phone
  1. iOS
wifi

dear,
i have installed fresh ML on same config laptop you have got,
HP Probook 4530s : i3 2330m : bios f9
i used Probook installer 5.0b2 it gave an error in the end that installation failed when i select Mountain lion 10.8 and bluetooth + ethernet fix

it is working but i have to boot from unibeast usb, camera not working, wifi not working : bluetooth not working
 
Joined
Jul 4, 2011
Messages
57
Motherboard
macBook Pro 10,1 Retina, MacBook Pro 9,1. Probook 4530s
CPU
i7, i7, i7, i3
Graphics
Nivida GeForce GT 650M, HD 4000, HD 3000
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
I've just tried it, no luck. The Chimera is now the v1.11 but the OS X partition still doesn't appear.

What should I do?

Try using Disk Utility to repair disk drive and also disk permission. It should show up in disk utility when connect via USB external.
 
Joined
Jul 25, 2012
Messages
2
Motherboard
mountain lion
CPU
i3
Graphics
intel 3000hd
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
same problem

i have same problem i have lion and mountain lion installed and i can boot only from usb
 
Joined
Jul 25, 2012
Messages
2
Motherboard
mountain lion
CPU
i3
Graphics
intel 3000hd
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
i solved the problem i instal windows 7 as well after instal the chimera again now works ok
 
Status
Not open for further replies.
Top