Contribute
Register

[GUIDE 4530s] Lion --> Mountain Lion Upgrade Method - WiFi, Bluetooth, more!

Status
Not open for further replies.
Joined
Dec 21, 2010
Messages
7
Motherboard
Asus P5Q Premium
CPU
Q6600
Graphics
DH 6850
Mac
Classic Mac
Mobile Phone
How do I get my VGA port to work? When in setting I went to display and every time I clicked detect display.... nothing happens

Try this my Friend :)
 

Attachments

  • AppleIntelSNBGraphicsFB.zip
    104.4 KB · Views: 91
Joined
Jul 3, 2011
Messages
57
Motherboard
macBook Pro 10,1 Retina, MacBook Pro 9,1. Probook 4530s
CPU
i7, i7, i7, i3
Graphics
Nivida GeForce GT 650M, HD 4000, HD 3000
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
It seem many people run into different issue with the install. I will write a upgrade/clean install guide with kexts pack and post it up sometime later today.

Until then I recommend everyone to flushing their DNS caches and delete sleep image.

Flushing DNS caches:

1. Open terminal and type sudo killall -HUP mDNSResponder and hit "enter" enter password if asked.
2. delete sleep image
3. DO NOT REBOOT until next step

Delete sleep image:
1. Open terminal type sudo rm /private/var/vm/sleepimage and hit "enter" enter password if asked.
2. Reboot
 
D

Deleted member 135134

Guest
It seem many people run into different issue with the install. I will write a upgrade/clean install guide with kexts pack and post it up sometime later today.

Until then I recommend everyone to flushing their DNS caches and delete sleep image.

Flushing DNS caches:

1. Open terminal and type sudo killall -HUP mDNSResponder and hit "enter" enter password if asked.
2. delete sleep image
3. DO NOT REBOOT until next step

Delete sleep image:
1. Open terminal type sudo rm /private/var/vm/sleepimage and hit "enter" enter password if asked.
2. Reboot

yeah thanks a lot, that's it....without this workaround I had issues with mail and App Store. Now all works fine.....
 
Joined
Dec 20, 2011
Messages
29
Motherboard
HP ProBook 4530s XU015UT
CPU
Intel Core i3-2310M 2.1GHz
Graphics
Intel HD Graphics 3000
Mac
Classic Mac
Mobile Phone
  1. iOS
Has anyone run into the problem of their computer restarting continuously after installing and restarting? Can not boot with -x or -v, still restarts. Also it will not let me run unibeast.
 
Joined
Jul 23, 2012
Messages
2
Motherboard
HP 4530s
CPU
i5-2450m
Graphics
HD 3000
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
HP Probook 4530s - Installation problems and fixes.

Current system: Hp Probook 4530s - i5 2450m, 8gb ddr3 1333mhz, 320gb WD Black Scorpio HD.

Now i have read many threads and tried so many installations and not all goes correct the first time. I end up have root delay issues where by the verbose diagnostics (-v) in unibeast hangs at "waiting on root device".
Alot of forums accused the new so called drivers for the AHCI controller for the hard drive but this is not the case. Apple uses SSD drives which have faster response/boot up time than a normal HD which can take anywhere between 1-200ms. Now the problem there is that Mountain Lion only sends out the root device request once, thus the hang. There is a patch for this which increases the root request from 0x1 - 0x8 and also increases the timeout to 200ms which is enough time for any HD at 5400rpms or more to respond to.(patch-ahci-mlion)
You can also disable the UseKernalCache as well but that increases the boot up time by a noticeable difference. This is found in Chameleon Wizard.

Alright, now that is out of the way with the booting issue in mountain lion here is the run down.

Step 1: Download Uni-beast 1.5.1 and have a legally obtained "Mountain Lion.app" (from the app store) OS X installation saved to your application folder.
Step 2: Run Uni-beast 1.5.1 with Laptop support and wait till it is finished. It can report for unto 8hrs etc till finish time, ignore this it does not take longer than 20-30mins.
Step 3: Restart the computer with the Uni-beast Flash Drive attached and hit F9 and select the USB Drive.
Step 4: When selecting your Mountain Lion Installation be sure to use the following commands or it may not work: -x -v cpus=1
Step 5: Install Mountain Lion - This can take around 19-25mins depending on your laptop specs.
Step 6: After Installation, Restart computer and press F9 and boot from the USB again. You do not need to use the commands this time as it is a fresh boot.
Step 7: Once with in OS X ML, You need to have the following programs: HP Probook Installer v4, Chimera 1.9.1 or Chameleon 2.1-r2034 and ahci-mlion(HD Patch)
Step 8: Run Chameleon or Chimera
Step 9: Run Hp Probook Installer v4 with current selection: OS Version - 10.7.4, Ethernet Kext Installer, Bluetooth, CPU(Type) Spec, Graphics Glitch Fix, DSDT - select your laptop and the BIOS version, System Definitions( select one of the 3 8,1=13" 8,2=15.6" 8,3 17") and Extra Tools - Chameleon Wizard and Kext wizard if necessary.
Step 10: If your running a non SSD system(solid state drive), you need to run the patch-ahci-mlion script to change the root device request to 0x8 and increase timeout to 200ms from 50ms.

If you are running an SSD you do not need to run the patch or disable UseKernalcache.

You should be able to restart and boot with out the USB.

If everything runs smoothly, you can open the chameleon wizard and turn off GUI and slide the timer all the way down for quiet boot aka, no wait screen for commands before booting OS X MLion.

Please let me know if anyone has any issue or questions.
Due to the fact i am new i can not post links or files as yet. But i will be happy to point you where to go. But you can obtain most from Tonymac webstite
 
Joined
Jul 3, 2011
Messages
57
Motherboard
macBook Pro 10,1 Retina, MacBook Pro 9,1. Probook 4530s
CPU
i7, i7, i7, i3
Graphics
Nivida GeForce GT 650M, HD 4000, HD 3000
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Has anyone run into the problem of their computer restarting continuously after installing and restarting? Can not boot with -x or -v, still restarts. Also it will not let me run unibeast.

Try clearing boot cache. Boot with -f -v and post back the last kext it try to load.
 
Joined
Dec 20, 2011
Messages
29
Motherboard
HP ProBook 4530s XU015UT
CPU
Intel Core i3-2310M 2.1GHz
Graphics
Intel HD Graphics 3000
Mac
Classic Mac
Mobile Phone
  1. iOS
THe kexts go by so quickly I can't see the last one & it ends at this screen.
50806b55.jpg
 
Joined
Jul 3, 2011
Messages
57
Motherboard
macBook Pro 10,1 Retina, MacBook Pro 9,1. Probook 4530s
CPU
i7, i7, i7, i3
Graphics
Nivida GeForce GT 650M, HD 4000, HD 3000
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
THe kexts go by so quickly I can't see the last one & it ends at this screen.
50806b55.jpg

Yes I seen this before during my first attempt of ML, you seem to be missing a few kexts. Which install or whose install procedure did you use? Instead of walking you thru single use mode or terminal command, the easiest way to get it back up to desktop is to rerun unibeast and reinstall ML on top of your previous install. When booting up your unibeast drive, boot with -f and go thru the install again. DO not format your drive just install on top of it. Once you back on desktop, follow post #8 in this thread.
 
Joined
Jul 3, 2011
Messages
57
Motherboard
macBook Pro 10,1 Retina, MacBook Pro 9,1. Probook 4530s
CPU
i7, i7, i7, i3
Graphics
Nivida GeForce GT 650M, HD 4000, HD 3000
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Wi-fi not working properly nor is the sound!

Don't know what to do! :/

For wifi and ethernet:

1. Flush DNS - Open terminal and type sudo killall -HUP mDNSResponder and hit "enter" enter password if asked.
2. Clear sleep image - Open terminal type sudo rm /private/var/vm/sleepimage and hit "enter" enter password if asked.
3. Open Finder and go to /Library/Preferences/SystemConfiguration/
Delete these 4 plist
1. preferences.plist
2. NetworkInterfaces.plist
3. com.apple.airport.preferences.plist
4. com.apple.network.identification.plist
4. Download the attached and install those kexts using kext wizard -(Note: it seem the system won't allow more than 2MB zip file. Keep getting upload fail error.) If you want you can PM me with your email and I'll email the kexts file to you.
5. rebuild extension cache with kext wizard
5. reboot
Note: ML should rebuild your network services. If not you may need to add/create new service for wifi and ethernet.

For sound:
1. Download the attached audio kexts
2. Install using kext wizard
3. rebuild extension cache
4. reboot
 

Attachments

  • audio.zip
    2 MB · Views: 89
  • RealtekRTL81xx.kext.zip
    151.1 KB · Views: 81
Status
Not open for further replies.
Top