Contribute
Register

GTX 970 / GTX 980 are here

Status
Not open for further replies.
Joined
Mar 26, 2012
Messages
19
Motherboard
MSI X299M GAMING PRO CARBON AC
CPU
i9-7900X
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Asrock X99M

Success at last. I now have the Asrock X99M Killer booting with Clover and the GTX980.
All 3 DP ports and the HDMI port work. With 4 displays connected, the 4k UP2414Q display works at only 1080P, same as the other displays.
Oddly enough, the HDMI port does not show up in System Profiler, only the 3 DP displays.View attachment 120709

With only the 4K display connected, I can get max res of 3008x1692@30Hz.
Text is sharp, but a bit too small for my eyes to comfortably read with the display 24"-30" away (my normal distance). 2560x1440@30Hz is a much more comfortable res for normal working conditions.
View attachment 120711View attachment 120710

Hi, Saw you had a build based on this board. I have a similar system with the Asrock X99M board, i7-5820K, and was running with a Radeon HD5450. I have just bought a MSI GTX 980 Ti, but cannot get the system to load the GFX drivers, and i get a halt during boot even with nv_disable=1.

I have not been able to get the ALC1150 sound working either.

Would you mind sharing your config.plist and any other specifics you found with your build? Really want to get this new card working. Thanks so much!
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,468
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Hi, Saw you had a build based on this board. I have a similar system with the Asrock X99M board, i7-5820K, and was running with a Radeon HD5450. I have just bought a MSI GTX 980 Ti, but cannot get the system to load the GFX drivers, and i get a halt during boot even with nv_disable=1.

I have not been able to get the ALC1150 sound working either.

Would you mind sharing your config.plist and any other specifics you found with your build? Really want to get this new card working. Thanks so much!

Using the basic config.plist from the Clover guide. Used toleda's clover patch-on-the-fly script to get audio working - device id needs to be changed to get audio. Had to use a different GPU to boot and install the nVidia web drivers for the GTX980. Trying to boot with nv_disable=1 was a flat failure - it would not boot at all.

Install with GTX740 installed, download and install web drivers, use the nVidia control panel to change to web drivers, shut down, swap cards and boot up.
 
Joined
Mar 26, 2012
Messages
19
Motherboard
MSI X299M GAMING PRO CARBON AC
CPU
i9-7900X
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Using the basic config.plist from the Clover guide. Used toleda's clover patch-on-the-fly script to get audio working - device id needs to be changed to get audio. Had to use a different GPU to boot and install the nVidia web drivers for the GTX980. Trying to boot with nv_disable=1 was a flat failure - it would not boot at all.

Install with GTX740 installed, download and install web drivers, use the nVidia control panel to change to web drivers, shut down, swap cards and boot up.

That's fantastic thanks, had too many DSDT fixes in my clover.plist. Got the 980 Ti working, it's amazing! Thanks for your help.
 
Joined
Sep 5, 2013
Messages
4
Motherboard
GA Z87-UD3H
CPU
Core i7 4770K
Graphics
Gigabyte GTX 970 G1
Mac
Classic Mac
Mobile Phone
Hi people, I was wondering if anyone know any workaround to set up a GTX 970 on Mavericks, im currently running OS X 10.9.3. Tried Nvidia Web Drivers but the last update for mavericks wont support Maxwells architecture. Im stuck with Mavericks because PT10 compatibility issues :/
Thanks in advance.:beachball::beachball::beachball:
 
Joined
Jul 25, 2012
Messages
2
Motherboard
Hackintosh
CPU
i7-3.6 GHz
Graphics
GTX 660 Ti
Mac
Classic Mac
Mobile Phone
Hi! Is it possible? I am wondering today norning

?????? ?????? 2015-11-22 ? 11.03.13.jpg?????? ?????? 2015-11-22 ? 11.03.04.jpg
 
Joined
Sep 26, 2013
Messages
195
Motherboard
AsRock X299-Extreme4
CPU
i7-7820K
Graphics
RX 570
Mac
  1. Mac Pro
I have fully working 10.11.2 with GTX970 but never boot right after computer start - booting process ends in restart. I must make hard reset (pressing reset button on the PC case) to successfully boot including fully working GTX970. Any advice?
 
Joined
Nov 17, 2013
Messages
1
Motherboard
Gigabyte UD3H
CPU
4770k
Graphics
970
I have fully working 10.11.2 with GTX970 but never boot right after computer start - booting process ends in restart. I must make hard reset (pressing reset button on the PC case) to successfully boot including fully working GTX970. Any advice?

Tell us more about the flags you're using to boot.

BTW I had your exact problem and the solution was to disable the NVidia Driver Injection from Multibeast. If you use the Web Driver, you don't need that.
 
Joined
Mar 10, 2011
Messages
5
Motherboard
P5Q PRO
CPU
Q9650
Graphics
GTX970
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I have fully working 10.11.2 with GTX970 but never boot right after computer start - booting process ends in restart. I must make hard reset (pressing reset button on the PC case) to successfully boot including fully working GTX970. Any advice?
I have the same problem. Only one differ: I do not reset my comp. It have multiple boot (twice or triple) and after that the boot is successful. Video here:
https://www.youtube.com/watch?v=9wNwrxZy_Qw
 
Status
Not open for further replies.
Top