Contribute
Register

GTX 970 - Black Screen after Nvidia 346.01.02f01

Status
Not open for further replies.
Joined
Aug 19, 2014
Messages
51
Motherboard
Lenovo M920s
CPU
i5-9500
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks for the tip, i will try it. But if serial is not matching your smbios hardware that could cause problem on the long run...dont you think ?

good question.. maybe someone cares to comment on that??
 
Joined
Aug 19, 2014
Messages
51
Motherboard
Lenovo M920s
CPU
i5-9500
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have switched back and for between iMac14,2 and iMac15,1 and never loose iMessage. Just have to log back in. The MacPro6,1 and iMac15,1 have caused lots of people problems with the latest drivers.

Are you getting flash player crash errors in safari ??
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Are you getting flash player crash errors in safari ??

Haven't noticed any flash issues.

As far as the serial number you should have something that matches the rest of your smbios. In my experience the type of Mac that is displayed in the About This Mac is dependent on the serial number and nothing else.
 
Joined
Aug 19, 2014
Messages
51
Motherboard
Lenovo M920s
CPU
i5-9500
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Haven't noticed any flash issues.

As far as the serial number you should have something that matches the rest of your smbios. In my experience the type of Mac that is displayed in the About This Mac is dependent on the serial number and nothing else.

Ur are right i just changed my serial now its displaying the correct iMac :D

And iMessage is running still!!
 
Joined
May 31, 2011
Messages
16
Motherboard
x79-UP4
CPU
4930k @ 4.25
Graphics
EVGA GTX 980 SC ACX 2.0
Mac
Classic Mac
Mobile Phone
got the solution to keep MacPro6,1 def

Originally Posted by rankrotten

Edit the AppleGraphicsControl.kext and burrow down to /Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/Info.plist

> IOKitPersonalities
> AppleGraphicsDevicePolicy
> ConfigMap
F60DEB81FF30ACF6 change from Config 2 to none.

Save changes and reinstall kext. Reboot.

Now I have my system fully working again, with Nvidia graphics + MacPro 6,1 sys def.
 
Joined
May 26, 2011
Messages
138
Motherboard
I didn't read
CPU
the RULES!
Graphics
so IGNORE me!
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
got the solution to keep MacPro6,1 def

Originally Posted by rankrotten

Edit the AppleGraphicsControl.kext and burrow down to /Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/Info.plist

> IOKitPersonalities
> AppleGraphicsDevicePolicy
> ConfigMap
F60DEB81FF30ACF6 change from Config 2 to none.

Save changes and reinstall kext. Reboot.

Now I have my system fully working again, with Nvidia graphics + MacPro 6,1 sys def.

this one actually worked perfect thanks...
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
got the solution to keep MacPro6,1 def

Originally Posted by rankrotten

Edit the AppleGraphicsControl.kext and burrow down to /Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/Info.plist

> IOKitPersonalities
> AppleGraphicsDevicePolicy
> ConfigMap
F60DEB81FF30ACF6 change from Config 2 to none.

Save changes and reinstall kext. Reboot.

Now I have my system fully working again, with Nvidia graphics + MacPro 6,1 sys def.

I assume this would also work for the iMac 15,1 by changing:

<key>Mac-42FD25EABCABB274</key>
<string>Config2</string>

to

<key>Mac-42FD25EABCABB274</key>
<string>none</string>
 
Joined
Mar 31, 2010
Messages
154
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i9-9900KS
Graphics
RX 5700 XT
I assume this would also work for the iMac 15,1 by changing:

<key>Mac-42FD25EABCABB274</key>
<string>Config2</string>

to

<key>Mac-42FD25EABCABB274</key>
<string>none</string>

Yes that's what I originally did to make iMac 15,1 work. You don't need to add nv_disable=1 either.
 
Joined
Feb 2, 2015
Messages
79
Motherboard
mac pro
CPU
3.89 Ghz Intel Core i7 (4770)
Graphics
NVIDIA GeForce GTX 970 4095 MB
Mac
Classic Mac
Mobile Phone
hummm file does not appear to be there

no info.plist

Screen Shot 2015-04-13 at 9.34.08 PM.jpg
 
Joined
Mar 31, 2010
Messages
154
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i9-9900KS
Graphics
RX 5700 XT
Strange.
 

Attachments

  • Screen Shot 2015-04-14 at 16.53.50.png
    Screen Shot 2015-04-14 at 16.53.50.png
    69.1 KB · Views: 561
Status
Not open for further replies.
Top