Contribute
Register
Status
Not open for further replies.
Joined
Jan 30, 2017
Messages
5
Motherboard
Asus Z170-E
CPU
Intel i7-6700K
Graphics
EVGA GTX 970 SC
Mac
  1. iMac
Mobile Phone
  1. iOS
I had this problem on my AMD hackintosh too but I have Photoshop and Premiere installed on my Sierra hackintosh (specs below). Premiere crashes when I tell the project to use GPU acceleration and Photoshop crashes in general after the splash screen. It's apparent that it's due to incompatibility with my GPU. Is there a fix for this? I'd rather not force all the processing on my CPU for video-based tasks.


Also, latest webdriver is installed and works just fine. This is the only issue I've come across graphics-wise.


Specs:

Intel i7 6700k

Asus Z170-E Motherboard

EVGA GTX 970 4GB

16GB DDR4 RAM
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,277
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
What version of the Adobe apps are you running? I don't have any issues with my 970 in PhotoShop or Premiere. I am running CC2017 currently but it also worked fine in 2015.
 
Joined
Jan 30, 2017
Messages
5
Motherboard
Asus Z170-E
CPU
Intel i7-6700K
Graphics
EVGA GTX 970 SC
Mac
  1. iMac
Mobile Phone
  1. iOS
What version of the Adobe apps are you running? I don't have any issues with my 970 in PhotoShop or Premiere. I am running CC2017 currently but it also worked fine in 2015.
CC 2017. All versions after CS5 crash.
 
Joined
Jan 30, 2017
Messages
5
Motherboard
Asus Z170-E
CPU
Intel i7-6700K
Graphics
EVGA GTX 970 SC
Mac
  1. iMac
Mobile Phone
  1. iOS
I would suggest uninstalling and reinstalling the Adobe apps.
Tried reinstalling 3 times with Photoshop, twice with Premiere. No offense but if the solution was basic troubleshooting, I wouldn't be posting here. I tried every version of Photoshop from CS5 and up. I tried Premiere from CS6 and up. Reinstalled multiple times. Tried running just trial versions, etc. It's an issue with the graphics driver not playing nice.
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,277
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Tried reinstalling 3 times with Photoshop, twice with Premiere. No offense but if the solution was basic troubleshooting, I wouldn't be posting here. I tried every version of Photoshop from CS5 and up. I tried Premiere from CS6 and up. Reinstalled multiple times. Tried running just trial versions, etc. It's an issue with the graphics driver not playing nice.

But it isn't an issue with the driver. I am running Adobe Photoshop CC 2017 on three different machines. Two of those are using the web drivers and one is running a GTX 970. NONE of them are having crash issues and I spend a few hours a day in Photoshop. On my machine with the 970 I also use Premiere and don't have any issues using the GPU for encoding with OpenCL, CUDA or Metal.

Screen Shot 2017-02-03 at 8.37.13 PM.png

Screen Shot 2017-02-03 at 8.38.18 PM.png
 
Last edited:
Joined
Jan 30, 2017
Messages
5
Motherboard
Asus Z170-E
CPU
Intel i7-6700K
Graphics
EVGA GTX 970 SC
Mac
  1. iMac
Mobile Phone
  1. iOS
Okay let's try this. First thing I noticed is that for Premiere, I'm missing the CUDA option. I have it on PC. Another thing, I tried Metal instead of OpenGL and no crash. It works fine. So tell me what could possibly cause that issue, because to me that sounds like a driver thing. I don't see how options could be missing and compatibility with one is different than with another.

Edit: Did a quick Google search and apparently the CUDA driver has to be downloaded and installed separately. Did that and restarted and Premiere works fine with CUDA. Have yet to try Photoshop.

Edit: Noticed this in Photoshop. It's not detecting a GPU.
YS50Ohf.png


So at this point I think it's safe to say the issue is with OpenGL and my GPU not being detected. Certainly sounds like it could be a driver issue to me.

Funny. The Adobe Help site seems to think so as well...
tVbfCnt.png
 
Last edited:
Joined
Jul 24, 2015
Messages
64
Motherboard
Gigabyte GA-Z370-HD3P
CPU
i7-8700K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
And what about Premiere Pro?
How did you fixed the problem?
In premiere pro I can't see any GPU panel in preference....
I'm using cc2017
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,277
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
And what about Premiere Pro?
How did you fixed the problem?
In premiere pro I can't see any GPU panel in preference....
I'm using cc2017

Start a new project and see if you have the option to choose a hardware renderer. Like in my screen shot above.
 
Status
Not open for further replies.
Top