Contribute
Register

GTX 780 6GB working?

Status
Not open for further replies.
Joined
Oct 18, 2013
Messages
40
Motherboard
Z87X-UD5 TH
CPU
4770k
Graphics
Intel HD 4600
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
I am planning to buy a ASUS GTX 780 Strix with 6GB of video RAM.
Do you think this card will work?

I got my Gainward Phantom 780 6Gb working for some time. With OpenCl apps like Final Cut Pro X... working perfectly. Have to say though I can't reproduce the conditions or patch in the way I did it back then. So after updating to 10.9.2 it stopped working. I have tried to do the same but I am missing something and I don't know what it is.

I guess If you buy it is not going to be any different from a 780 with 3Gb. There is 50% of guys who have got it working and 50% that not. If you are skilled you will probably get it right. But if you do just make sure you back up and don't commit the same mistake I did.
By the way, I didn't do anything special because it was 6Gb when I got it working, just following the advice of people and trying to replicate those with a 3Gb 780. Actually I haven't seen any other besides me with a 6Gb 780)

Get it, you will be better suited for the future.
 
Joined
Nov 24, 2011
Messages
852
CPU
i7-3770K @ 4,4GHz
Graphics
GTX 670
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thx! That's good to know that in general I just need to follow the regular instalation procedure.
No idea why it stopped working for you? My build has to work under OSX, as it is my main OS and the full GPU power is just requiered for gaming under windows.
 
Joined
Oct 18, 2013
Messages
40
Motherboard
Z87X-UD5 TH
CPU
4770k
Graphics
Intel HD 4600
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
I already had Nvidia Web Drivers for 10.9.1 installed on 10.9.1 and I got it working installing 10.9.2 Nvidia Drivers on 10.9.1 afterwards.
To do this I had to change the build version on /system/library/coreservices/systemversion.plist from 13B42 which is 10.9.1 to 13C64 which is 10.9.2. What I think I did then before that is do the OpenCl Fix there is a post about here : http://www.tonymacx86.com/graphics/126323-step-step-guide-opencl-cuda-fix-gtx780-titan-gk110b.html (not the one that requires using terminal) before actually installing the Drivers and I think if worked then or maybe I updated again but from the Nvidia WebDrivers panel on OSX panel preferences this time. At that point whether it was before or after the last step I know I could use Final Cut Pro X using almost the 6Gb the card had available and without crashing using all features like stabilizing... I made my holidays video at this point.


Then I realised nobody I could read about had actually done it that way (chaning the build version to install the drivers). So, even if I was a bit hesitant I did go and update to 10.9.2 which I thought it would be alright since that was the OSX version that the drivers I was using where made for. However it stopped working (when I say stopped working I mean not having OpenCL support with Final Cut Pro X crashing, eventhough I could use Adobe Premiere with Cuda which is different from OpenCL.)


Afterwards I realised it made sense that it stopped working because I read that updating overrides the OSX Default Drivers again which I hade modified before installing the Nvidia Drivers for 10.9.2 when I was on 10.9.1 following the methods of the post I linked above (OSX Stock Drivers for Nvidia Card would be on GeForceGLDriver.bundle while Nvidia Official Drivers are on GeForceGLDriverWeb.bundle) . So I tried to do it again which would really make more sense than what I did myself above to get it working, and it didn't. Maybe because I did it in a weird way in first place but not sure.


When I say I haven't been able to reproduce the conditions I got it working with it is not entirely accurate. I did try and do this most of people has done followind the post I linked after formatting and installing 10.9.1, then installing the Combo update and then trying the fix as I should have tried in first place. Though I didn't get if working that way to my surprise. Then I updated to 10.9.3 with combo update and installed 10.9.3 Nvidia Drivers and the same thing. I mean it would boot but Final Cut Pro X would crash which means no OpenCl support. Now that I have recalled everything I did in my mind to explain you this I realise I haven't done it again the way I got it working because I though it would make sense to make it the way most people have got it working and then I got a bit satturated to try again. So I may try again soon if I take the patience to do so and write down every step I take and its outcome this time.


Any way I do hope Yosemite will support it since there is support for a R9 290X on it which has never been supported on Mavericks. So I guess it would make sense though 290X has nothing to do with GTX 780 we could find total support for it considering there is some porcentage of people who has got it working with the official drivers whithout tweaking on 10.9.3. Who knows
 
Joined
Aug 9, 2011
Messages
3
Motherboard
DELL
CPU
INTEL
Graphics
ATI HD 3450
Mac
Classic Mac
Mobile Phone
yep. Works OOB. STRIX-GTX780-OC-6GD5 - OOB... неясыть придет к вам в дом!!!
 
Joined
Feb 6, 2011
Messages
46
Motherboard
ASUS P8P67 Deluxe
CPU
Intel i7 2600K
Graphics
ASUS GTX 570 DIRECTCU II
Mac
Classic Mac
Mobile Phone
  1. Other
So do any of you have any results from the Strix card?
How is OpenCL behavior and Cuda functions?
 
Status
Not open for further replies.
Top