Contribute
Register

GTX 770 Performance issues

Status
Not open for further replies.
Joined
Dec 30, 2014
Messages
2
Motherboard
GA-Z97X-UD5H
CPU
i7-4970k
Graphics
GTX 770 (PNY VCGGTX7704XPB-OC2)
Mac
Classic Mac
Mobile Phone
Hello all, I'm about 12 hours into working on my first hackintosh, having spent the past 4 trying to get my video card to perform well.

I have a PNY GTX 770 (http://www.newegg.com/Product/Product.aspx?Item=N82E16814133499), and am seeing very slow rendering time and screen tearing (I can see the wallpaper render band by band as the computer boots, also, I can see band by band painting each time the Chrome Browser redraws a page.) I am able to get multiple monitors and 4k resolution, etc... It is just an issue of performance when programs try to use graphics acceleration.

Programs that twitch, tear and lag:
  • Initial boot, drawing of desktop
  • Google Chrome
  • App Store

Other programs seem to run well. I don't have any games or heavy graphics programs installed yet.

I have installed the new NVIDIA drivers for 10.10.1
Experimented with all combinations of grapihcsenabler and IPGEnabler

What else is left to try and which configuration files may be relevant?

cat /Extra/org.chameleon.Boot.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>IGPEnabler</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>kext-dev-mode=1</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>HDEFLayoutID</key>
<string>01000000</string>
<key>UseKernelCache</key>
<string>Yes</string>
<key>HDAEnabler</key>
<string>Yes</string>
</dict>

Thanks in advance!
David
 
Joined
Nov 10, 2011
Messages
354
Motherboard
Gigabyte X79-UD5
CPU
i7-3930K
Graphics
GTX 960 and RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. Android
  2. iOS
I have the same issue - I have fixed this before but can't recall ATM and having this again. Did you get solution?


Thanks,

Hello all, I'm about 12 hours into working on my first hackintosh, having spent the past 4 trying to get my video card to perform well.

I have a PNY GTX 770 (http://www.newegg.com/Product/Product.aspx?Item=N82E16814133499), and am seeing very slow rendering time and screen tearing (I can see the wallpaper render band by band as the computer boots, also, I can see band by band painting each time the Chrome Browser redraws a page.) I am able to get multiple monitors and 4k resolution, etc... It is just an issue of performance when programs try to use graphics acceleration.

Programs that twitch, tear and lag:
  • Initial boot, drawing of desktop
  • Google Chrome
  • App Store

Other programs seem to run well. I don't have any games or heavy graphics programs installed yet.

I have installed the new NVIDIA drivers for 10.10.1
Experimented with all combinations of grapihcsenabler and IPGEnabler

What else is left to try and which configuration files may be relevant?

cat /Extra/org.chameleon.Boot.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>IGPEnabler</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>kext-dev-mode=1</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>HDEFLayoutID</key>
<string>01000000</string>
<key>UseKernelCache</key>
<string>Yes</string>
<key>HDAEnabler</key>
<string>Yes</string>
</dict>

Thanks in advance!
David
 
Joined
Dec 30, 2014
Messages
2
Motherboard
GA-Z97X-UD5H
CPU
i7-4970k
Graphics
GTX 770 (PNY VCGGTX7704XPB-OC2)
Mac
Classic Mac
Mobile Phone
Hey Gabriel,

Thanks for the response. I have not made any headway. At this point I'm considering selling the card and buying another one, which I'm not looking forward to doing.

Any suggestions would be very much appreciated!

Thanks!
David
 
Joined
Jan 8, 2012
Messages
86
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i5-9600K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
You need to actually activate the web driver by adding nvda_drv=1 in you boot flags. It's also best to deactivate your integrated graphics in the bios and have igpenabler to false.
 
Status
Not open for further replies.
Top