Contribute
Register

GTX 660 glitch issue with MacOS High Sierra 10.13

Status
Not open for further replies.
Joined
Nov 9, 2015
Messages
87
Motherboard
GIGABYTE Z170XP-SLI
CPU
I5-6600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Unfortunately after 6 days, glitch started when I launched Viber or JEdit. The solution did not work so I'm going to buy Radeon video card. I'm tired of nVidia delaying web driver releases after new macOS updates and Apple won't fix old native nVidia drivers. Apple would have fixed the glitch issue since it was discovered in High Sierra but they haven't.

Bummer! Yeah I bit the bullet and got the sapphire nitro+ rx 580. Runs like butter and it's amazing
 
Joined
Jul 11, 2015
Messages
386
Motherboard
ASUS Maximus Gene VIII
CPU
i7-6700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Bummer! Yeah I bit the bullet and got the sapphire nitro+ rx 580. Runs like butter and it's amazing

I'm picking up Sapphire RX 570 tomorrow.
 
Joined
Jun 19, 2018
Messages
17
Motherboard
AsRock Z77 Extreme 4
CPU
i5 35770k @4.2Ghz
Graphics
GTX 660
Mac
  1. iMac
Mobile Phone
  1. iOS
unfortunately here in Brazil the AMD is now very expensive (all cards actually)... and I have to stay with GTX660 for more months (or years I dont know) :(
 
Joined
Jul 11, 2015
Messages
386
Motherboard
ASUS Maximus Gene VIII
CPU
i7-6700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
unfortunately here in Brazil the AMD is now very expensive (all cards actually)... and I have to stay with GTX660 for more months (or years I dont know) :(

If you did the patch like I did then you will notice much less glitches. The glitch appeared on 6th day after several sleep/wake cycles but if you reboot or shutdown often then glitch won't appear. I did notice the difference before and after the patch. The sleep/wake cycles without rebooting the computer for awhile can have undesirable effects.

I rebooted the computer and JEdit and Viber worked okay. No glitches.
 
Joined
Oct 10, 2016
Messages
29
Motherboard
ASRock X79 Extreme 4
CPU
i7-3930K
Graphics
RX 580
I jump from sierra (normal) to Mojave 10.4.0 I update all the beta and yesterday the last official update 10.4.1
and BUG on NVIDIA GTX 660 si always the same... seem fine long you open and use GFX apps or NLE video app like FINAL CUT PRO X...and GLITCH come out!! impossible working any more with nvidia cards also the few "native".. that normaly not need webdrivers...

crazy , because, all the littel apps, but also programs like LOGIC PROX , MAINSTAGE ecc.. no glitch !! also QUICKTIME with any clip..no GLITCH...but preview on gfx , and NLE video programs..come out in 2 seconds...and you must only restart the system for really close this glitch!!!

problem is only the driver NVIDIA in Mojave, and for sure in the lasts update sierra high.
and we can forget any FIX from apple... now like only AMD business...

or...we need a GENIUS , fix this "gpu" bug...with a fix kext/app...but only a miracle can do that!
the 660 work super and is really bad buy now a expansive AMD, only for this stupid BUG!

PS (i try all the metode here...I haven't any INTEL video card on my MB, so I can't use the injet intel metode...)
 

Attachments

  • Schermata 2018-10-20 alle 13.21.44.png
    Schermata 2018-10-20 alle 13.21.44.png
    1.1 MB · Views: 211
Joined
Dec 15, 2012
Messages
83
Motherboard
Gigabyte GA-Z77X-UP5-TH F12 (GA-Z77X-UP5-TH)
CPU
INTEL i7 3770K
Graphics
Radeon RX 580 8 GB (GV-RX580GAMING-8GD)
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Yup. I've tried my Nvidia 650TI Boost on Mojave 10.14.1 , same issue, glitches still happens on Mojave. Some of the Kepler cards do not work well with Metal and neither Apple and Nvidia bother to fix it. And Nvidia not releasing the webdrive quick enough.

I have to use my onboard Intel HD1400 for now. :(
 
Joined
Oct 10, 2016
Messages
29
Motherboard
ASRock X79 Extreme 4
CPU
i7-3930K
Graphics
RX 580
only with APPLE FIX in osx "updates" can be resolved this BUG... so MOJAVE...

but I' dont think APPLE have interesting any more to see this NVIDIA bug...

all the rest (Clover, kext,...) can't help us...

bad is a new AMD card (like 580)... si not much better of old Nvidia cards...and without cuda many softwares are slow in OPENCL.... premiere and resolve exemples...
 
Joined
Apr 24, 2015
Messages
13
Motherboard
MSI z97s Krait edition
CPU
i7-4770K
Graphics
GTX 650 Ti
i7 4770k
Mobo MSI z97s Krait Edition
ssd data 128 Go + 1t
16 G ram
2 Graphics carte GTX 650 ti Boost
Corsair 600 W
1.png 2.png 3.png 4.png 5.png 6.png 7.png 8.png 9.png 10.png
11.png
 
Joined
Apr 18, 2011
Messages
16
Motherboard
Asus P8h77 M Pro
CPU
i5-2400
Graphics
GTX 660
Mobile Phone
  1. Android
  2. Other
Status
Not open for further replies.
Top