Contribute
Register

GTX 660 glitch issue with MacOS High Sierra 10.13

Status
Not open for further replies.
Joined
Jun 19, 2018
Messages
17
Motherboard
AsRock Z77 Extreme 4
CPU
i5 35770k @4.2Ghz
Graphics
GTX 660
Mac
  1. iMac
Mobile Phone
  1. iOS
I noticed that when de VRAM stuck on midle clock (mine in 1600mhz)... the glitches apears... but unfortunately i didnt locate this frequency to stick with maximum clock (its 3002mhz in my case)
 
Joined
Mar 29, 2012
Messages
53
Motherboard
ASUS P8 H61-M LX2 R2.0
CPU
i5-3470
Graphics
GTX 650 TI
Mac
  1. MacBook Air
Mobile Phone
  1. Android
I noticed that when de VRAM stuck on midle clock (mine in 1600mhz)... the glitches apears... but unfortunately i didnt locate this frequency to stick with maximum clock (its 3002mhz in my case)

Maybe if the frequencies can be fixed inside some kext, I don't have a clue. I don't want to quote any developer, but for sure someone have a clue about that (at least for testing purposes).
 
Joined
Jun 19, 2018
Messages
17
Motherboard
AsRock Z77 Extreme 4
CPU
i5 35770k @4.2Ghz
Graphics
GTX 660
Mac
  1. iMac
Mobile Phone
  1. iOS
Well... I founded where to fixed the clock of VRAM... and I did... BUT... even so... becomes the glitch... BUT AGAIN... become to be different... it glitch only in the effect of maximize or open and close photo for exemple... but as soon as the effect ends... the artifacts gone away

So... defenely it is problem with the clock steps

I will test now with fixed VRAM and GPU clock to seed what happens
 
Joined
Jun 11, 2012
Messages
27
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Is it still working OK?
Unfortunately no. The problems are less frequent and the machine is basically usable for my purposes, but glitching does still occur.
 
Joined
Nov 9, 2015
Messages
87
Motherboard
GIGABYTE Z170XP-SLI
CPU
I5-6600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS

WEG recently rolled together all the different graphicsfixup kexts into a single kexts. That being said, someone posted that they were getting the black screen bug on a 660.

I can no longer easily test this card since i have replaced my 660 with a HD 5770 that was lying around.
 
Joined
Mar 29, 2012
Messages
53
Motherboard
ASUS P8 H61-M LX2 R2.0
CPU
i5-3470
Graphics
GTX 650 TI
Mac
  1. MacBook Air
Mobile Phone
  1. Android
WEG recently rolled together all the different graphicsfixup kexts into a single kexts. That being said, someone posted that they were getting the black screen bug on a 660.

I can no longer easily test this card since i have replaced my 660 with a HD 5770 that was lying around.

It's because the project seems quite active and because of this:
  • Fixes NVIDIA GPU interface stuttering on 10.13 (official and web drivers)
 
Joined
Jun 19, 2018
Messages
17
Motherboard
AsRock Z77 Extreme 4
CPU
i5 35770k @4.2Ghz
Graphics
GTX 660
Mac
  1. iMac
Mobile Phone
  1. iOS
I tested here with all clock fixed and nothing... fixed voltage and clock and still glitch... but not permanent as i comment previewsly
 
Joined
Jul 25, 2011
Messages
26
Motherboard
MSI Z87-GD65 Gaming
CPU
i5 4690
Graphics
ASUS GTX 660 2GB
Mac
  1. iMac
Mobile Phone
  1. iOS
I just tested WhateverGreen with Mojave public beta 2. The artifacts seemed to start showing much faster, but seemed slightly less intrusive for some things. Previously when the artifacts would appear, the menubar text and drop down menus would be unreadable, but so far that hasn't been the case with WhateverGreen. The artifacts aren't staying on the menubar permanently, but they do seem to be permanent on the drop down menus. I can watch a fullscreen youtube video in Safari without artifacts (although they do show up while the video is switching to fullscreen). I only tested for maybe 15 minutes so it's possible that it could get worse. For me, any amount of artifacts is unacceptable so I wasn't interested in testing any further.
 
Last edited by a moderator:
Joined
Mar 29, 2012
Messages
53
Motherboard
ASUS P8 H61-M LX2 R2.0
CPU
i5-3470
Graphics
GTX 650 TI
Mac
  1. MacBook Air
Mobile Phone
  1. Android
I just tested WhateverGreen with Mojave public beta 2. The artifacts seemed to start showing much faster, but seemed slightly less intrusive for some things. Previously when the artifacts would appear, the menubar text and drop down menus would be unreadable, but so far that hasn't been the case with WhateverGreen. The artifacts aren't staying on the menubar permanently, but they do seem to be permanent on the drop down menus. I can watch a fullscreen youtube video in Safari without artifacts (although they do show up while the video is switching to fullscreen). I only tested for maybe 15 minutes so it's possible that it could get worse. For me, any amount of artifacts is unacceptable so I wasn't interested in testing any further.

I've setup an High Sierra installation to test it. It seems the glitches are far less than usual for me. It happens slightly less, and it's exactly the same situation you described. Just for the record, here's the setup I've tested so far:

MacOS High Sierra 10.13.6, CUDA Driver 396.148, Nvidia Drivers 387.10.10.10.40.105, WhateverGreen 1.2.0.

Update: I was testing some stuff here. If you keep a game fullscreen, the glitches doesn't appears anymore, but is just a matter of changing to window mode and the window will be entirely glitched. I've close the window and there's no glitches anywhere else. In other hand, if I open youtube in Safari, changes to fullscreen to window again, is a matter of minutes to glitching and transmit to menus and other windows.
 
Last edited by a moderator:
Status
Not open for further replies.
Top