Contribute
Register

GTX 660 glitch issue with MacOS High Sierra 10.13

Status
Not open for further replies.
Joined
Nov 9, 2015
Messages
87
Motherboard
GIGABYTE Z170XP-SLI
CPU
I5-6600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Was able to get Mojave B2 installed and booted (it went to a black screen so had to use a iMac 14,1 smbios until nvidiagraphicsfixup is updated). Glitches are still there :(

It's still better than high Sierra as the artifacts seems to go away when you switch to a different app and back (but not always)

The graphics performance overall is quite stuttery (but there is acceleration as the menus are transparent and launchpad is fairly smooth)
 
Joined
Jan 31, 2014
Messages
21
Motherboard
Gigabyte Z87M-D3H
CPU
i5-4570 @ 3.20GHz
Graphics
NVIDIA GeForce GTX 660
Mobile Phone
  1. Android
Hello guys.. for a temporary solution i created a simple applescript, which just rotates the screen for a second and back to clean the graphic ram and the glitches are away for some time. Not a real solution, but hej..

Does this work all the time? I mean I was using editing some display settings in Preferences but sometimes it wasn't enough to clear glitches.
 
Joined
Jun 9, 2015
Messages
26
Motherboard
Gigabyte Z370 AORUS Gaming 5
CPU
i3-8100
Graphics
UHD 630
Please be careful about posting about the Mojave Betas. I had my post mentioning it removed and got a warning, telling me to read the rules.

  • This site allows discussion of pre-release software (such as OS X Public Beta software builds) from the free Apple Beta Software Program. This site does NOT support pre-release Apple Developer Program Beta software, and does NOT allow the discussion of installation or use of Apple Developer Program Beta software. Repeated violations of this rule will result in a permanent ban. No Apple Developer Program Builds, Apple Beta Software Program builds only.
 
Joined
Jul 25, 2011
Messages
27
Motherboard
MSI Z87-GD65 Gaming
CPU
i5 4690
Graphics
ASUS GTX 660 2GB
Mac
  1. iMac
Mobile Phone
  1. iOS
Please be careful about posting about the Mojave Betas. I had my post mentioning it removed and got a warning, telling me to read the rules.

Same thing happened to me, but the public beta is out so it’s safe to talk about it now. No changes here with Mojave, the glitches usually take no more than 10 minutes to appear on mine and make it pretty much unusable. I’m hoping it’ll get fixed before the final release but I’m not very optimistic at this point.
 
Joined
Nov 9, 2015
Messages
87
Motherboard
GIGABYTE Z170XP-SLI
CPU
I5-6600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Same thing happened to me, but the public beta is out so it’s safe to talk about it now. No changes here with Mojave, the glitches usually take no more than 10 minutes to appear on mine and make it pretty much unusable. I’m hoping it’ll get fixed before the final release but I’m not very optimistic at this point.

It will never get fixed unless someone with a mac pro with this card opens a ticket. It's been ongoing since HS betas and was never fixed there.

While the RX series work good now, who knows, they might start artifacting in 10.17 or something. Apple seems to struggle in the graphics department a lot (iphone4/ipad3/6+ underpowered GPUs, 15 inch macbook dGPU issues, etc)
 
Joined
Nov 14, 2017
Messages
15
Motherboard
A1993
CPU
3.2 Ghz
Graphics
Intel UHD 630
Mac
  1. Mac mini
It will never get fixed unless someone with a mac pro with this card opens a ticket. It's been ongoing since HS betas and was never fixed there.

While the RX series work good now, who knows, they might start artifacting in 10.17 or something. Apple seems to struggle in the graphics department a lot (iphone4/ipad3/6+ underpowered GPUs, 15 inch macbook dGPU issues, etc)

I do have a Mac Pro and sent multiple tickets and got no response. Apple has no interest in fixing the issue with the 660 or any other card affected.
 
Joined
Nov 14, 2017
Messages
15
Motherboard
A1993
CPU
3.2 Ghz
Graphics
Intel UHD 630
Mac
  1. Mac mini
Did you tried open a ticket with nvidia?

I did not. I'm not using the NVIDIA web driver and don't want to either. On a Mac Pro and Sierra, the 660 was plug and play and I never had any issues. When I tried it with High Sierra, it was a mess.

Btw, I don't think NVIDIA will or CAN fix this problem. They would have by now if they could.
 
Joined
Mar 29, 2012
Messages
53
Motherboard
ASUS P8 H61-M LX2 R2.0
CPU
i5-3470
Graphics
GTX 650 TI
Mac
  1. MacBook Air
Mobile Phone
  1. Android
I did not. I'm not using the NVIDIA web driver and don't want to either. On a Mac Pro and Sierra, the 660 was plug and play and I never had any issues. When I tried it with High Sierra, it was a mess.

Perhaps nvidia could pay more attention about this issue and, at least, fix it (if someone with a real mac was able to report it).
 
Status
Not open for further replies.
Top