Contribute
Register

GTX 660 glitch issue with MacOS High Sierra 10.13

Status
Not open for further replies.
Joined
May 10, 2013
Messages
9
Motherboard
Asus H61M-K
CPU
Intel Core i5 3570k
Graphics
Nvidia Geforce GTX 660 TI
Well, you first said "Igpu connected to first screen gtx660 to second", so I based my assumptions on that. Didn't mean to discredit your work.

Still wondering why this isn't working for anyone except you. Maybe it's the combination of your specific motherboard and iGPU that does the trick. Are you still using the underclocked bios?

Regarding the AU causing glitches, that would make sense. Mine don't seem to trigger it.
 
Joined
Aug 20, 2011
Messages
31
Motherboard
Gigabyte Z77X-UD5H
CPU
i7-3770K
Graphics
GTX 970
Mac
  1. MacBook Air
Classic Mac
  1. iBook
  2. iMac
  3. Power Mac
Mobile Phone
  1. iOS
I have 2 GTX 660Ti in my machine. I have all the graphical glitches and pixel vomit. I have noticed that enabling IGPU seems to help a tiny bit. Scrolling and zooming can sometimes clear the crud off the screen. Still waiting for some sort of solution to this problem though... Do we know if genuine Macs (like the iMac) that have 660 chips have issues? Otherwise I'm thinking of grabbing a new GPU for my machine and something comparable to the two 660Tis in SLI for my windows side in gaming but the damn cryptocurrency miners have made all the prices INSANE! Trying to get a 970 or even 780/Ti is at $200 or more... while the 1070s are almost to $300 well above MSRP... Terrible time to need a new GPU.
 
Joined
Oct 30, 2013
Messages
9
Motherboard
some
CPU
some
Graphics
some
Add me to the list of people affected by the GTX 660 issues on High Sierra. I have been running Sierra for a long time without issue. I was able to enable the iGPU and have it show in the System Report - and that does help some - but I still get artifacts and once they show up - the machine is not usable. Not sure where to go now to fix this. Bummer.
 
Joined
Nov 13, 2017
Messages
15
Motherboard
A1993
CPU
3.2 Ghz
Graphics
Intel UHD 630
Mac
  1. Mac mini
It seems the issue with the 660 card will never be fixed. Would have happened by now. Can anyone recommend a card, I'm not a gamer, around $100 that will fix this problem on an early 2009 Mac Pro (although upgraded to 2010 5,1 and 8 core to 12)? Thanks.
 
Joined
Mar 29, 2012
Messages
53
Motherboard
ASUS P8 H61-M LX2 R2.0
CPU
i5-3470
Graphics
GTX 650 TI
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Last edited:
Joined
Oct 13, 2011
Messages
260
Motherboard
Dell 9010 XRRDV desktop
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Joined
Mar 29, 2012
Messages
53
Motherboard
ASUS P8 H61-M LX2 R2.0
CPU
i5-3470
Graphics
GTX 650 TI
Mac
  1. MacBook Air
Mobile Phone
  1. Android
I did try a online chat with Nvidia...... not supported not supported nonsense, and please wait for the update... goodbye...... hahahaha. sigh

Nvidia doesn't give a crap to his customers. If you say linux/windows/mac, they'll say "yeah next update", if you say hackintosh, they'll say "not supported". For me this is called "dodge", that's the level of quality of nvidia support: dodging customer's issues caused by themselves.
 
Joined
Oct 13, 2011
Messages
260
Motherboard
Dell 9010 XRRDV desktop
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
hmmmmmmm. im not so sure it's so malign.
For a start it's going to be an issue shared between apple updates and the specific tech of this card, and combine that with the very very small user base for this card with either hackintosh machines or apple and I can see how they do not have an emergency team working thru the night to fix it... and as for the front line customer support team..... they are mostly working zero hour contracts and off a tick sheet of answers..... they couldn't possibly have any genuine insight into our problem.....

im hoping this will be addressed in either a driver or cuda update, yet if so it will be a bonus and not an expectation...... we are all beyond the bleeding edge in this community, supported by ourselves and not by 'them'.
in other words, fingers crossed...
ba43e1d22dcbdd71e32f5ed83f221e9a--prayer-pictures-girl-pictures.jpg
 
Joined
Mar 29, 2012
Messages
53
Motherboard
ASUS P8 H61-M LX2 R2.0
CPU
i5-3470
Graphics
GTX 650 TI
Mac
  1. MacBook Air
Mobile Phone
  1. Android
hmmmmmmm. im not so sure it's so malign.
For a start it's going to be an issue shared between apple updates and the specific tech of this card, and combine that with the very very small user base for this card with either hackintosh machines or apple and I can see how they do not have an emergency team working thru the night to fix it... and as for the front line customer support team..... they are mostly working zero hour contracts and off a tick sheet of answers..... they couldn't possibly have any genuine insight into our problem.....

im hoping this will be addressed in either a driver or cuda update, yet if so it will be a bonus and not an expectation...... we are all beyond the bleeding edge in this community, supported by ourselves and not by 'them'.
in other words, fingers crossed...
ba43e1d22dcbdd71e32f5ed83f221e9a--prayer-pictures-girl-pictures.jpg

Yeah but since people with real macs with same cards is having the same issue, I don't think it´s something specific to hackintoshes anymore.
 
Status
Not open for further replies.
Top