Contribute
Register

GTX 1060 performance on 10.13 High Sierra

Status
Not open for further replies.
Joined
Feb 7, 2011
Messages
5
Motherboard
GA-Z97-D3H
CPU
i5 4460
Graphics
NVIDIA 1080Ti (FE)
Mobile Phone
  1. iOS
Yea I really don't understand why there arent more complaints, does it actually work smoothly for anyone? Or are people just not paying attention?
Btw, my 1070 TI just gets detected as "NVIDIA graphics device 8gb" - wonder if matters will improve if Nvidia implements specific support for it in the driver. Does the 1060 or 1080 TI get detected correctly?

I got back to Sierra because of High Sierras laggy UI. Thankfully I cloned my whole SSD before upgrading. But I can say that my 1080Ti was detected correctly under High Sierra
 
Joined
Nov 24, 2012
Messages
28
Motherboard
Gigabyte Z390 Designair
CPU
i9 9900K
Graphics
Vega64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I found that the RX580 does work on both displays after resume from sleep, so the aformentioned issue where only one monitor works is only occurring on a cold boot. Sad to say the GPU performance of the RX580 on 10.13.2 is so much better than the 1080 TI that I will likely be selling my nvidia card. There is absolutely no comparison. Everything feels extremely smooth with the RX 580 even when using dual 4k monitors in scaled resolutions.

Did you need to do anything to get the RX580 working ? is it native ? any fix kext or anything ?
 
Joined
Mar 12, 2012
Messages
53
Motherboard
Asus ROG STRIX B360-I Gaming
CPU
i5-8500
Graphics
RX 570
Mobile Phone
  1. iOS
Just chiming in to say that I have the same problems as you guys :/
My Sierra installation on this same machine was flawless, but with High Sierra it feels like I'm working on Core2Duo CPU and not a Skylake... I have GTX 1060 as a GPU.

Will follow this thread if someone comes up with useful information or share if I figure out something myself.
 
Joined
Aug 11, 2016
Messages
161
Motherboard
Asus Z170I PRO Gaming
CPU
i5 6600k
Graphics
GTX 1060
We should probably gather some information, so everyone who has the problem please report back with these points:

OSX Version: 10.13.2
Update or fresh install: Update from El Capitan and then Sierra
APFS or HFS+: APFS
GPU Model: GTX 1060
Driver Version: 378.10.10.10.25.102
SMBIOS: iMac 17,1

Multi-Monitor: No
Resolution: 4k

In the meantime I will try a completely fresh APFS install and see if the problem persists
 
Last edited:
Joined
Feb 7, 2011
Messages
5
Motherboard
GA-Z97-D3H
CPU
i5 4460
Graphics
NVIDIA 1080Ti (FE)
Mobile Phone
  1. iOS
We should probably gather some information, so everyone who has the problem please report back with these points:

OSX Version: 10.13.2
Update or fresh install: updating since 10.6.8 including all major versions with no gaps (10.6.8 -> 10.7 -> ... -> 10.12.6 -> 10.13.2)
APFS or HFS+: APFS
GPU Model: GTX 1080Ti
Driver Version: the most recent (including CUDA)
SMBIOS: iMac 14,2

Multi-Monitor: Yes
Resolution: 4k + 1920x1080

And as mentioned before in this thread ( https://discussions.apple.com/thread/8141739?start=150&tstart=0 ), the problem also effects MacBooks with an NVIDIA-GPU
 
Joined
Aug 11, 2016
Messages
161
Motherboard
Asus Z170I PRO Gaming
CPU
i5 6600k
Graphics
GTX 1060
After a complete fresh install I can now say the NVIDIA Driver is the problem.

System was running fine without the driver (of course UI scale was horrible). After installing the latest Nvidia driver (now with iMac 14,2 config) it immediately began stuttering and lagging (now even when OSX Default Drivers are selected in the Nvidia settings).

Will revert back to Sierra until we have official information on a fix.
 
Last edited:
Joined
Jul 31, 2012
Messages
113
Motherboard
ASUS STRIX Z370G
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
OSX Version: 10.13.2
Update or fresh install: Update from El Capitan and then Sierra
APFS or HFS+: APFS
GPU Model: GTX 1070 TI
Driver Version: 378.10.10.10.25.102
SMBIOS: iMac 14,2

Multi-Monitor: No
Resolution: 4k over DP (1080p x2 - "Default for Display")
 
Joined
Jul 31, 2012
Messages
113
Motherboard
ASUS STRIX Z370G
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Ok guys I found the "solution"

Just go straight and clean install Sierra, 1060 performs real good!

:lol:
 
Joined
Mar 12, 2012
Messages
53
Motherboard
Asus ROG STRIX B360-I Gaming
CPU
i5-8500
Graphics
RX 570
Mobile Phone
  1. iOS
Guys,

I just want to share my findings - I tried switching to integrated graphics (Intel 530) and THE PROBLEM GOES AWAY! Everything runs smoothly, animations are not lagging, no stuttering in performance of common tasks... I tried the test of resizing the Finder window rapidly and everything runs smooth, unlike when I'm using nVidia drivers and 1060 card GPU where it looks like I'm having serious drop in FPS... Anyway, not sure how much it helps but at least it seems that this confirms that it's definitely an issue with nVidia drivers, because the same GPU performed perfectly in previous OSX versions.
 
Status
Not open for further replies.
Top