Contribute
Register

GTS 450 Updated to 10.7.2 Black Screen

Joined
Jul 20, 2010
Messages
149
Motherboard
MacPro
CPU
i7 2600
Graphics
Nvidia 450 GTS
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Hi Guys,

I've been looking for a solution and can't find anything. 10.7.1 was super stable with no EFI STRING edits and no GraphicEnabler, updated to 10.7.2 and I got the black screen, even with graphicenabler=yes.

I found this solution but can't find a way to apply it. PLEASE HELP!

Replacing:

"device_type"
Buffer (0x0D)
{
"NVDA,Geforce"
}

with:
"device_type"
Buffer (0x0C)
{
"NVDA,Parent"
}



THANK YOU!
 
Joined
Jul 20, 2010
Messages
149
Motherboard
MacPro
CPU
i7 2600
Graphics
Nvidia 450 GTS
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Joined
Feb 12, 2011
Messages
83
Motherboard
Mac OS X 10.7.4
CPU
Intel Core i5
Graphics
GeForce GT430
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. Android
I found this solution but can't find a way to apply it. PLEASE HELP!

Replacing:

"device_type"
Buffer (0x0D)
{
"NVDA,Geforce"
}

with:
"device_type"
Buffer (0x0C)
{
"NVDA,Parent"
}

It's a DSDT fix. If you're using DSDT injection you can apply this fix.
 
Joined
Jul 20, 2010
Messages
149
Motherboard
MacPro
CPU
i7 2600
Graphics
Nvidia 450 GTS
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Thanks so much replying, do you know of any other fix?
 
Joined
Feb 12, 2011
Messages
83
Motherboard
Mac OS X 10.7.4
CPU
Intel Core i5
Graphics
GeForce GT430
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. Android
There's some user who was able to use the fix in efi strings by just changing NVDA,Geforce to NVDA,Parent before converting into hex. Didn't work for me though. Still can't use my DVI in any OS X version.
 
Top