Contribute
Register

Grey screen w/cursor after CalDigit USB 3 MultiBeast install

Status
Not open for further replies.
Joined
Oct 7, 2012
Messages
56
Motherboard
Gigabyte GA-Z77-DS3H
CPU
Intel i5-3570K
Graphics
NVIDIA GeForce GT 640 2GB
Mac
  1. iMac
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
I've had my hackintosh for less than a month, and I recently decided to get my USB 3.0 working on it. Not for the speed, but because the ports on the front of my case are 3.0, and I want to charge my iPhone with those.

I installed the CalDigit 3rd party drivers with Multibeast, and now, I can't boot into my hackintosh. The apple logo screen freezes, and then a few seconds later it shows a grey screen with the black cursor in the upper left corner.

USB 3 isn't that important to me, but it would be nice to get it working. I've already tried to boot with GraphicsEnabler=No. Is there any way I can get rid of the 3.0 drivers and use the hackintosh that way, or to fix the problem and use USB 3.0? And either of those without doing a clean install and losing my data? Any help is appreciated.
 
Joined
Oct 7, 2012
Messages
56
Motherboard
Gigabyte GA-Z77-DS3H
CPU
Intel i5-3570K
Graphics
NVIDIA GeForce GT 640 2GB
Mac
  1. iMac
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Okay I've discovered that I can boot into single-user mode, and delete the caldigit kexts. Are the only caldigit kexts CalDigitFastIO.kext and CalDigitUSBxHCI.kext?

Also I can't enter anything into single user mode because my keyboard won't work in it. Any ideas?
 
Joined
Oct 7, 2012
Messages
56
Motherboard
Gigabyte GA-Z77-DS3H
CPU
Intel i5-3570K
Graphics
NVIDIA GeForce GT 640 2GB
Mac
  1. iMac
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Alright. I managed to boot into an Ubuntu 12.04 CD and reach the terminal that way. I remounted the Mountain Lion drive as read/write, and I deleted the caldigit kexts.

Now, another problem has come up. I get a kernel panic on startup regarding the apple IOUSBFamily.kext.

Please help! Someone!

BTW, if anyone is having the same problem, I'm currently working this out with my uncle and will post any solutions we come up with.
 
Joined
Oct 7, 2012
Messages
56
Motherboard
Gigabyte GA-Z77-DS3H
CPU
Intel i5-3570K
Graphics
NVIDIA GeForce GT 640 2GB
Mac
  1. iMac
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Success! I am posting from a working hackintosh!

I used multibeast to install the LaCie USB 3 drivers. It booted correctly after that. The odd thing is that USB 3 still doesn't work. Oh well. My hack is working!
 
Joined
Oct 17, 2012
Messages
9
Motherboard
None yet
CPU
3770k
Graphics
650ti
Mac
Classic Mac
Mobile Phone
Thank you!!!!! You're post just helped me resolve my system from the same issue! The cal USB 3.0 totally hung my computer up.



Alright. I managed to boot into an Ubuntu 12.04 CD and reach the terminal that way. I remounted the Mountain Lion drive as read/write, and I deleted the caldigit kexts.

Now, another problem has come up. I get a kernel panic on startup regarding the apple IOUSBFamily.kext.

Please help! Someone!

BTW, if anyone is having the same problem, I'm currently working this out with my uncle and will post any solutions we come up with.
 
Joined
Mar 6, 2013
Messages
13
Motherboard
Gigabyte B75M-D3P
CPU
i5 3570K
Graphics
HD 4000
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
Thank you for the info. I just erased Caldigit kexts from terminal in my Unibeast USB.
Lacie kexts did nothing to me.

Cheers!
 
Status
Not open for further replies.
Top