Contribute
Register

[Great Success] mini HTPC: ASRock Z370M-ITX/ac - i5-8400 - UHD 630 Graphics - Mojave

Joined
Jun 4, 2019
Messages
4
Motherboard
ASRock Z370M-ITX/ac
CPU
Intel i5 8400
Graphics
Integrated
I have the same motherboard and CPU. I followed your instruction and get a nearly 100% working hack. The only problem is random wakeup around every 30 min during sleep and I don't know how to fix it.

pmset -g log|grep -e " Wake " shows:

414563


Is there anybody can help me?
 
Joined
Jul 13, 2011
Messages
33
Motherboard
Asrock Z370m-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
I have the same motherboard and CPU. I followed your instruction and get a nearly 100% working hack. The only problem is random wakeup around every 30 min during sleep and I don't know how to fix it.

pmset -g log|grep -e " Wake " shows:

View attachment 414563

Is there anybody can help me?
So strange.
Can you confirm it exist after clean install?
 
Joined
Aug 1, 2019
Messages
2
Motherboard
ASRock Z370M-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Hi.


Can you help me.
After that

cd Desktop/install
sudo cp -R *.kext /Library/Extensions
sudo kextcache -i /


I get such error kext with invalid signatured (-67062)
error.png


Can I live with this?:)
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,222
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Joined
Dec 25, 2018
Messages
4
Motherboard
Gigabyte Z370M/ITX-ac
CPU
i5-8400
Graphics
UHD 630
Classic Mac
Plus, SE, SE/30
Hi bjgo!

Thanks for the excellent build description! Tried to follow it as closely as possible. Asrock Z370M/ITX-ac i5-8400. I have 32 Gig of DDR4 memory and a 3 TB disk. Did all the steps.

Everything works fine (including sleep) but I get no audio. There is no audio devices found what so ever. Tried reinstalling the Audio drivers using Multibeast a number of times but no effect.

Then I read that AppleHDA should not be present and then I checked with kextstat and found AppleHDA. I removed AppleHDA and did a kextcache -i and then rebooted it. But still no audio devices.

If I do the kextstat command now I see the AppleALC kext listed and no AppleHDA kext present.

Any hints on what to do?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,222
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Hi bjgo!

Thanks for the excellent build description! Tried to follow it as closely as possible. Asrock Z370M/ITX-ac i5-8400. I have 32 Gig of DDR4 memory and a 3 TB disk. Did all the steps.

Everything works fine (including sleep) but I get no audio. There is no audio devices found what so ever. Tried reinstalling the Audio drivers using Multibeast a number of times but no effect.

Then I read that AppleHDA should not be present and then I checked with kextstat and found AppleHDA. I removed AppleHDA and did a kextcache -i and then rebooted it. But still no audio devices.

If I do the kextstat command now I see the AppleALC kext listed and no AppleHDA kext present.

Any hints on what to do?
AppleALC needs and only works on an untouched AppleHDA.kext

You will need to re run the macOS installer to refresh the kexts
 
Joined
Jul 20, 2019
Messages
18
Motherboard
Asrock Z390 Phantom ITX
CPU
I5-9600k
Graphics
Sapphire RX 580
bjgo, could you please test one thing for me. If your Mac done its boot and you're in the macOS menu, could you please use the power off button for 3 sec? Does your Mac goes to sleep or do you get the "sleep, restart, shutdown" menu ?

Thanks for checking
 
Top