Contribute
Register

[Great Success] mini HTPC: ASRock Z370M-ITX/ac - i5-8400 - UHD 630 Graphics - Mojave

Joined
Jul 13, 2011
Messages
33
Motherboard
Asrock Z370m-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
No, after sleep the sound does not work, I have to restart to make it work. Now I try to set 99
you must NOT have any other sound kexts like a voodoo or appleHDA

try to reinstall all from a zero
 
Joined
Jan 15, 2019
Messages
4
Motherboard
ASRock H370M-ITX/ac
CPU
i5-8400
Graphics
HD 630
Looks like a sweet build. Thanks for the clear steps too. Am trying to conquer graphics with H370 version of that board. Following your steps end me in black screen on boot though there should be no need to fake id with an 8400?
Also any reason why you went with Mac Mini 8.1 over the iMac 18.1 SMBIOS? Thanks.
 
Joined
Jul 13, 2011
Messages
33
Motherboard
Asrock Z370m-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
Looks like a sweet build. Thanks for the clear steps too. Am trying to conquer graphics with H370 version of that board. Following your steps end me in black screen on boot though there should be no need to fake id with an 8400?
Also any reason why you went with Mac Mini 8.1 over the iMac 18.1 SMBIOS? Thanks.
After every reboot and black screen - boot from UniBeast drive, select your HDD as dthe boot device in Cover. Boot into system with 7MB VRAM. Restore config.plist to condition before patches. Reboot. Open hackintool framebuffer patch guide add go step by step one more time.
(I use 0x05 bus ID for HDMI, and by the guide it should'nt work, but it does. It was my guess, so try as much as you can and all gonna be done.)

No fake ID for UHD 630 with the i5-8400, but whatevergreen+lilu+"inject intel" in Cover.

Before hackintool patches, I had full accelerated video, but no hotswap HDMI.
After patches, I got 2048MB VRAM instead of 1536, and both HDMI's hotswap and simultaneous work.

Why macmini8,1?
First - my build looks more like a Mac Mini than iMac
Second - all we know sometimes setting correct SMBIOS can add more compatibility.
As long as MacMini8,1 useS UHD 630, I think it is a good idea.
 
Last edited:
Joined
Feb 26, 2019
Messages
1
Motherboard
ASRock Z370M-ITX/ac
CPU
i5-8400
Graphics
Nvidia GTX 750 ti
How to edit Clover config similar as in Clover Configurator on Windows?

I bought similar hardware - same motherboard, same CPU, Broadcom WiFi, w/o graphics card. But...I don't have enough experience with macOS install.
 
Joined
Jul 13, 2011
Messages
33
Motherboard
Asrock Z370m-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
How to edit Clover config similar as in Clover Configurator on Windows?

I bought similar hardware - same motherboard, same CPU, Broadcom WiFi, w/o graphics card. But...I don't have enough experience with macOS install.
At first, you will need any Mac or hackintosh to create UniBeast USB drive.

After that, you can boot your PC with UniBeast created USB drive and follow my steps to install Mojave.
 
Joined
Jun 5, 2017
Messages
4
Motherboard
ASROCK Z370M ITX/AC
CPU
I5-8400
Graphics
UHD 630
Mac
Mac mini
Mobile Phone
iOS
Hi! Congrats on your success. However, I have the same specs as yours I mean CPU and motherboard are the same. But I have this issue whenever I boot up with two screen connected the iGPU will glitch out and only one have signal. Do you know why? Thanks.
 
Joined
Jul 13, 2011
Messages
33
Motherboard
Asrock Z370m-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
Hi! Congrats on your success. However, I have the same specs as yours I mean CPU and motherboard are the same. But I have this issue whenever I boot up with two screen connected the iGPU will glitch out and only one have signal. Do you know why? Thanks.
thanks!

whatevergreen issue
send them a bug report

for now connect/turn on second monitor after full boot
 
Last edited:
Joined
Jun 5, 2017
Messages
4
Motherboard
ASROCK Z370M ITX/AC
CPU
I5-8400
Graphics
UHD 630
Mac
Mac mini
Mobile Phone
iOS
Okay, thanks a lot for your reply. Now I want to ask about the USB. After i follow hackintool USB patching guide, how do I activate the 6 USB 3.1 at the back and one in front of case and 2 USB 2.0 at the back only? Can You guide me to the link to my problem?
 
Joined
Jul 13, 2011
Messages
33
Motherboard
Asrock Z370m-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
Okay, thanks a lot for your reply. Now I want to ask about the USB. After i follow hackintool USB patching guide, how do I activate the 6 USB 3.1 at the back and one in front of case and 2 USB 2.0 at the back only? Can You guide me to the link to my problem?
Following thought the guide you need to 'mark' USB port by inserting USB device.
So just mark all six 3.0 and eight 2.0 on back panel.
 
Top