Contribute
Register

[Great Build] mini HTPC: ASRock Z370M-ITX/ac - i5-8400 - UHD 630 Graphics - Mojave

Joined
Jan 19, 2019
Messages
2
Motherboard
ASRock Z370M-ITX/ac
CPU
i3-8100
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
Thanks a ton for this build description. That helped me iron out the glitches I had after upgrading my machine from High Sierra to Mojave. Now it works even better than before. :)
 
Joined
Jul 13, 2011
Messages
36
Motherboard
Asrock Z370m-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
Will this configuration work with Asrock Z370 Pro 4? Thanks!
not sure. most likely my config.plist will cause errors, so instead of coping mine, create your own
my config only contain:
layout 99 for applealc
inject intel=1
darkwake=8
macmini8,1 smbios
and hackintool patches
 
Last edited:
Joined
Jul 13, 2011
Messages
36
Motherboard
Asrock Z370m-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
iOS
>BCM94352Z
exactly same

>kexts
BrcmFirmwareRepo.kext
BrcmPatchRAM2.kext
AirportBrcmFixup

all in /Library/Extension
but be sure kexts are installed correctly. take a look into my guide: you should copy them into install folder, then "sudo cp" them into /Library/Extensions
then perform "sudo kextcache -i /"
 
Joined
Apr 16, 2016
Messages
54
Motherboard
Asrock Z370M
CPU
i7-8700
Graphics
none
Mobile Phone
iOS
Hi I have a little question, I have this build : asrock Z370m itx + I7 8700 + vega 56.
When I start my computer, the system will shutdown after 5/10 seconds to reboot normally and display the bios / clover and macos. I dont know why. It do as well when I reboot in mac os.
Maybe its normal and it come from the motherboard. So if it is I supose you have it as well. Could you tell me if you have this case.
Thx.
 
Joined
Sep 26, 2015
Messages
126
Motherboard
Gigabyte H270N WiFi
CPU
i5-7500
Graphics
Quadro K1200
Mac
MacBook Pro
ouh, you mean 'clover'...
select boot drive and stuff like recovery or single-user mode?
no bt support) usb only
It's possible to use BT keyboard in UEFI and Clover.
 
Joined
Mar 26, 2019
Messages
1
Motherboard
not yet, i just have a Mac Mini 2012
CPU
i5
Graphics
4000
What is the power usage of this system? (For this moment I have an old Mac Mini late 2012, and it consumes 14 watts).
 
Joined
Aug 27, 2018
Messages
18
Motherboard
Lenovo T440s
CPU
2,69 GHz Intel Core i7
Graphics
Intel HD Graphics 4400
Hi I have a little question, I have this build : asrock Z370m itx + I7 8700 + vega 56.
When I start my computer, the system will shutdown after 5/10 seconds to reboot normally and display the bios / clover and macos. I dont know why. It do as well when I reboot in mac os.
Maybe its normal and it come from the motherboard. So if it is I supose you have it as well. Could you tell me if you have this case.
Thx.
Same problm for me :confused:
 
Joined
Aug 27, 2018
Messages
18
Motherboard
Lenovo T440s
CPU
2,69 GHz Intel Core i7
Graphics
Intel HD Graphics 4400
Hello
I have same config than you and last version of Mojave
I have problm with my USB 3 ports

If i put usb2 Peripheral on usb2 or usb3 it work
If i put ubs3 Peripheral on ubs2 port it work
If i put ubs3 Peripheral on ubs2 port it not work !!!

I use Hackintool for create USBPorts.kext and i putit on EFI > EFI > CLOVER > Kext

396254



Before mojave i use
XHCI-200-series-injector.kext
&
USBInjectAll.kext

Thank for your help
 
Top