Contribute
Register

Graphics still not working/config.plist help.

Status
Not open for further replies.
Joined
Sep 27, 2015
Messages
14
Motherboard
GIGABYTE GA-Z97M-DS3H
CPU
I-54590
Graphics
EVGA GeForce 740 sc
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
Hey So I have tried a lot of things to try to get this graphics card to work. I'm even getting glitches when using integrated graphics...don't know why this would happen.

I am going to post my Config.plist in hopes that some one will see something in it that I need to change to get graphics working. This is the plist ive been using.when I go to mount plist there are a few options I'm editing the first option on the list in configurator.

Build:
MOB - Gigabyte LGA 1151 Z170
cpu - I5 -6600k
Graphics - Gigabyte GeForce GTX Graphics Cards GV-N950XTREME-2GD



Config.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DSDT</key>
<dict>
<key>Debug</key>
<false/>
<key>DropOEM_DSM</key>
<false/>
<key>Fixes</key>
<dict>
<key>AddDTGP_0001</key>
<false/>
<key>AddHDMI_8000000</key>
<false/>
<key>AddIMEI_80000</key>
<false/>
<key>AddMCHC_0008</key>
<false/>
<key>AddPNLF_1000000</key>
<false/>
<key>DeleteUnused_400000</key>
<false/>
<key>FIX_ACST_4000000</key>
<false/>
<key>FIX_ADP1_800000</key>
<false/>
<key>FIX_INTELGFX_100000</key>
<false/>
<key>FIX_RTC_20000</key>
<false/>
<key>FIX_S3D_2000000</key>
<false/>
<key>FakeLPC_0020</key>
<false/>
<key>FiX_TMR_40000</key>
<false/>
<key>FiX_WAK_200000</key>
<false/>
<key>FixAirport_4000</key>
<false/>
<key>FixDarwin_0002</key>
<false/>
<key>FixDisplay_0100</key>
<false/>
<key>FixFirewire_0800</key>
<false/>
<key>FixHDA_8000</key>
<false/>
<key>FixHPET_0010</key>
<false/>
<key>FixIDE_0200</key>
<false/>
<key>FixIPIC_0040</key>
<false/>
<key>FixLAN_2000</key>
<false/>
<key>FixRegions_10000000</key>
<false/>
<key>FixSATA_0400</key>
<false/>
<key>FixSBUS_0080</key>
<false/>
<key>FixShutdown_0004</key>
<false/>
<key>FixUSB_1000</key>
<false/>
<key>NewWay_80000000</key>
<false/>
</dict>
<key>Name</key>
<string>DSDT.aml</string>
<key>ReuseFFFF</key>
<false/>
</dict>
<key>HaltEnabler</key>
<false/>
<key>SSDT</key>
<dict>
<key>DropOem</key>
<false/>
<key>Generate</key>
<dict>
<key>CStates</key>
<false/>
<key>PStates</key>
<false/>
</dict>
</dict>
</dict>
<key>Boot</key>
<dict>
<key>Arguments</key>
<string>nvda_drv=1</string>
<string>dart=0</string>
<key>DefaultVolume</key>
<string>MacHDD</string>
<key>Legacy</key>
<string>PBR</string>
<key>Log</key>
<true/>
<key>Secure</key>
<false/>
<key>Timeout</key>
<integer>3</integer>
<key>XMPDetection</key>
<string>NO</string>
</dict>
<key>Devices</key>
<dict>
<key>Audio</key>
<dict>
<key>Inject</key>
<string>1</string>
</dict>
<key>FakeID</key>
<dict>
<key>ATI</key>
<string>0x0</string>
<key>IMEI</key>
<string>0x0</string>
<key>IntelGFX</key>
<string>0x0</string>
<key>LAN</key>
<string>0x0</string>
<key>NVidia</key>
<string>0x0</string>
<key>SATA</key>
<string>0x0</string>
<key>WIFI</key>
<string>0x0</string>
<key>XHCI</key>
<string>0x0</string>
</dict>
<key>USB</key>
<dict>
<key>FixOwnership</key>
<false/>
<key>Inject</key>
<false/>
</dict>
<key>UseIntelHDMI</key>
<false/>
</dict>
<key>DisableDrivers</key>
<array>
<string>Nothing</string>
</array>
<key>GUI</key>
<dict>
<key>Hide</key>
<array>
<string>Windows</string>
<string>\EFI\BOOT\BOOTX64.EFI</string>
</array>
<key>Language</key>
<string>en:0</string>
<key>Mouse</key>
<dict>
<key>Enabled</key>
<true/>
<key>Speed</key>
<integer>8</integer>
</dict>
<key>Scan</key>
<dict>
<key>Entries</key>
<true/>
<key>Legacy</key>
<string>First</string>
<key>Tool</key>
<true/>
</dict>
<key>ScreenResolution</key>
<string>1920x1080</string>
<key>Theme</key>
<string>tonymacx86</string>
</dict>
<key>Graphics</key>
<dict>
<key>Inject</key>
<dict>
<key>ATI</key>
<false/>
<key>Intel</key>
<true/>
<key>NVidia</key>
<false/>
</dict>
</dict>
<key>KernelAndKextPatches</key>
<dict>
<key>AppleRTC</key>
<true/>
<key>AsusAICPUPM</key>
<true/>
<key>KernelCpu</key>
<false/>
<key>KernelHaswellE</key>
<false/>
<key>KernelLapic</key>
<false/>
<key>KernelPm</key>
<true/>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Find</key>
<data>
RXh0ZXJuYWw=
</data>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>
SW50ZXJuYWw=
</data>
</dict>
<dict>
<key>Comment</key>
<string>Raise 15 port limit to 30 in AppleUSBXHCIPCI</string>
<key>Find</key>
<data>
g72M/v//EA==
</data>
<key>Name</key>
<string>AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g72M/v//Hw==
</data>
</dict>
</array>
</dict>
<key>RtVariables</key>
<dict>
<key>BooterConfig</key>
<string>0x28</string>
<key>CsrActiveConfig</key>
<string>0x3</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>Trust</key>
<false/>
</dict>
<key>SystemParameters</key>
<dict>
<key>InjectKexts</key>
<string>YES</string>
<key>InjectSystemID</key>
<true/>
</dict>
</dict>
</plist>
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DSDT</key>
<dict>
<key>Debug</key>
<false/>
<key>DropOEM_DSM</key>
<false/>
<key>Fixes</key>
<dict>
<key>AddDTGP_0001</key>
<false/>
<key>AddHDMI_8000000</key>
<false/>
<key>AddIMEI_80000</key>
<false/>
<key>AddMCHC_0008</key>
<false/>
<key>AddPNLF_1000000</key>
<false/>
<key>DeleteUnused_400000</key>
<false/>
<key>FIX_ACST_4000000</key>
<false/>
<key>FIX_ADP1_800000</key>
<false/>
<key>FIX_INTELGFX_100000</key>
<false/>
<key>FIX_RTC_20000</key>
<false/>
<key>FIX_S3D_2000000</key>
<false/>
<key>FakeLPC_0020</key>
<false/>
<key>FiX_TMR_40000</key>
<false/>
<key>FiX_WAK_200000</key>
<false/>
<key>FixAirport_4000</key>
<false/>
<key>FixDarwin_0002</key>
<false/>
<key>FixDisplay_0100</key>
<false/>
<key>FixFirewire_0800</key>
<false/>
<key>FixHDA_8000</key>
<false/>
<key>FixHPET_0010</key>
<false/>
<key>FixIDE_0200</key>
<false/>
<key>FixIPIC_0040</key>
<false/>
<key>FixLAN_2000</key>
<false/>
<key>FixRegions_10000000</key>
<false/>
<key>FixSATA_0400</key>
<false/>
<key>FixSBUS_0080</key>
<false/>
<key>FixShutdown_0004</key>
<false/>
<key>FixUSB_1000</key>
<false/>
<key>NewWay_80000000</key>
<false/>
</dict>
<key>Name</key>
<string>DSDT.aml</string>
<key>ReuseFFFF</key>
<false/>
</dict>
<key>HaltEnabler</key>
<false/>
<key>SSDT</key>
<dict>
<key>DropOem</key>
<false/>
<key>Generate</key>
<dict>
<key>CStates</key>
<false/>
<key>PStates</key>
<false/>
</dict>
</dict>
</dict>
<key>Boot</key>
<dict>
<key>Arguments</key>
<string>nvda_drv=1</string>
<string>dart=0</string>
<key>DefaultVolume</key>
<string>MacHDD</string>
<key>Legacy</key>
<string>PBR</string>
<key>Log</key>
<true/>
<key>Secure</key>
<false/>
<key>Timeout</key>
<integer>3</integer>
<key>XMPDetection</key>
<string>NO</string>
</dict>
<key>Devices</key>
<dict>
<key>Audio</key>
<dict>
<key>Inject</key>
<string>1</string>
</dict>
<key>FakeID</key>
<dict>
<key>ATI</key>
<string>0x0</string>
<key>IMEI</key>
<string>0x0</string>
<key>IntelGFX</key>
<string>0x0</string>
<key>LAN</key>
<string>0x0</string>
<key>NVidia</key>
<string>0x0</string>
<key>SATA</key>
<string>0x0</string>
<key>WIFI</key>
<string>0x0</string>
<key>XHCI</key>
<string>0x0</string>
</dict>
<key>USB</key>
<dict>
<key>FixOwnership</key>
<false/>
<key>Inject</key>
<false/>
</dict>
<key>UseIntelHDMI</key>
<false/>
</dict>
<key>DisableDrivers</key>
<array>
<string>Nothing</string>
</array>
<key>GUI</key>
<dict>
<key>Hide</key>
<array>
<string>Windows</string>
<string>\EFI\BOOT\BOOTX64.EFI</string>
</array>
<key>Language</key>
<string>en:0</string>
<key>Mouse</key>
<dict>
<key>Enabled</key>
<true/>
<key>Speed</key>
<integer>8</integer>
</dict>
<key>Scan</key>
<dict>
<key>Entries</key>
<true/>
<key>Legacy</key>
<string>First</string>
<key>Tool</key>
<true/>
</dict>
<key>ScreenResolution</key>
<string>1920x1080</string>
<key>Theme</key>
<string>tonymacx86</string>
</dict>
<key>Graphics</key>
<dict>
<key>Inject</key>
<dict>
<key>ATI</key>
<false/>
<key>Intel</key>
<true/>
<key>NVidia</key>
<false/>
</dict>
</dict>
<key>KernelAndKextPatches</key>
<dict>
<key>AppleRTC</key>
<true/>
<key>AsusAICPUPM</key>
<true/>
<key>KernelCpu</key>
<false/>
<key>KernelHaswellE</key>
<false/>
<key>KernelLapic</key>
<false/>
<key>KernelPm</key>
<true/>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Find</key>
<data>
RXh0ZXJuYWw=
</data>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>
SW50ZXJuYWw=
</data>
</dict>
<dict>
<key>Comment</key>
<string>Raise 15 port limit to 30 in AppleUSBXHCIPCI</string>
<key>Find</key>
<data>
g72M/v//EA==
</data>
<key>Name</key>
<string>AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g72M/v//Hw==
</data>
</dict>
</array>
</dict>
<key>RtVariables</key>
<dict>
<key>BooterConfig</key>
<string>0x28</string>
<key>CsrActiveConfig</key>
<string>0x3</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>Trust</key>
<false/>
</dict>
<key>SystemParameters</key>
<dict>
<key>InjectKexts</key>
<string>YES</string>
<key>InjectSystemID</key>
<true/>
</dict>
</dict>
</plist>
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Is all that copied and pasted from one file?
 
Joined
Sep 27, 2015
Messages
14
Motherboard
GIGABYTE GA-Z97M-DS3H
CPU
I-54590
Graphics
EVGA GeForce 740 sc
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
Is all that copied and pasted from one file?
yes it is. it's double no ? I haven't a clue as to how that would have happened. could that be causing glitches in GUI etc. ?
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
yes it is. it's double no ? I haven't a clue as to how that would have happened. could that be causing glitches in GUI etc. ?

It is actually triple and there are errors in the syntax. You should use Clover Configurator to edit your config.plist. It is hard to see all of the errors but this one stood out:

<key>Arguments</key>
<string>nvda_drv=1</string>
<string>dart=0</string>

should be:

<key>Arguments</key>
<string>dart=0 nvda_drv=1</string>
 
Joined
Sep 27, 2015
Messages
14
Motherboard
GIGABYTE GA-Z97M-DS3H
CPU
I-54590
Graphics
EVGA GeForce 740 sc
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
I'll check out a tutorial on configurator. looking at all the options in the app seemed more daunting than mounting and editing the text file. Could that error be responsible for glitches etc ? I can boot with the GC installed and get signal from card but just glitchy. also glitchy through intigrated graphics
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
I'll check out a tutorial on configurator. looking at all the options in the app seemed more daunting than mounting and editing the text file. Could that error be responsible for glitches etc ? I can boot with the GC installed and get signal from card but just glitchy. also glitchy through intigrated graphics

Syntax errors can have a big effect on the system
 
Joined
Sep 27, 2015
Messages
14
Motherboard
GIGABYTE GA-Z97M-DS3H
CPU
I-54590
Graphics
EVGA GeForce 740 sc
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
Thanks you've been very helpful SlimJim !
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Status
Not open for further replies.
Top