Contribute
Register

gpu temperature info rx 580 8gb

Status
Not open for further replies.
Joined
Oct 10, 2015
Messages
1,048
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
My RX 580 does not use over 100W during non-gaming usages, on both of macOS and Windows. I don’t understand why yours would consume so high which is really abnormal.

I use one single 4K display.
 
Joined
Oct 10, 2015
Messages
1,048
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
OK I finally captured one record above 100W after many attempts.

"Device Utilization %"=38
"Fan Speed(%)"=0
"Core Clock(MHz)"=1324
"Memory Clock(MHz)"=2000
"GPU Activity(%)"=0
"Fan Speed(RPM)"=0
"Temperature(C)"=50
"Total Power(W)"=116
 
Joined
May 5, 2019
Messages
20
Motherboard
ASUS Z370A
CPU
i7-8700k
Graphics
RX580 Nitro+
Are you using a vanilla install with WEG as well?

In case ioreg / iStat isn't reporting correctly... Does the heat pipes on the card itself feel about the same temperature when idling in both win and macos? Is that with fans off (typically under 50)? Do they feel hot to the touch, mine definately does, but not in win at all when idling.

Perhaps you could share EFI or other relevant settings. Also would be great if others could confirm a power consumption / temperature on RX580 similar to win, to estimate how normal that is to achieve.

I hope @Bustycat and other users of the RX580 can chime in, so I can judge how (ab)normal my situation is, and whether I can change the config to make it use less power.
 
Last edited:
Joined
May 5, 2019
Messages
20
Motherboard
ASUS Z370A
CPU
i7-8700k
Graphics
RX580 Nitro+
I have double checked my wattage in Win10 and it shows around 35W at idle, with a GPU temperature around 38 degrees celcius.

RX580 Win10, sensors.png


RX580 Win10, card info.png


In macos I don't get below around 90W at idle, with temperatures being around 50, here 48 before stabilizing at 50.

Screenshot 2019-10-28 at 17.22.37.png


Is it possible I need to disable some output ports on the graphic card, or what could be the reason for the extra power usage in macos?

What info will be relevant to share to get help?

Can anyone (besides @Bustycat) provide low wattage stats from an RX580 in macos?
 
Joined
May 5, 2019
Messages
20
Motherboard
ASUS Z370A
CPU
i7-8700k
Graphics
RX580 Nitro+
Could it matter if I use DisplayPort or HDMI for my monitor? I use DisplayPort currently. Wondering if unused GFX ports can be turned off.
 
Joined
Apr 3, 2019
Messages
70
Motherboard
ASRock Z390 Phantom Gaming ITX/ac - v4.40
CPU
i7-9700
Graphics
UHD 630 + RX 590 Nitro+
Hey, I'm also interested at this topic although I have a RX 590 Nitro + (instead of a 580), but I'm facing the very same problem : very high temps under macOS

"Device Utilization %"=0
"Fan Speed(%)"=0
"GPU Activity(%)"=0
"Fan Speed(RPM)"=0
"Temperature(C)"=47
"Total Power(W)"=97
"Device Utilization %"=0
"Fan Speed(%)"=0
"GPU Activity(%)"=0
"Fan Speed(RPM)"=0
"Temperature(C)"=47
"Total Power(W)"=97

Power shown by iStat or HWMonitor (tried with FakeSMC and VirtualSMC) is always between 90 and 120W when doing basic tasks, making temps going back and forth around 46 and 58°C with the fans turning on then off periodiclly which is quite annoying. In Windows it stays around 35-45W and rarely goes above 45°C when doing similar tasks. I'm using only one monitor, 2560x1440 @ 144Hz trought HDMI. I also tried the "quiet" BIOS available on the Nitro + without noticeable effect in low load.

I'm on macOS 10.14.6, SMBIOS iMac19,1 with Lilu 1.3.9 + WEG 1.3.3, iGPU seems to be properly configured as headless (I just learnt what it meant...), not showing in system info but in iOReg, HWMonitor and iStat. VideoProc shows both h264 HEVC hrdware compatible but shows "N/A" instead of UHD630 as it should.
Anyway here my main concern is dGPU power consumption.
 
Joined
May 5, 2019
Messages
20
Motherboard
ASUS Z370A
CPU
i7-8700k
Graphics
RX580 Nitro+
I have upgraded to 10.15.1 in hope that power usage would drop on my Radeon RX 580 8GB Sapphire NITRO+, but no luck. Still idling at over 90W. Also in "quiet" BIOS mode. In Windows the RX580 idles around 35W.
SMBIOS iMac19,1 with Lilu 1.3.9, WEG 1.3.4 (and AppleALC 1.4.3 and FakeSMC 1800). Like @Blableuh I have iGPU as headless. I have a single 4K monitor, Dell P2715Q, attached to the RX580 via DisplayPort to mini-DP. No other monitors attached.
I would love to get this issue fixed. What can I do to help troubleshoot the problem?
 
Joined
Jul 11, 2015
Messages
10
Motherboard
Gigabyte Z87P-D3
CPU
E1230 v3
Graphics
RX 560
Mac
  1. iMac
I have upgraded to 10.15.1 in hope that power usage would drop on my Radeon RX 580 8GB Sapphire NITRO+, but no luck. Still idling at over 90W. Also in "quiet" BIOS mode. In Windows the RX580 idles around 35W.
SMBIOS iMac19,1 with Lilu 1.3.9, WEG 1.3.4 (and AppleALC 1.4.3 and FakeSMC 1800). Like @Blableuh I have iGPU as headless. I have a single 4K monitor, Dell P2715Q, attached to the RX580 via DisplayPort to mini-DP. No other monitors attached.
I would love to get this issue fixed. What can I do to help troubleshoot the problem?

iMac Pro (2017)
 
Joined
May 5, 2019
Messages
20
Motherboard
ASUS Z370A
CPU
i7-8700k
Graphics
RX580 Nitro+
iMac Pro (2017)

Can you elaborate a little? Not sure what you mean. Are you suggesting changing the SMBIOS? I'd be happy to try if anyone can confirm a lower power usage using this trick.
 
Joined
Apr 3, 2019
Messages
70
Motherboard
ASRock Z390 Phantom Gaming ITX/ac - v4.40
CPU
i7-9700
Graphics
UHD 630 + RX 590 Nitro+
Can you elaborate a little? Not sure what you mean. Are you suggesting changing the SMBIOS? I'd be happy to try if anyone can confirm a lower power usage using this trick.
Maybe this is what he means as I've seen this advice several times, but iMacPro1,1 is first for Intel Xeon Skylake CPU without iGPU, which is quite far from our i7 Coffe Lake (Refresh in my case) CPU. For me using iGPU is not mandatory but I use it now to help the dGPU to stay cooler (which is not really a success...).
Maybe iMacPro1,1 handles graphic power management for RX 500 cards better than iMac19,x but I have doubts about that as iMacPro1,1 only has Vega while iMac19,x has plenty of RX 500 dGPU.
 
Status
Not open for further replies.
Top