Contribute
Register

GPU Related Kernel Panic - Skylake i7-6700K Sierra 10.12.5!

Status
Not open for further replies.
Joined
Jul 9, 2015
Messages
33
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
is there any chance that changing my CsrActiveConfig to 0x67is throwing the panic?
 
Joined
Oct 25, 2013
Messages
1,054
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
is there any chance that changing my CsrActiveConfig to 0x67is throwing the panic?

Change CsrActiveConfig from 0x03 to 0x67 let you install kext to L/E, 0x03 allow kext install in S/L/E, install kext in L/E have higher priority, inject information to X86PlatformPlugin first before system X86PlatformPlugin load.
You can install it to S/L/E without change CsrActiveConfig 0x3 to 0x67.
 
Joined
Jul 9, 2015
Messages
33
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Alright! You fixed it! The problem was that I had installed the file to S/L/E with 0x67. Moved x86Platform... to L/E with 0x67 and panic fixed.
Now CPU stepping is good, Geekbench is much improved, and video renders without crash!! Now if I can get the ethernet and USB SSDT sorted out, I will have a 100% working Skylake, and I do mean 100%!! You are awesome! Thank you so much! Screen Shot 2017-06-21 at 4.11.59 AM.png

during render>Screen Shot 2017-06-21 at 4.18.06 AM.png

during idle>Screen Shot 2017-06-21 at 4.21.45 AM.png
 
Joined
Jul 9, 2015
Messages
33
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Ok update on this post - Problem 1 Ethernet was killing my network SOLVED - that turned out to be a check box in AirPort Extreme (I disabled IPv6 sharing, and Viola!) both ethernet ports work like a charm[as they have] but the rest of my network stays online! (I feel pretty silly about this one)

Problem 2 - Crashing on video Render SOLVED- Using Shuhung's HWPEnable method with TinySSDT.aml and X86PlatformPluginInjector.kext worked very well when I did two things properly - TinySSDT.aml needed to be in the /EFI/CLOVER/ACPI/origin folder or my system would panic and not boot. Strange, as I would imagine it needed to be in "patched." (someone please feel free to correct me if I'm wrong).

Discovered problem #3 NOT SOLVED when RehabMan looked at my config.plist - and said I did it all wrong. Does anyone have a custom IOreg for a GA-Z170x Designare? Or does anyone else use another method without issue?

Could it be possible that my CPU PM isn't functioning to its full potential because of errors in my IOreg? When I turn off my network audio interfaces, disable bluetooth and wifi, my processor will idle around 1.2Ghz. When those things are on, it straddles 3Ghz - is this normal?

Thank you again everyone for all the help, Best forum ever!
 
Joined
Jul 9, 2015
Messages
33
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Update 8.24.17- so last night gigabyte came out with a new bios, f23b. It's supposed to fix hyperthreading errors. After my last post, there was a few weeks of great operation and a few weeks of terrible crashes, back to the initial problem of instant reboots under video encoding load. After updating the bios and tweaking the HWPEnable values, I think I'm finally at a stable overclock of 4.6 with an xmp1 profile on my 2666 DDR 4, but so far, the successes I've had haven't lasted very long. The thing that gets me is how low the power consumption is at idle(.87w), even though x86PlatformPlugin and shim aren't loading. Should I worry about that, or is the HWPEnable method sufficient for power managment? Also, what would cause the x86PlatformPlugin and shim to refuse to load(and cause KP's with the correct loading directory)? This has been driving me insane, and spoiling what would otherwise be success.
 
Status
Not open for further replies.
Top