Contribute
Register

got imessage running Gygabyte h170n-wifi (finally)!

Status
Not open for further replies.
Joined
Mar 22, 2014
Messages
21
Motherboard
AsRock B360M-ITX/ac
CPU
i3-8100
Graphics
UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Got it all running on my Skylake Gygabyte h170n Board - after months trying now also imessage by today by doing something a little bit differnt (trying around). However, this works now finally:

  1. Log out from iCloud in the system settings
  2. open a terminal session and execute "defaults write com.apple.finder AppleShowAllFiles TRUE"
  3. under /Users/[Username]/Library/Chaches delete all folders starting with:
    1. com.apple.Messages*
    2. com.apple.imfoundation.IMRemoteURLConnectionAgent*
  4. Under /Users/[Username]/Library/Preferences delete all folders starting with:
    1. com.apple.iChat.*
    2. com.apple.imagent.*
    3. com.apple.imessage.*
    4. com.apple.imservice.*
  5. go to /Users/[Username]/Library and perform and delete folder "Messages"
  6. open Disk Utility, chose your partition and perform a "First Aid" - just let the process run through
  7. execute "defaults write com.apple.finder AppleShowAllFiles FALSE"
  8. open CloverConfigurator and mount EFI partition
  9. Load your config.plist into CloverConfigurator
  10. SMBIOS section, click magic wand (For the h170n-wifi I've chosen iMac17,1
  11. now hit the wand several times to generate some random values
  12. Copy Serial Number into the field "Board Serial Number" and add 5 random characters or numbers behind it
  13. DO NOT PUT ANYTHING IN SmUUID Field - delete whatever value is in there and leave it empty! This is the major difference from all other posts (at leasts the ones I've found)
  14. Go to install drivers in CloverConfigurator and install "EmuVariableUefi" (important to not lose your HW UUID all the time)
  15. In Rt Variables just make sure you've set the right network interface in ROM (in my case UseMacAddr0) - leave MLB empty
I've rebooted several times to make sure my HW UUID does not get changed. This can be checked by going to "About This Mac" / System Report and watching out for the entry "Hardware UUID". It remained the same even after several reboots now. Now login into iCloud under System Settings and open imessage. This is the only way I could have iMessage running on my machine since I've installed Sierra couple of months ago.

For all the rest check out ammulders great guide: https://www.tonymacx86.com/threads/guide-el-capitan-on-the-skylake-h170n-wifi.178197/

I hope this works for you too.
 
Joined
Sep 1, 2015
Messages
316
Motherboard
Gigabyte GA-H67MA-USB3-B3
CPU
i7-2600
Graphics
GTX 1050 Ti
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I find the default iMessage guide on the site way too confusing and long, I always follow the generate random smbios and rom value tutorial to be the easiest.

This is the tutorial I follow for all my hacks, works great.

https://www.******.com/r/hackintosh/comments/2wohwn/getting_imessage_working_on_10102_generating/
 
Status
Not open for further replies.
Top