Contribute
Register

Gobias’s Haswell Build: GA-Z87X-UD5H - i7-4770K - RX 580 - macOS Big Sur & Windows 10

Joined
Dec 6, 2013
Messages
148
Motherboard
GA-Z87X-UD5H
CPU
i7-4770K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. Color Classic
Mobile Phone
  1. iOS
Gobias’s Haswell Build
GA-Z87X-UD5H - i7-4770K - RX 580
Dual Boot macOS 11.3 Big Sur & Windows 10
iMac 15,1 - Clover r5133


Case

Change Log

04/24/21: Updated to macOS 11.3 Big Sur
04/24/21: Updated System Definition for Big Sur and Fixed iMessage
04/15/21: Added YOUBO Wifi/Bluetooth Adapter and Configured USB Ports
04/03/21: Updating to Clover r5123+
04/02/21: config.plist Cleanup
04/02/21: Kext Changes
03/12/21: Updated to macOS 10.15.7 Supplemental Update
10/05/20: Updated to macOS 10.15.7
08/23/20: Fixing 4K Monitor Resolution Issues
08/23/20: Updated to macOS 10.15.6 Supplemental Update
08/19/20: Added BenQ PD2720U 4K Monitor
08/03/20: Updated to macOS 10.15.6
05/27/20: Catalina 10.15.5 Supplement Update Issues and Installation
05/27/20: APFS SuperDuper Clone and Update to macOS 10.15.5
05/22/20: Updated to macOS 10.15.4 Catalina
04/13/19: Replaced GTX 660 graphics card with RX 580
04/07/19: Updated to macOS 10.14.4
02/23/19: Updated to macOS 10.14.3 Mojave
12/01/18: USB Audio and SSD Upgrades
08/01/18: Updated to macOS 10.13.6 High Sierra
03/27/16: Updated to OS X 10.11.4
11/29/15: Updated to OS X 10.11.1 El Capitan, Windows 10, and Simplified HDMI Audio
04/26/15: Updated to OS X 10.10.3
04/12/15: Updated to OS X 10.10.2 Yosemite & Switched to Clover Installation
02/21/15: Added Cooler Master Hyper 212 EVO CPU Cooler
11/02/14: Updated to OS X 10.9.5 and resolved USB issues
I ended up deleting GenericUSBXHCI.kext from S/L/E, and then I updated to OS X 10.9.5. After the update, I had to reinstall the audio and TRIM drivers with MultiBeast. However, I did NOT install USB 3.0 - Universal. Now all USB drives are mounting again.:D

10/18/14: boot0, kernel panics, OS X 10.9.4, and USB issues
After tinkering with some boot options, I ended up getting the dreaded boot0 error. Attempting to follow recommended fixes resulted in kernel panics that I could not resolve. I ended up going nuclear and doing a clean install of OS X 10.9.4. Everything was working fine until I recently discovered that most USB drives would not mount.

06/19/14: Updated to OS X 10.9.3
This is a very belated post, but I updated OS X to version 10.9.3. After the update, I had to reinstall the audio and TRIM drivers with MultiBeast, but I have had no other issues.

02/17/14: Added Logo and Modified About This Mac
I have been very happy with my CustoMac, but I felt like something was missing. Then I figured out what it was: an Apple logo. I made my own vinyl Apple logo based on Apple's 30th-anniversary logo and adhered it to my case (seen in the new system picture at the beginning of the build description). I also followed the Mod About This Mac! guide to change the Apple logo, case picture, model, and year in About This Mac.

02/16/14: Enabled HDMI Audio
I hooked my TV up to the GTX 660 and followed the Mavericks: HDMI Audio AppleHDA guide to enable HDMI audio with ssdt.


Components

Intel Core i7-4770K Haswell Processor
Amazon | Newegg

Cooler Master Hyper 212 EVO CPU Cooler (
Added 02/21/15)
Amazon | Newegg

Gigabyte GA-Z87X-UD5H ATX Motherboard DVI/HDMI/DP
Amazon | Newegg

EVGA GeForce GTX 660 Superclocked 2GB GDDR5 2xDVI/HDMI/DP (02G-P4-2662-KR) (Replaced GTX 660 graphics card with RX 580 on 04/13/19)
Amazon | Newegg

Sapphire Radeon Pulse RX 580 8GB (11265-05-20G)
Amazon | Newegg

EVGA SuperNOVA NEX650G 650W PSU (120-PG-0650-GR)
Amazon | Newegg

2 x Corsair Vengeance LP 8GB DDR3 SDRAM 1600 Desktop Memory (CML8GX3M1A1600C10)
Amazon | Newegg

2 x Samsung 840 EVO 6Gb/s SATA 120GB SSD (MZ-7TE120BW) (
Replaced 120GB 840 EVO SSDs with 500GB 860 EVO SSDs on 12/01/18)
Amazon | Newegg


2 x Samsung 860 EVO 6Gb/s SATA 500GB SSD (MZ-76E500B/AM)
Amazon | Newegg

2 x Seagate Barracuda 6Gb/s SATA 2TB HDD (ST2000DM001)
Amazon | Newegg

Fractal Design Define R4 Silent Computer Case - Black Pearl (FD-CA-DEF-R4-BL)
Amazon | Newegg

Logitech Wireless Solar Keyboard K750 for Mac - Silver
Amazon | Newegg

Logitech Wireless Performance Mouse MX
Amazon | Newegg

Kinivo BTD-300 Bluetooth 3.0 USB adapter (
Replaced with YOUBO Wifi/Bluetooth Adapter on 04/16/21)
Amazon | Newegg


YOUBO BCM94360CD 802.11a/g/n/ac BT4.0 PCIe Network Adapter (Added 04/16/21)
Amazon

Sabrent Aluminum USB External Stereo Sound Adapter (AU-EMCB) (Added 12/01/18)
Amazon

Seagate Backup Plus 3 TB USB 3.0 Desktop External Hard Drive (STCA3000101)
Amazon | Newegg

Microsoft Windows 8.1 Professional
Amazon | Newegg


BenQ DesignVue PD2720U 4K Monitor (Added 08/19/20)
Amazon | Newegg

KabelDirekt DisplayPort 1.4 6 ft Cable (Added 08/19/20)
Amazon

Already Owned

Apple Cinema HD Display 23-inch DVI (M9178LL/A) (
Replaced Apple Cinema Display with BenQ PD2720U 4K Monitor on 08/19/20)
eBay Search


Boxes

Comments

The Build
This is not only my first CustoMac build but also my first ever computer build, so I would first like to thank tonymacx86 and the whole tonymacx86.com community as well as numerous other resources on CustoMacs and PC building.

The main purpose of this build was to replace an aging MacBook Pro as my primary computer for photo editing. Here are a few reflections on some of the hardware.

Fractal Design Define R4 Silent Case: Let me start out by saying that this case is very big and very heavy (27.1 lbs!). That said, it is a very well-built case with some great features. The front and side panels are lined with noise absorbing foam, and the result is a machine that is not quite silent but nevertheless very quiet. It also features a large cable management compartment behind the motherboard plate, which is great for hiding my giant bird’s nest of cables and also improving airflow.

Gigabyte GA-Z87X-UD5H Motherboard: This motherboard has more USB 3.0 ports than I know what to do with and even includes an optional 3.5” front panel with two USB 3.0 ports. All ports are tested and working with my Seagate USB 3.0 external hard drive.

Samsung EVO 840 SSD: These are my first SSDs, and what a difference they make. I got two: one for Mac and one for Windows. Both boot quicker than any computer I have ever used, and applications open almost instantly.


Inside the finished build

UEFI Settings
Note: I originally had Internal Graphics and Wake on LAN enabled, but that caused issues. Everything in the Maps app was garbled, but disabling Internal Graphics fixed it. I also could not shut down my computer; it would always restart. Disabling Wake on LAN fixed that.

  1. To access UEFI Setup, press and hold Delete on a USB Keyboard while the system is booting up.
  2. Press F7 to set Optimized Defaults.
  3. In the Peripherals tab
a. Set Init Display First to PCIe 1 Slot if not already selected.
b. Set Internal Graphics to Disabled (fixes Maps graphics bug).

  1. In the Power Management tab, set Wake on LAN to Disabled (fixes shut down issue).
  2. Save and exit.
Peripherals Tab

Wake on LAN

Mavericks Installation
I followed the 10.9 Installation Guide to install OS X Mavericks 10.9 without issue. I have since updated to 10.9.5.

Post-Installation MultiBeast Settings
As this motherboard does not require DSDT, I chose DSDT Free on the Quick Start tab and added these options:

  • Drivers > Audio > Realtek ALCxxx > ALC898
  • Drivers > Disk > TRIM Enabler > 10.9.4+ TRIM Patch
  • Drivers > Misc > FakeSMC v6.9.1315 Plugins
  • Drivers > Misc > FakeSMC v6.9.1315 HWMonitor Application
  • Drivers > Network > Intel > AppleIntelE1000e v2.4.14
  • Customize > Boot Options > 1080p Display Mode

Problems I Encountered with Mavericks
To get the Messages app to work, I tried multiple fixes, but this guide was the only one that worked for me. Note: I had to install FileNVRAM 1.1.2 because version 1.1.3 did not work for me.

Initially, OS X would freeze sometimes when HWMonitor loaded at login. Removing the GPU Sensors plugin from Fakesmc.kext (as recommended in this post) stopped the freezing. However, this is no longer an issue with the latest version of HWMonitor.

Windows 8.1 Installation
I followed the Dual Booting Mountain Lion and Windows 8 Guide to install Mavericks and Windows on separate drives. I had no issue with the actual installation, but I had one problem that almost prevented me from even starting the installation.

I wanted to install Windows from a USB flash drive because I did not put a DVD drive in this build. Unfortunately, making a bootable USB Windows installer requires using Windows 7 USB/DVD Download tool, which only works on Windows, and I did not own a Windows PC. Luckily, I came up with a somewhat elaborate workaround for this. First, I temporarily installed Windows on my Mac as a virtual machine using VirtualBox. Then, I used that Windows virtual machine to create the bootable USB drive with Windows 7 USB/DVD Download tool. From there, I was able to install Windows from the bootable USB drive without any problems.

After installation, I booted into OS X and reinstalled Chimera in Multibeast to add Windows to the Chimera bootloader.

Benchmarks
Geekbench 3


Unigine Heaven 4.0

System Info
 

Attachments

  • GA-Z87X-UD5H_10-9-5.mb
    5.3 KB · Views: 445
  • GA-Z87X-UD5H_10-9-0.mb
    5.5 KB · Views: 363
  • 1555033960087.png
    1555033960087.png
    1.1 MB · Views: 178
Last edited:
Joined
Nov 29, 2013
Messages
14
Motherboard
ASUS Z270E
CPU
I7-7700
Graphics
GT1050
Hi.. I'm a newbie, trying to get installation going..
I have GA-z87x-ud5h and Gigabyte N7600c GTX 760 and 120Gb HDD.
I was initially breaking my head over iBoot 3.3 or 2.7.2 and then realized I had to use Haswell iBoot and got going..
I have Snow Leopard 10.6.3 and I pulled down the 10.6.8 update and the multibeast.
Snow Leopard 10.6.3 completed. During Installation of 10.6.8 and when I looked at multibeast options I found a mismatch in Chimera version. The Haswell was v2.2 and the one in multibeast was v1.7
When I went ahead the system is not booting.

I need to know what I should be doing..
Please help!
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,784
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
You shouldn't have run MultiBeast in 10.6.8 if you want to install Mavericks. Can you boot into 10.6.8 using iBoot? If not, reinstall Snow Leopard.

If you can boot into 10.6.8 using iBoot, then go to the Apple Mac App Store (MAS) and create an account. Then, download Mavericks from the MAS. Once Mavericks is downloaded, download UniBeast for Mavericks and MultiBeast for Mavericks. Create the UniBeast USB thumb drive and put MultiBeast for Mavericks on the UniBeast USB thumb drive. Now, install Mavericks per the 10.9 Guide.
 
Joined
Nov 29, 2013
Messages
14
Motherboard
ASUS Z270E
CPU
I7-7700
Graphics
GT1050
Thanks Stork and Gobias..

I had to remove my GTX 760 Videocard and run the 10.6.8 dmg and no multibeast; Then I was able to get past the errors.

After that I was able to connect to app store and download Mavericks and while running unibeast I ran into issue creating the USB for Mavericks install.

I had to then install the http://support.apple.com/kb/DL1512 to get past that hurdle.

Once that is done.. rest was a breeze.

Now I have 10.9.1 running with Audio / Video (GTX 760); Haven't tried dual monitor yet..

Many thanks to all. I will put together a complete step by step for my config shortly.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,784
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Oh, nuts! I forgot to tell you that the 760 graphics card is too new for Snow Leopard. Glad you discovered this on your own. But, congrats on getting up and running. :thumbup:
 
Joined
Dec 7, 2012
Messages
48
Motherboard
Mavericks 10.9.5 Yosemite 10.10 Windows 7
CPU
i7 4770K
Graphics
HD4600
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Great build :D Gongrats !!
i have the same case :) are ur front panel mic/headphones workin for u ?
cause i dont know how to get them to work :) any suggestions ?
 
Joined
Dec 6, 2013
Messages
148
Motherboard
GA-Z87X-UD5H
CPU
i7-4770K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. Color Classic
Mobile Phone
  1. iOS
I don't have a microphone to test the microphone port, but the headphone port works. Do you have sound from your rear audio ports? If not, double-check your motherboard specs to make sure you installed the correct audio driver with MultiBeast. If you do have sound from the rear ports, verify that the audio cable from the case is properly connected to the audio header on your motherboard.
 
Top