Gigabyte Z77X-UP5 (2013 build) to Catalina

Not open for further replies.
Apr 4, 2020
Gigabyte GA-Z77X-UP5 TH
GTX 680
William's Mac Pro:
Gigabyte Z77X-UP5 TH - i7-3770K - GTX 680


TP-LINK Archer T9E AC1900 Wireless Dual Band PCI Express Adapter Adapter (WiFi)

Already Owned

Gigabyte Z77X-UP5 TH (Motherboard)
(No longer available)

Intel Core i7 3770K/3.50GHz/8MB CACHE/LGA1155 Ivy Bridge (Processor)

Corsair Carbide 500R Black Mid-Tower (Case - No PSU)
(No longer available)

SanDisk Extreme SSD 480G - SATA3/MLC/SF-2281 (OSX Install Drive)
(No longer available)

Corsair HX650v2 650W ATX, 80 PLUS GOLD (Power Supply)
(No longer available)

TP-LINK TL-WDN4800 - 450Mbps Wireless N Dual Band PCI Express Adapter (WiFi)
(No longer available)

Corsair 32GB (4x8GB) Vengeance CMZ32GX3M4A1600C9 (RAM)
(No longer available)

Gigabyte GTX 680 OC EDITION PCI-E 3.0 4GB (Graphics Card)
(No longer available)

This original install was Mountain Lion 10.8.5


I built this back in 2013. It's been flawless. I do my work editing on this machine. However, I've been terrified to upgrade the OS. I literally can't work without it. But, because of Coronavirus, all my work has been cancelled. Perfect opportunity!

I ran into so many roadblocks during 4 days spent on this upgrade. But I found a helpful post for every problem I encountered! I'll try to list links to all the helpful posts for each issue. I did have to replace one piece of hardware - the WiFi card. The old one didn't work in Catalina. It wouldn't even display in the network list. I didn't really look too much to see if it was patchable, just ordered the new one, and it worked straight away. So that was easy.

Problem #1 - Can't download Catalina from app store in Mountain Lion because system definition too old

I sill had Mavericks available in my app store from when I had tried to update previously. So I was able to get that installer downloaded and proceeded to see if I could get Mavericks to work. Install went great, using this guide:

App store still won't let me download Catalina because I'm running a 2008 Mac Pro. Using Mavericks MultiBeast, I change system definition to iMac 14,2 (late 2013).

Problem #2 - App Store gives error message "Your device or computer could not be verified."

This problem was caused because the Mavericks install didn't add an Ethernet driver for my system (apparently the app store checks this???).

More info on this and the fix I used with an amazingly simple walk through (for dummies like me) on this post from @pcmarques:

Finally I'm downloading Catalina from the app store!!!

Problem #3 - Can't create UniBeast USB installer with small downloaded file

The OS update download was very small (about 16mb I think). You have to run the installer to get it to download the bulk of it (around 5GB I think). Then you have to move all this downloaded stuff into the correct place, so UniBeast can find it.

I found full instructions on how to do this here:

The guide is for High Sierra but works equally well for Catalina, with appropriate changes to the terminal code.

Problem #4 - Catalina install boot error

I encountered this error message on a black screen at the very beginning of Catalina install:

boot0: GPT
boot0: test
boot0: test
boot0: GPT
boot0: test
boot0: test
boot0: error

To get past this, I had to update my BIOS from version F11 to latest F12.

Install now goes further until new error...

Problem #5 - macOS could not be installed on your computer. An error occurred while loading the installer resources.

This took me a while to get past, but ultimately this thread helped me out:

You need to manually continue the install with some terminal commands. Read the first couple pages of the above thread, to understand what we're doing. Especially @FabCa's comment on page 2.

But ultimately, there was just one command I needed to type into terminal that worked for me:
cp -rf /Volumes/Install\ macOS\ Catalina/Install\ macOS\* /Volumes/Cats/macOS\ install\ data/
You need to type this exactly. Except for the name of your drive where you're installing the OS. I called my OS drive "Cats". Just replace Cats with whatever you named your drive.

To be sure of the directories you're targeting, in terminal, if you just type mount and hit enter, this gives you a list that includes the directory of your OS drive and the partially complete installer on that drive.

Also remember that you need to type a backslash followed by a space to represent spaces in filenames. (eg, If you named your drive Cats OS Drive you need to type Cats\ OS\ Drive.)

Problem #6 - WiFi doesn't work in Catalina

Unfortunately, I don't know much about this problem except that WiFi wasn't showing up in my new Catalina install at all. I assume the MultiBeast simply doesn't include drivers for this old card?

Anyway, I bought a new WiFi card (the one recommended in the current Mac Pro build). I literally turned my machine off, replaced the WiFi card with the new one, booted up and it worked straight away.

The card is listed above under "New Components".

MultiBeast Settings for Catalina


I mainly wanted to write this post so people running an old OS on a similar system could know it's at least possible to upgrade to Catalina.

I'm so happy my machine is still running fantastic, even with the latest OS. I bought the parts and built this mac in 2013 and it still feels like new!

This forum is amazing. Love your work.
Last edited:


Staff member
Sep 21, 2010
Asus ProArt Z490 Creator
RX 580
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
@WilliamSG, please share your MultiBeast for Catalina settings. (Edit Post #1 is appropriate.)
Not open for further replies.