Contribute
Register

Gigabyte Z77N-WIFI won't boot after HDMI Audio DSDT Install

Status
Not open for further replies.
Joined
Nov 13, 2012
Messages
3
Motherboard
10.8.3
CPU
3770K
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
Hello,

I've just installed the HDMI Audio DSDT for the Gigabyte Z77N-WIFI (with Bios version F2).

I followed this guide: http://www.tonymacx86.com/mountain-...-customac-mini-2012-guide-notes-progress.html

But I'm stuck at the boot screen (white with grey Apple logo).

Verbose mode screenshot: Photo 17-05-13 00.24.00.jpg

CPU: 3770K

Hope one of you guys can tell me what's wrong, and how it can be fixed.

Thanks in advance
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,090
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I've just installed the HDMI Audio DSDT for the Gigabyte Z77N-WIFI (with Bios version F2).

Hope one of you guys can tell me what's wrong, and how it can be fixed.
Boot with DSDT=NULL. Did you rename the dsdt from the data base to DSDT.aml? If yes, delete Extra/DSDT.aml and restart.
 
Joined
Nov 13, 2012
Messages
3
Motherboard
10.8.3
CPU
3770K
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
Boot with DSDT=NULL. Did you rename the dsdt from the data base to DSDT.aml? If yes, delete Extra/DSDT.aml and restart.

Thanks, works like a charm.

Do you got any ideas on how to enable HDMI Audio then? Thanks.
 
Joined
Nov 10, 2011
Messages
1,455
Motherboard
GA-H77N-WIFI F4
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
  1. Android
Thanks, works like a charm.

Do you got any ideas on how to enable HDMI Audio then? Thanks.

1. Boot you system with DSDT=NULL again in order to be sure you are running your system with vanilla DSDT.
2. Download MaciASL and start it. The main window will appear with your current (vanilla) DSDT.
3. Select Patch from the toolbar, press Open and use this patch to patch the DSDT.
4. Close this windows and press Compile on the toolbar to check it.
5. If there are no error (there shouldn't be such), File/Save as and save it as /Extra/DSDT.aml (don't forget the dropdown menu with the file format, it has to be AML and not DSL).
6. Start MultiBeast and select Drivers & Bootloaders/Drivers/Audio/Realtek ALC8xx/With DSDT/ALC892. Nothing else.
7. Repair the permissions and rebuild the kext cache with Kext Wizard, then reboot.

But before you do all the above steps, make sure:

1. You don't have any HDAEnablers (HDAEnabler*.kext) in /S/L/E.
2. Your board is configured according to this post.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,090
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Nov 13, 2012
Messages
3
Motherboard
10.8.3
CPU
3770K
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
Thank you very much both. It's working flawlessly now. I appreciate it!
 
Joined
May 2, 2013
Messages
11
Motherboard
Gigabyte GA-Z77N-WIFI
CPU
Intel i5-3570k
Graphics
Intel HD4000
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS

The patch may be obsolete, but the step-by-step instructions that were provided by philip_petev were exactly what I was looking for to get the HDMI audio going on my Gigabyte GA-Z77N-WiFi MB. I read through the Easy Guide and had absolutely no clue of what I needed to do, as I am very, very new at this :oops:

I have a 95% working Customac, but I just need a little hand-holding to get the last couple of items fixed (the other being my HDMI video that is all garbled until I power-cycle the monitor). Any help would be very much appreciated.

Thanks in advance!

KC
 
Status
Not open for further replies.
Top