Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
May 13, 2020
Messages
15
Motherboard
Gigabyte Vision G Z490
CPU
I7-10700
Graphics
UHD 630 + RX 570
Mobile Phone
  1. iOS
Failed trial so far:
1. Removed all SSD except CATALINA - doesn't work (A)
2. Tried 2nd M.2 slot (for Catalina NVME SSD) - doesn't work (A)
3. Used USB to boot, recover OS - doesn't work - (B)

A == login screen shows as as usual like it used to, put password... nothing (see screenshot)
B == Mac logo shows up and nothing
In both A or B nothing is happening after that point, I waited as long as an hour
Could you try to set false DisableIOmapper then reboot again ?
If it crashes, set false drop dmar, and unselect dmar aml files then reboot again.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Failed trial so far:
1. Removed all SSD except CATALINA - doesn't work (A)
2. Tried 2nd M.2 slot (for Catalina NVME SSD) - doesn't work (A)
3. Used USB to boot, recover OS - doesn't work - (B)

A == login screen shows as as usual like it used to, put password... nothing (see screenshot)
B == Mac logo shows up and nothing
In both A or B nothing is happening after that point, I waited as long as an hour
Some comments:
  • I recommend making a bootable backup using disk cloning software such as Carbon Copy Cloner. This kind of problem can be avoided if we have a bootable backup.
  • Because Recovery does not launch, your choices now are very limited:
    • Option 1: Install Catalina on a spare SATA or NVMe SSD
      • Create a new USB install disk using the same EFI folder
      • Boot from the USB install disk
      • Then install Catalina on the spare SSD
    • Option 2: Install the Catalina NVMe SSD into an external enclosure such as this one.
      • Connect this enclosure to another Mac that is working
      • Transfer the files you need to the other Mac
      • Then try running the macOS Catalina installer on this enclosure -- it should reinstall Catalina without deleting the home folder
        • But backup all files from the home folder first
 
Joined
Jun 2, 2020
Messages
60
Motherboard
GIGABYTE Z490 Aorus Master
CPU
i9-10900K
Graphics
RX 580
2. Nothing, password is accepted (as it doesn't complain for wrong password), but then nothing happens on that screen, no progress bar or next screen
Sounds like you have FileVault enabled. Please show us the EFI folder you are using.
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** Quick Note on macOS 13: Ventura **

Apple intends to release a public beta of Ventura next month. As soon as it's available, I'll post a mini-guide explaining (a) OpenCore configuration, (b) installation options, and (c) what works and what does not work. Meanwhile, consider upgrading to latest version of macOS Big Sur or Monterey if you are still on Mojave or Catalina. And latest version of OpenCore (0.8.1).
 
Joined
May 27, 2020
Messages
12
Motherboard
Gigabyte Z490 Vision-D
CPU
i9-10900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Some comments:
  • I recommend making a bootable backup using disk cloning software such as Carbon Copy Cloner. This kind of problem can be avoided if we have a bootable backup.
  • Because Recoverydoes not launch, your choices now are very limited:
    • Option 1:Install Catalina on a spare SATA or NVMe SSD
      • Create a new USB install disk using the same EFI folder
      • Boot from the USB install disk
      • Then install Catalina on the spare SSD
    • Option 2: Install the Catalina NVMe SSD into an external enclosure such as this one.
      • Connect this enclosure to another Mac that is working
      • Transfer the files you need to the other Mac
      • Then try running the macOS Catalina installer on this enclosure -- it should reinstall Catalina without deleting the home folder
        • But backup all files from the home folder first
Thanks @CaseySJ - went with option 2 - I got a similar M.2/NVME-2-USB adapter, and got all my remaining data out from Catalina NVME-SSD - so all good on personal data part.

Thanks for your input/help, and sorry for killing your time on this :) - just a silly mistake on my side. So now I can re-do the whole installation again.
 
Joined
May 27, 2020
Messages
12
Motherboard
Gigabyte Z490 Vision-D
CPU
i9-10900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Could you try to set false DisableIOmapper then reboot again ?
If it crashes, set false drop dmar, and unselect dmar aml files then reboot again.
Tried didn't do anything different. Thanks for the help, now that I have my data out, I will rather format and re-do installation instead of more debug. It would have been nice though to fix this, as I see the Catalina SDD is all fine when used via a USB adapter, it did asked me for admin/pwd and let me copy my stuff out.
 
Joined
May 27, 2020
Messages
12
Motherboard
Gigabyte Z490 Vision-D
CPU
i9-10900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS

Attachments

  • Screen Shot 2022-06-15 at 8.41.30 PM.png
    Screen Shot 2022-06-15 at 8.41.30 PM.png
    47.9 KB · Views: 13
  • Screen Shot 2022-06-15 at 8.41.43 PM.png
    Screen Shot 2022-06-15 at 8.41.43 PM.png
    46.2 KB · Views: 15
Last edited:
Joined
Apr 27, 2013
Messages
167
Motherboard
GA-Z490 Vision D
CPU
i9-10900K
Graphics
UHD 630
Mac
  1. iMac
sorry for offtop, but is there a way to boot in verbose mode without -v flag in OpenCore?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
sorry for offtop, but is there a way to boot in verbose mode without -v flag in OpenCore?
Yes, this is very easy in OpenCore boot picker. Please see screenshot/diagram at the end of this post:
 
Joined
May 27, 2020
Messages
12
Motherboard
Gigabyte Z490 Vision-D
CPU
i9-10900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
@CaseySJ - Good news :) - my issue got solved - on not booting post login... I took all my data out (using NVME-2-USB adapter), and today thought let me format that NVME SSD and install OS again, since I already have the old USB from Oct/2020.

So I started with step 6 (and good that by this time I didn't format that Catalina NVME SSD)

-------Prepare Vision-D:
-------The remaining steps take place on the Z490 Vision-D.
-------Step 6: Open the spoiler and configure BIOS/Firmware parameters on Z490 Vision-D

- I matched all BIOS settings and saved as a new PROFILE, rebooted
- Then I saw -------Step 7: Unlock MSR 0xE2 (CFG-Lock) -- Firmware (BIOS) F2 to F5a only

And thought - I didn't try this on my debug/fix session, so I tried it, and yes this Catalina NVME-SSD was locked (I don't know how), so when I followed step 7 and it got unlocked (CFG-Lock)... and for testing I tried boot-login again everything started working like it was before. Yaay!!! :headbang: - and so I didn't continue on any next step (my issue is gone).

Thanks again for your help/input, your build and all of the documented steps are as usual rock solid. Now I think instead of having a time machine backup (which I don't use because I keep copying data to external drives), I will rather make a bootable backup like you suggested/documented (Step 13). Will update some other day.

[ For new readers - anyone reading my reply (this instance), please refer to my previous post to understand the whole scenario... it is unique case, where accidentally I removed the Catalina NVME-SSD and booted my hackintosh, don't try to apply this solution to every problem... follow the troubleshoot section, consult CaseySJ/other-admin please) ]
 
Top