Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,547
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks, @CaseySJ. My bad, I didn't read it properly.:( I decided install the Fenvi FV-T919 again as it's still definitive better option for now.:)

Another question, I use 'OC-078-Intel-Wireless-VISION-D' with OpenCore 0.8.1. I'm getting the annoying messages before arriving to the bootpicker. What is the easiest way to remove it?
post 1 explains on how to update opencore
 
Joined
May 4, 2019
Messages
27
Motherboard
Dell XPS 15 7590
CPU
i9-9980HK
Graphics
GTX 1650
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi, guys. I built this exact configuration over a year ago (only the case is different), and I have been using it with great success since then. Now I need to go back to boot directly into Windows ,and I have noticed that Windows cannot see Thunderbolt external drives when connected (like a Samsung x5).

I have reprogrammed the Thunderbolt chip at the time, maybe that's the problem under windows now? I tried to search this thread but could not find people with the same problem so I thought I would ask. Thanks a lot.

F05 BIOS and latest version of OpenCore.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,138
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi, guys. I built this exact configuration over a year ago (only the case is different), and I have been using it with great success since then. Now I need to go back to boot directly into Windows ,and I have noticed that Windows cannot see Thunderbolt external drives when connected (like a Samsung x5).

I have reprogrammed the Thunderbolt chip at the time, maybe that's the problem under windows now? I tried to search this thread but could not find people with the same problem so I thought I would ask. Thanks a lot.

F05 BIOS and latest version of OpenCore.
When we flash the Thunderbolt firmware, it enables Thunderbolt Bus in macOS. But it causes problems in Windows and Linux. So if you no longer need to run macOS on this system, then it's highly recommended to flash back the original Thunderbolt firmware.
 
Joined
May 4, 2019
Messages
27
Motherboard
Dell XPS 15 7590
CPU
i9-9980HK
Graphics
GTX 1650
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
thanks @CaseySJ, is the original bin available? I used my raspberry last time and since then I changed the image on it. I don't know if I have the original file.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,138
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@rd3500 @cliffDeane

Attached is the original Thunderbolt NVM 50 for Gigabyte Z490 Vision D.
 

Attachments

  • Vision-D-1.bin.zip
    275.9 KB · Views: 16

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,138
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Even modifying directly SSDT-5, dropping the OEM table and injecting the modified table still does not produce GFX0 attachment:
View attachment 548370
GPU device ID spoofing requires WhateverGreen.kext. It's also better to try the earlier, simpler SSDT such as the one I posted.
 
Joined
May 23, 2022
Messages
31
Motherboard
Gigabyte Vision G Z490
CPU
10700K
Graphics
RX580
This is so strange. In Big Sur, it loads the dext and works fine. In Monterey, it loads the kext and does not work.

@jaymonkey would you mind sanitizing and sharing your config/EFI?
 

Attachments

  • Screen Shot 2022-05-31 at 9.12.04 AM.png
    Screen Shot 2022-05-31 at 9.12.04 AM.png
    51.5 KB · Views: 10
  • Screen Shot 2022-06-01 at 6.42.58 AM.png
    Screen Shot 2022-06-01 at 6.42.58 AM.png
    43 KB · Views: 11
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,138
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
This is so strange. In Big Sur, it loads the dext and works fine. In Monterey, it loads the kext and does not work.

@jaymonkey would you mind sanitizing and sharing your config/EFI?
In Monterey, have you added this device property to the PCI path of i225V?
  • device-id equal to F3158680
Please refer to bottom of this post:
 
Top