Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Dec 23, 2021
Messages
69
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 570
Hi Casey,
Had to take the HackinDrom SSDT out but here is my folder.
Thunderbolt, Titan Ridge 2 shows under PCI just having a problem connecting my AntelopeAudio Orion 32 Gen 3 to work.
 

Attachments

  • EFI.zip
    4.8 MB · Views: 16
Joined
Jun 10, 2021
Messages
252
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Couple of suggestions:
  • Check “SecureBootModel”. Is it set to Default or Disabled? Try one or the other.
  • If WiFi worked in OC 0.7.6, you can always try that version again by unzipping the backup that was made by HackinDROM. Backup should be in EFI partition.
  • Try downloading the Monterey version of AirportItlwm from OpenIntelWireless website on GitHub and renaming it to AirportItlwm-Monterey.kext, then replacing the file in OC/Kexts folder.
  • If all else fails, try BIOS F20 again. However, if Intel WiFi is working in Big Sur, then BIOS may not be the issue.
Hi Casey, Sorry been busy but just got to doing this now. I tried the suggestions above and managed to get it working downloading the V2.2.0 beta kext. This seems to have got wifi working agin in Monterey. Attached is the kext I am using.
Screen Shot 2022-01-26 at 12.38.42 PM.png
 

Attachments

  • AirportItlwm-Monterey2.kext.zip
    14.7 MB · Views: 10

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi Casey,
Had to take the HackinDrom SSDT out but here is my folder.
Thunderbolt, Titan Ridge 2 shows under PCI just having a problem connecting my AntelopeAudio Orion 32 Gen 3 to work.
Hello @massanalaz,

For Antelope devices, we need to enable AppleVTD, but your EFI is not configured for AppleVTD. Please see this post for instructions:
These instructions apply to Z490 Vision D as well.
 
Joined
Jun 6, 2017
Messages
100
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10600K
Graphics
RX 580 + GTX 710
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Fellas, I screwed up.
I updated my machine to the latest version (12.0 -> 12.1, I think), it was working fine. But now, I am stuck at the bar screen. Does anyone experience related issues?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Fellas, I screwed up.
I updated my machine to the latest version (12.0 -> 12.1, I think), it was working fine. But now, I am stuck at the bar screen. Does anyone experience related issues?
If you look at the bottom right corner of the image in the post below, you'll see how to enable Verbose mode. Please give that a try and see where the boot process stops.
 
Joined
Jun 6, 2017
Messages
100
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10600K
Graphics
RX 580 + GTX 710
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
If you look at the bottom right corner of the image in the post below, you'll see how to enable Verbose mode. Please give that a try and see where the boot process stops.
I can get my FileVault screen, I enter my password and it stucked. Here is a photo of the output;
 

Attachments

  • tempImageyvwaO2.png
    tempImageyvwaO2.png
    17.8 MB · Views: 16

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I can get my FileVault screen, I enter my password and it stucked. Here is a photo of the output;
Because this screenshot is filled with the kernel panic report (a problem in com.apple.security.Sandbox) is it possible to capture a screenshot that shows log messages just before this?
 
Joined
Aug 8, 2018
Messages
84
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@CaseySJ Well a new and interesting problem has emerged in my build. After believing all was well with my dual boot Win 11 & MacOS 12.1 installs, I decided to just leave the machine for a few days without proceeding with my migration from the old system. Was testing how well the new system went into and came out of sleep. Sleep on MacOS seems to work fine for a day or so. But at some point the system will just reboot itself without my intervention. And in this last go round it came up to the OC Canopy menu with MacOS highlighted but I had no USB functionality with my connected keyboard and mouse. It tried to boot into MacOS but failed with no verbose screen. Rebooted itself again, but this time selected the Windows 11 SSD and tried to boot that. But that has failed also with a 'Preparing Automatic Repair' message on a black screen. Ugh. Things work perfectly on this build otherwise. I haven't installed any software or utilities for either OS. Just vanilla installs. Using HackinDROM latest and I even tried updating to OC .7.7 thinking that might help resolve. But nope. Just happened again. I don't know the files or debugging steps needed to get troubleshooting support. But wondering if there are any obvious fixes for this issue that others might have run into.

UPDATE: I decided to just do a hard reboot on the auto repair screen and was able to boot right into Windows with no issues. Expect the same with MacOS. So the root cause of the sleep/wake crash and fail is the issue here.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@misterwiggles

The gods of energy conservation are obviously telling you to power down the machine at the end of each day!

I would suggest to monitor the situation and report back if this occurs again. I have experienced some wake issues recently, but they are occasional and not really bothersome. If you comb through Apple’s own support pages, you’ll see that all sorts of issues affect real Macs as well.
 
Joined
Aug 8, 2018
Messages
84
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@misterwiggles

The gods of energy conservation are obviously telling you to power down the machine at the end of each day!

I would suggest to monitor the situation and report back if this occurs again. I have experienced some wake issues recently, but they are occasional and not really bothersome. If you comb through Apple’s own support pages, you’ll see that all sorts of issues affect real Macs as well.
Interesting. Yes, my brand new M1 Max MBP recently greeted me in the morning with indications that it had rebooted overnight from its sleep state. I took that to be something similar to my Hack issue but could be wrong. It's possible that Monterey 12.1 has some issues in the core OS for this that are showing up more acutely in the Hack build.

Dare I update to today's 12.2 release in hopes of greener pastures?
 
Top