Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,153
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi CaseySJ,
Followed the instructions but my machine froze on start up please see attached grab.
The error in the screenshot means that a UEFI driver in OC/Drivers is missing. Probably the best thing is to compress and post your EFI Folder, but remove serial numbers from PlatformInfo --> DataHub section of config.plist before compressing and posting.
 
Joined
Feb 23, 2012
Messages
47
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi CaseySJ,
I am still struggling with the update from 12.0.1. I followed your instruction to no avail, as I mentioned earlier. The setting was set to "disable".
I found in com.appleSoftwareUpdate.plist the LastUpdateAvailable is set to 0. Is that why I cant to update? I appreciate any help you can provide.
 

Attachments

  • Screen Shot 2022-01-20 at 8.59.00 PM.png
    Screen Shot 2022-01-20 at 8.59.00 PM.png
    104.5 KB · Views: 30
Joined
May 31, 2016
Messages
991
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
If a USB Type A or Type C port is available, I would recommend something like this, which I have been using very reliably with Monterey. This particular model has a Type C connector, but similar products are available with Type A as well.

Type C:

Type A:

Both Type C and A:
I can vouch for the pluggable Type A + Type C. It works on my hack and real macs.
 
Joined
Dec 23, 2021
Messages
77
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 570
Hi Casey,
Had to take the HackinDrom SSDT out but here is my folder.
Thunderbolt, Titan Ridge 2 shows under PCI just having a problem connecting my AntelopeAudio Orion 32 Gen 3 to work.
 

Attachments

  • EFI.zip
    4.8 MB · Views: 17
Joined
Jun 10, 2021
Messages
279
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Couple of suggestions:
  • Check “SecureBootModel”. Is it set to Default or Disabled? Try one or the other.
  • If WiFi worked in OC 0.7.6, you can always try that version again by unzipping the backup that was made by HackinDROM. Backup should be in EFI partition.
  • Try downloading the Monterey version of AirportItlwm from OpenIntelWireless website on GitHub and renaming it to AirportItlwm-Monterey.kext, then replacing the file in OC/Kexts folder.
  • If all else fails, try BIOS F20 again. However, if Intel WiFi is working in Big Sur, then BIOS may not be the issue.
Hi Casey, Sorry been busy but just got to doing this now. I tried the suggestions above and managed to get it working downloading the V2.2.0 beta kext. This seems to have got wifi working agin in Monterey. Attached is the kext I am using.
Screen Shot 2022-01-26 at 12.38.42 PM.png
 

Attachments

  • AirportItlwm-Monterey2.kext.zip
    14.7 MB · Views: 11

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,153
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi Casey,
Had to take the HackinDrom SSDT out but here is my folder.
Thunderbolt, Titan Ridge 2 shows under PCI just having a problem connecting my AntelopeAudio Orion 32 Gen 3 to work.
Hello @massanalaz,

For Antelope devices, we need to enable AppleVTD, but your EFI is not configured for AppleVTD. Please see this post for instructions:
These instructions apply to Z490 Vision D as well.
 
Joined
Jun 6, 2017
Messages
100
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10600K
Graphics
RX 580 + GTX 710
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Fellas, I screwed up.
I updated my machine to the latest version (12.0 -> 12.1, I think), it was working fine. But now, I am stuck at the bar screen. Does anyone experience related issues?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,153
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Fellas, I screwed up.
I updated my machine to the latest version (12.0 -> 12.1, I think), it was working fine. But now, I am stuck at the bar screen. Does anyone experience related issues?
If you look at the bottom right corner of the image in the post below, you'll see how to enable Verbose mode. Please give that a try and see where the boot process stops.
 
Joined
Jun 6, 2017
Messages
100
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10600K
Graphics
RX 580 + GTX 710
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
If you look at the bottom right corner of the image in the post below, you'll see how to enable Verbose mode. Please give that a try and see where the boot process stops.
I can get my FileVault screen, I enter my password and it stucked. Here is a photo of the output;
 

Attachments

  • tempImageyvwaO2.png
    tempImageyvwaO2.png
    17.8 MB · Views: 17

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,153
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I can get my FileVault screen, I enter my password and it stucked. Here is a photo of the output;
Because this screenshot is filled with the kernel panic report (a problem in com.apple.security.Sandbox) is it possible to capture a screenshot that shows log messages just before this?
 
Top