Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,439
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I have a vision D Z490 board with i9 10850K processor, and I am using @CaseySJ 0.7.6 EFI. Do I really need to follow the guide and remap all the USB ports? The only two USB ports that are not working are the two USB 3.0 ports right next to the two thunderbolt ports on the motherboard. Please help!
Two items:
  • Please post the following two screenshots:
    • ACPI section of OpenCore Configurator
    • Kernel section of OpenCore Configurator
  • Are you connecting a USB 2.x or USB 3.x device to those red ports?
 
Joined
Mar 30, 2021
Messages
60
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
RX 6900 XT
Mac
  1. Mac Pro
Two items:
  • Please post the following two screenshots:
    • ACPI section of OpenCore Configurator
    • Kernel section of OpenCore Configurator
  • Are you connecting a USB 2.x or USB 3.x device to those red ports?
@CaseySJ Here are the screenshots you requested, and no, I am connecting USB drives both 2.X and 3.X and MacOS are not detecting the USB drives when I connecting them to those USB ports right next to the thunderbolts ports. Please let me know what can I do, and many many thanks!
 

Attachments

  • Screen Shot 2021-12-21 at 11.55.19 AM.png
    Screen Shot 2021-12-21 at 11.55.19 AM.png
    286 KB · Views: 21
  • Screen Shot 2021-12-21 at 11.56.05 AM.png
    Screen Shot 2021-12-21 at 11.56.05 AM.png
    398 KB · Views: 23
  • Screen Shot 2021-12-21 at 11.56.22 AM.png
    Screen Shot 2021-12-21 at 11.56.22 AM.png
    388.9 KB · Views: 24
Joined
Nov 25, 2021
Messages
13
Motherboard
Gigabyte Z490M
CPU
i5-10500
Graphics
UHD 630
@CaseySJ
Much thanks for your Demo-EFIs and explanations. You helped me a lot for my first successful Hackintosh installation. I did build a Monterey 12.1 Hackintosh with Gigabyte Z490M motherboard, SATA-SSD, i5-10500 CPU, 32 GB Ram, iGPU-UHD-630, using HDMI out. I just got it working with an additional old Radeon HD 7790 card as the output card without iGPU use before i found your EFI.

It would be nice to hear from you on these two short questions for a hint to your Gigabyte-Z490-iGPU-OC 0.7.6-BigSur EFI:

1. My audio works on rear analog output (ALC887 with alcid=1). But i have an additional choice for DigitalOut in system preferences -> sound -> output. But using that choice I do not have any HDMI embedded audio out, so HDMI embedded audio from monitor keeps silent with that choice. Do you have any hint for me to get iGPU-UHD-630 HDMI output with embedded digital audio working?

2. I was not able to get iGPU-UHD-630 with HDMI out working with the settings recommended in the official OC comet lake guide. Always black screen and stopping before any apple logo screen on a Big Sur and Monterey USB-installer. After installation with Radeon HD 7790 works i found your additional settings in you Gigabyte-Z490-iGPU-OC 0.7.6-BigSur EFI. With this settings installer now works with OC 0.7.6 and Big Sur 11.2.3 (for USBPorts.kext generating) and then for Monterey 12.1 without any problems with iGPU-UHD-630 HDMI output (no more Radeon HD 7790 card needed). I did not found any hint on the extra EFI settings (see following picture) in the OC comet lake guide. Can you give me a hint where to find the guide on how to get these extra settings and why these settings?

Thank you and again great thanks for your perfect guide and EFIs.

OS-Monterey-12.1__config.plist__iGPU-UHD-630.jpg


I am missing the OC comet lage guide needed framebuffer-stolenmem - Data - <00003001> setting for iGPU use. Is this setting no more needed with the other settings or any other reason?
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,439
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ Here are the screenshots you requested, and no, I am connecting USB drives both 2.X and 3.X and MacOS are not detecting the USB drives when I connecting them to those USB ports right next to the thunderbolts ports. Please let me know what can I do, and many many thanks!
Some more questions:
  • Are you running Big Sur or Monterey?
  • Do the same USB drives work on other USB ports?
  • Have you tried a CMOS Reset?
 
Joined
Mar 30, 2021
Messages
60
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
RX 6900 XT
Mac
  1. Mac Pro
Some more questions:
  • Are you running Big Sur or Monterey?
  • Do the same USB drives work on other USB ports?
  • Have you tried a CMOS Reset?
I am running Big Sur currently, and it’s about to upgrade to Monterey to try my luck. Yes, the USB drives work fine on the other USB ports. I tried a CMOS reset but it still doesn’t work!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,439
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS

1. My audio works on rear analog output (ALC887 with alcid=1). But i have an additional choice for DigitalOut in system preferences -> sound -> output. But using that choice I do not have any HDMI embedded audio out, so HDMI embedded audio from monitor keeps silent with that choice. Do you have any hint for me to get iGPU-UHD-630 HDMI output with embedded digital audio working?
Hello @tobipa

If you set audio to Optical Digital Output then all sound will be redirected to that output. If you then select your monitor for sound output, then all sound will go there. I’m not sure if we can send sound to two outputs at the same time.


2. I was not able to get iGPU-UHD-630 with HDMI out working with the settings recommended in the official OC comet lake guide. Always black screen and stopping before any apple logo screen on a Big Sur and Monterey USB-installer. After installation with Radeon HD 7790 works i found your additional settings in you Gigabyte-Z490-iGPU-OC 0.7.6-BigSur EFI. With this settings installer now works with OC 0.7.6 and Big Sur 11.2.3 (for USBPorts.kext generating) and then for Monterey 12.1 without any problems with iGPU-UHD-630 HDMI output (no more Radeon HD 7790 card needed). I did not found any hint on the extra EFI settings (see following picture) in the OC comet lake guide. Can you give me a hint where to find the guide on how to get these extra settings and why these settings?

Thank you and again great thanks for your perfect guide and EFIs.
If iGPU is working (including HDMI port) then you are done! No further changes needed. Stolen mem is generally used on older motherboards; not needed on this board.
 
Joined
Nov 25, 2021
Messages
13
Motherboard
Gigabyte Z490M
CPU
i5-10500
Graphics
UHD 630
@CaseySJ
Thanks for the answer and sorry for the confusion. I am coming from windows PCs and this is my first Hackintosh.

On PCs i can hear the sound over HDMI embedded audio with my monitor which is extracting the digital audio from the HDMI signal. I just want to know if it is possible on a Hackintosh with iGPU-UHD-630 HDMI output to switch the audio output from the analog rear output (which is now working with extra analog loudspeakers) to an embedded HDMI audio which i can hear over the monitor build in loadspeakers like with a PC and if yes what kext or setting i may have to add to try to get an embedded HDMI audio out choice option in the sound -> output selection? - i have now four audio out options in sound -> output, but the choice named DigitalOut (with type: optical digital-out port) is not working and the others three choices seems of a type: analog line-out port (rear out / front-out / other-out).

Everything seems now working over iGPU-UHD-630 HDMI output with these extra iGPU settings (see my picture) from your EFI. But these settings may change for future macOS or other CPU/iGPUs mainboard combinations. So i just want to know for future installations where i can find a guide or information to find these extra settings (see my picture) by myself from a guide or software tool or other information links?

Thank you for any answer.
 
Last edited:
Joined
May 13, 2020
Messages
15
Motherboard
Gigabyte Vision G Z490
CPU
I7-10700
Graphics
UHD 630 + RX 570
Mobile Phone
  1. iOS
I just noticed your post there. I've never been able to get my Vision G to sleep successfully. I always thought it was my Fenvi card. How does the CPU base clock change fit into this solution? Thanks.
When my PC went to sleep, it always restarted instead of sleeping. I don't why. I just changed CPU clock to 100Mhz, my PC sleep successfully.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,439
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ
Thanks for the answer and sorry for the confusion. I am coming from windows PCs and this is my first Hackintosh.

On PCs i can hear the sound over HDMI embedded audio with my monitor which is extracting the digital audio from the HDMI signal. I just want to know if it is possible on a Hackintosh with iGPU-UHD-630 HDMI output to switch the audio output from the analog rear output (which is now working with extra analog loudspeakers) to an embedded HDMI audio which i can hear over the monitor build in loadspeakers like with a PC and if yes what kext or setting i may have to add to try to get an embedded HDMI audio out choice option in the sound -> output selection? - i have now four audio out options in sound -> output, but the choice named DigitalOut (with type: optical digital-out port) is not working and the others three choices seems of a type: analog line-out port (rear out / front-out / other-out).
Understood. Two things to check:
  • In the Sound menubar option please see if your monitor's name is listed. Whenever HDMI audio is available, the name of the monitor will appear here. Because I'm away from home, here's what my 14" MacBook Pro shows. Under Output you should see the name of your monitor.
Screen Shot 2021-12-22 at 7.18.12 AM.png

  • If the name of your monitor does not appear, please post screenshots of OpenCore Configurator --> Device Properties as shown:
Screen Shot 2021-12-22 at 7.22.16 AM.png
Screen Shot 2021-12-22 at 7.22.12 AM.png


Everything seems now working over iGPU-UHD-630 HDMI output with these extra iGPU settings (see my picture) from your EFI. But these settings may change for future macOS or other CPU/iGPUs mainboard combinations. So i just want to know for future installations where i can find a guide or information to find these extra settings (see my picture) by myself from a guide or software tool or other information links?
...
One of the first guides I created was to address this issue. It's a bit old now, but still relevant. It's located here:
Thanks to @deeveedee for filling in for my negligence in answering the questions there! :)
 
Top