Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Dec 10, 2011
Messages
35
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 570
Mac
  1. iMac
Mobile Phone
  1. iOS
Hmmm. It doesn't seem widespread so I wonder if it's a config issue, or has something to do with which USB port the card is plugged in to.

EDIT - Regarding Bluetooth magic mouse not reconnecting after wake. It's a major usage hindrance since I need to reboot to wake sometimes.
 
Last edited:
Joined
Sep 26, 2010
Messages
118
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
This just showed up on my Z490 Vision D hack. Should I reinstall 12.0.1? The OSX side of this Dual boot machine has been wildly unstable. OSX 12.0.1 freezes almost daily. The Windows 11 side runs like a champ w/ no issues. I'm convinced it's a software / config issue. I just update OpenCore to 0.7.6 and the only change I made to Casey's EFI was to remove boot argument agdpmod=pikera (for my Vega 64) and set AAPL,ig-platform-id to 0300C89B (for headless Comet Lake iGPU). Any advice would be appreciated I've been troubleshooting this build for a week and I'm stumped. My BIOS is exactly as specified by the guide, I'm on Firmware F5.
I had exactly same issues after installing BIOS F21b, flashed F20 and all gone.
 
Joined
Mar 26, 2013
Messages
132
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Hi, thanks @CaseySJ another successfull update to OC 076:clap:
Quick question: should i enable ThirdPartyDrives Quirk for my old Samsung SATA SSD (used for some data only) or use trimforce enable command?
Note: My 2 "system" NVMe are PNY CS3030 (not Samsung) so they are fine with Trim i think.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,513
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi, thanks @CaseySJ another successfull update to OC 076:clap:
Quick question: should i enable ThirdPartyDrives Quirk for my old Samsung SATA SSD (used for some data only) or use trimforce enable command?
Note: My 2 "system" NVMe are PNY CS3030 (not Samsung) so they are fine with Trim i think.
Sure, feel free to try ThirdPartyDrives. It will enable trim automatically. Please refer to this post for more information:
 
Joined
Jan 31, 2011
Messages
133
Motherboard
Gigabyte Z490 Vision D rev 1.1
CPU
i7-10700
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I can understand the frustration. Why not use the Intel Bluetooth module that's preinstalled on the motherboard? Basic Bluetooth connection will work. Apple's Handoff/Continuity functions aren't supported.
Interestingly, the BT400 seems to be the same chip set as the built in. What steps are needed again to enable the built-in? Do I need a kext? At present you can't turn bluetooth on at all. I don't have the antennas installed at the moment.
 
Joined
Dec 22, 2019
Messages
7
Motherboard
Z490 Vision D
CPU
10700K
Graphics
Radeon 580
Updated to 0.7.6 yesterday and even though all things were fine, I noticed a critical stuff for me - Sidecar stopped working properly.

It allows me to switch to iPad (2021 Pro, 12"), however after few second (around 10-15) the screen on my iPad got frozen (mouse and the other stuff), even though the system worked well.

That's a critical for me, so I rolled back to 0.7.5 - I didn't have issues with SideCar there.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,513
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Updated to 0.7.6 yesterday and even though all things were fine, I noticed a critical stuff for me - Sidecar stopped working properly.

It allows me to switch to iPad (2021 Pro, 12"), however after few second (around 10-15) the screen on my iPad got frozen (mouse and the other stuff), even though the system worked well.

That's a critical for me, so I rolled back to 0.7.5 - I didn't have issues with SideCar there.
I just checked Sidecar on my Z490 Vision D, and it works just fine with this configuration:
  • Monterey 12.1
  • OpenCore 0.7.6
  • iMac19,1
  • Fenvi FV-T919 WiFi/BT module
  • Connecting to iPad mini 6 and iPad mini 5
I used Sidecar for 20 minutes before posting (used the Apple News app to pass the time).
Screen Shot 2021-12-10 at 1.52.29 PM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,513
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Interestingly, the BT400 seems to be the same chip set as the built in. What steps are needed again to enable the built-in? Do I need a kext? At present you can't turn bluetooth on at all. I don't have the antennas installed at the moment.
With the Asus BT400 connected to a USB port, please run IORegistryExplorer and scroll (avoid using the 'search' field) the list on left side until you find the USB port it's connected to. Then click on the device name such that idProduct and idVendor are shown on the right side, and post a screenshot. Please see this example (for Broadcom Bluetooth):
Screen Shot 2021-12-10 at 2.21.40 PM.png
 
Top