Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Apr 30, 2020
Messages
65
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Thanks @CaseySJ for this awesome tutorial! I managed to install MacOS, but I have the same issue as @one07. When MacOS enters sleep it almost immediately turns off.
I've tried the following:
  1. All possible combinations of sleep options - no luck.
  2. Setting hibernatemode, proximitywake, tcpkeepallive to 0 using Hackintool v3.4 - no luck.
  3. Adding darkwake=8 to boot-args no luck. I believe that the argument might not be picked up at all, as failure diagnostics report contains the following line Boot args: keepsyms=1 dart=0 debug=0x100 agdpmod=pikera alcid=11 shikigva=80

Next steps:
  1. Will try darkwake=0
  2. Check if the same issues occurs on Windows.
  3. Remove Fenvi card.
I will update the thread once I test those scenarios.

That's interesting. Which RX 5700 XT do you use? Can you share some more details about your specs please? Maybe we find something which is specific to our builds...

btw.: I'm still waiting for the reply from Gigabyte about this issue
 
Last edited:
Joined
Dec 7, 2013
Messages
49
Motherboard
Gigabyte GA-Z97X-SOC
CPU
i7-4790
Graphics
2x Vega 56 (Vega 64 Bios)
Mac
  1. MacBook Pro
Netflix - Yes it works in Chrome, and is only a problem in Safari.

iCloud - yes I-message works and downloaded all my apps from App Store

Handoff - yes works, tested opening a website from my phone to the Hackintosh

Wifi - Using the BCM94360CD with PCIE adapter on the x1 slot

Below is the screenshot of my Hackintool - interesting that the iGPU device id is different

I think I resolved my issue, I was on the old BIOS F2 that came with the board, after I updated to F5a bios the DRM started working!
 
Joined
Dec 7, 2013
Messages
49
Motherboard
Gigabyte GA-Z97X-SOC
CPU
i7-4790
Graphics
2x Vega 56 (Vega 64 Bios)
Mac
  1. MacBook Pro
@CaseySJ
Thanks for changing the post to correct thread.:)
Unfortunately I currently have only this picture of the custom loop but it should show all the relevat parts.
Took some time first to figure out the correct order, so that you can fill the whole loop from the top easily. After you’ve built and teared it down a few times it becomes clearer what works and what does not so well.
View attachment 479187
This is awesome, I am rethinking of hooking up my 2x240mm rads to water cool with 2 Vega GPUs! Where did you hook up the PWM for the PUMP motor? Just curious as sometimes the Vega chip can be hotter than the CPU
 
Joined
Jul 5, 2020
Messages
6
Motherboard
Z490
CPU
i7-10700k
Graphics
Radeon RX 5700 XT
Happy to report that replacing my FenviT919 card with the link below solved the sleeping issue for me.

https://www.amazon.com/dp/B082X8MBMD/?tag=tonymacx86com-20

Seems like Fenvi also makes this card - the instruction/pamplet had "FENVI" on it.

Looks like I might have the same problem as Fenvi T919 was causing issue with sleep (I couldn't wake up the PC). I ordered the card you've recommended and once it's delivered I will update the thread.

Also I haven't used non-laptop device in the last 10-15 years, so once PC entered sleep (both on MacOS/Win10)
  1. Fans stopped almost immediately.
  2. All RGB and LED lights went off.
  3. I heard this characteristic click on PSU.
So I misdiagnosed entering sleep mode as turning off in my previous post, where actually my PC was entering sleep correctly on both MacOS/Win10, but couldn't wake it up, because of the Fenvi card.

The card that is not working for me is this one: https://www.amazon.com/gp/product/B07WGS46PY/?tag=tonymacx86com-20?tag=tonymacx86com-20 (It may work for others though)


That's interesting. Which RX 5700 XT do you use? Can you share some more details about your specs please? Maybe we find something which is specific to our builds...

btw.: I'm still waiting for the reply from Gigabyte about this issue
I'm using Gigabyte Radeon RX 5700 XT Gaming OC 8G, but it looks like it's not related to the graphic card (see above). If it's relevant, initially I had BIOS F2, but it couldn't recognize my Radeon and it worked after upgrading to F5a.
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
13,917
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Looks like I might have the same problem as Fenvi T919 was causing issue with sleep (I couldn't wake up the PC). I ordered the card you've recommended and once it's delivered I will update the thread.

Also I haven't used non-laptop device in the last 10-15 years, so once PC entered sleep (both on MacOS/Win10)
  1. Fans stopped almost immediately.
  2. All RGB and LED lights went off.
  3. I heard this characteristic click on PSU.
So I misdiagnosed entering sleep mode as turning off in my previous post, where actually my PC was entering sleep correctly on both MacOS/Win10, but couldn't wake it up, because of the Fenvi card.

The card that is not working for me is this one: https://www.amazon.com/gp/product/B07WGS46PY/?tag=tonymacx86com-20?tag=tonymacx86com-20 (It may work for others though)



I'm using Gigabyte Radeon RX 5700 XT Gaming OC 8G, but it looks like it's not related to the graphic card (see above). If it's relevant, initially I had BIOS F2, but it couldn't recognize my Radeon and it worked after upgrading to F5a.
Please let us know if the replacement WiFi/BT card works better (i.e. does not prevent wake-from-sleep). Are you in US, EU, Asia, etc? I wonder if different regions have different issues with WiFi/BT.
 
Joined
Jul 5, 2020
Messages
6
Motherboard
Z490
CPU
i7-10700k
Graphics
Radeon RX 5700 XT
Please let us know if the replacement WiFi/BT card works better (i.e. does not prevent wake-from-sleep). Are you in US, EU, Asia, etc? I wonder if different regions have different issues with WiFi/BT.
I'm in the US. Yeah, I will let you know once I test the card.
 
Joined
Apr 30, 2020
Messages
65
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Looks like I might have the same problem as Fenvi T919 was causing issue with sleep (I couldn't wake up the PC). I ordered the card you've recommended and once it's delivered I will update the thread.

Also I haven't used non-laptop device in the last 10-15 years, so once PC entered sleep (both on MacOS/Win10)
  1. Fans stopped almost immediately.
  2. All RGB and LED lights went off.
  3. I heard this characteristic click on PSU.
So I misdiagnosed entering sleep mode as turning off in my previous post, where actually my PC was entering sleep correctly on both MacOS/Win10, but couldn't wake it up, because of the Fenvi card.

The card that is not working for me is this one: https://www.amazon.com/gp/product/B07WGS46PY/?tag=tonymacx86com-20?tag=tonymacx86com-20 (It may work for others though)



I'm using Gigabyte Radeon RX 5700 XT Gaming OC 8G, but it looks like it's not related to the graphic card (see above). If it's relevant, initially I had BIOS F2, but it couldn't recognize my Radeon and it worked after upgrading to F5a.

You can set whether LEDs remain on in sleep or hibernate mode. For me it works like this (at least if it works at all):
- Sleep: LEDs from mainboard and RAM stay turned on
- Hibernate: LEDs from mainboard stay turned on
- Shutdown: All LEDs off

You can hear the click of the PSU in all cases.

According to my tests my problem is not related to the Fenvi. I not only have the problem that the computer does not wake up, but also that I can only switch the computer on again by clicking the power button several times. Then the computer does the cold double boot (on, off, on). In macOS I also get a corresponding error that it had a problem in the last step before entering sleep.
 
Joined
Oct 24, 2013
Messages
335
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K OC@5.3GHz
Graphics
RX 6800 XT + RX 560
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Hey @CaseySJ, with your flashed NVM 50 on the Vision D, does your boot time increase? I noticed that on my Vision D, with the Flashed Thunderbolt NVM, the system post time increases by about 20 seconds or so. Seems that the motherboard is trying to communicate with the thunderbolt controller during post... On stock NVM, boot time is shortened significantly.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
13,917
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey @CaseySJ, with your flashed NVM 50 on the Vision D, does your boot time increase? I noticed that on my Vision D, with the Flashed Thunderbolt NVM, the system post time increases by about 20 seconds or so. Seems that the motherboard is trying to communicate with the thunderbolt controller during post... On stock NVM, boot time is shortened significantly.
Although mine boots up at normal speed, there is a way to solve the slow boot time. We add the following in OpenCore as an ACPI patch (credit: @Elias64Fr) with Signature = DSDT:

Comment: disable \_GPE.TINI (Zero, RPS0, RPT0, Zero)
Find: FF5C2E5F 47504554 494E4900 52505330 52505430 00
Replace : FFA3A3A3 A3A3A3A3 A3A3A3A3 A3A3A3A3 A3A3A3A3 A3
 
Joined
Apr 2, 2017
Messages
18
Motherboard
Gigabyte Z490 Vision D
CPU
Core i7-10700K @5.1GHz
Graphics
Sapphire Rx Vega 64 water cooled
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
This is awesome, I am rethinking of hooking up my 2x240mm rads to water cool with 2 Vega GPUs! Where did you hook up the PWM for the PUMP motor? Just curious as sometimes the Vega chip can be hotter than the CPU
Thanks! I had also 30mm thick 240mm rad for the Vega first as AIO and it kept it about 60 degrees. The Vega was of course overclocked and undervolted but took over 300W.
The 3pin Voltage signal for the Vega pump comes from SYS_Fan1 header and for the main pump from CPU_fan header. The main pump gets power also directly from power brick. Both pumps are at Full speed all the time and inaudible.

That BruceX in 6 seconds is just awesome!
 
Top