Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Mar 26, 2021
Messages
79
Motherboard
Gigabyte Z490 VISION D
CPU
i7-10700K
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Running Monterey 12.1 Public Beta with OC 0.7.4 without any problems so far. I have a few questions maybe you can answer me.

1. I am using now iMac20,2, should I switch to 19,1?
2. What geekbenchmarks do you achieve with 10700K in monterey? Did you overclocked CPU or tweaked somehow?
3. Is there any working guide how to change i9 with i7 in "About this mac" info?
4. I am using RX 570 GPU and my app iStat Menus shows GPU 97-99% usage mostly, while iStatistica shows 0-1% usage. Any idea what's wrong here?
5. Is there anything I should know before upgrading OC to 0.7.5?
6. I did windows reinstall and I have installed my WIN11 to separate SSD disk with dedicated EFI partition for windows (DISK2) and I have macos DISK1 with dedicated EFI partition for mac. From now on I can't boot to Windows 11 from OC menu anymore. I can only boot to windows if I select from BIOS boot menu - Windows Boot Loader. Is it possible to make Windows DISK2 bootable from OC again? ( I mean I can see disk in OC menu, but when I select it it shows Preparing for automatic repair and just stuck there for infinite time.
7. Anybody know how fast iPhone 12 Pro charging is via thunderbolt to lightning cable?

@CaseySJ which CPU and how much RAM do you have in your new MBP 14? I can't decide between 16GB and 32GB RAM for M1 Pro 16". Does 32GB for M1 Pro even an option?

PS. Added WiFi speed test with BCM94360CSAX WiFi Card, speed is amazing I don't thing that I ever even need IntelWiFi card to work natively :D ..
 

Attachments

  • Screenshot 2021-11-12 at 01.53.34.png
    Screenshot 2021-11-12 at 01.53.34.png
    172.1 KB · Views: 20
  • Screenshot 2021-11-11 at 08.23.39.png
    Screenshot 2021-11-11 at 08.23.39.png
    315.9 KB · Views: 21
Last edited:
Joined
Nov 2, 2018
Messages
20
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
5700XT
Mac
  1. MacBook Pro
  2. Mac Pro
I've been running my system with a 5700xt for a while but want to downgrade to integrated iGPU. I've got it working, but what's the best way to get 4k 60 out of it? The HDMI port is limited to 30p I guess and the DP on the board is an input. Would a USB-c to Displayport cable work out of the Thunderbolt ports?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,105
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I'm having lots of trouble with my system. I did a test install of Big Sur which went very well but I then wanted to switch to a larger disk, add more disks, and add Linux for dual-boot. I'm finding that it's impossible to get into the boot menu or the BIOS. The system just hangs at the logo screen. With absolutely everything unplugged, NVME drives removed, even graphics card removed, I can get into the BIOS screen - sometimes. This is with BIOS F20. Should I consider downgrading to F5? Or is there some other solution to this issue?

Any pointers appreciated!
Please try CMOS Reset by following the procedure in Gigabyte user manual. It will be necessary to configure BIOS parameters again afterwards, starting always with F7 (Load Optimized Defaults).

It is possible that Linux installed its boot loader onto the same EFI partition as OpenCore. In that case, Linux takes precedence because it replaces OpenCore's "BOOTx64.efi" with its own.

Also, whenever you (a) install or (b) remove any device on the motherboard you must (no ifs, ands, or buts) flip power switch on PSU to OFF position or pull power cable from the wall. That's the only way to stop the flow of electrical current to the motherboard.

BIOS F20 is okay.

After CMOS reset is done and BIOS has been configured, shutdown the system and flip power switch to OFF. Then reinstall the macOS SSD, but not the Linux SSD.

Power back up. Go to BIOS Setup and select the macOS SSD as 1st Boot Priority.

Does OpenCore Picker appear?

P.S. When installing Linux or Windows, it is always best to physically remove the macOS SSD in order to make absolutely certain that neither Linux nor Windows will corrupt the OpenCore EFI partition.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,105
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
after upgrading to 12.0.1, i find the sound disappears.
anybody know how to solve this issue?
View attachment 533939
Please use OpenCore Configurator to make sure all config.plist items are set up correctly. Then perform CMOS Reset by following procedure in Gigabyte user manual. When computer starts, go to BIOS Setup and configure all BIOS parameters again, starting with F7 (Load Optimized Defaults).

Boot macOS and check audio.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,105
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS

CaseySJ

I finally got my system working!!! I still have two problems. When I check my system report under Thunderbolt it says no drivers. I don't a Thunderbolt device yet so I assume by the system report its not working unless I'm wrong. Second issue is I have a Grace Design m905 monitor controller I use for audio connected via USB. It shows up in Audio but it says no output channels. I assumed this device is plug and play so I believe theres something wrong in the audio maybe. Any suggestions?
Regarding Thunderbolt, please see Step 12 of Post 1:

Screen Shot 2021-11-11 at 5.48.56 PM.png



Regarding Grace Design m905:
  • Which version of macOS are you using?
  • Is this device known to work with that version of macOS?
  • Which USB port is it connected to?
  • Is it connected via a USB hub or directly into the rear IO panel of motherboard?
  • Does it help to connect it to a different USB port?
  • Which music editing software do you use? Does that software recognize the m905?
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,105
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Running Monterey 12.1 Public Beta with OC 0.7.4 without any problems so far. I have a few questions maybe you can answer me.

1. I am using now iMac20,2, should I switch to 19,1?
No need to switch to iMac19,1. What you have now (iMac20,2) is good.

2. What geekbenchmarks do you achieve with 10700K in monterey? Did you overclocked CPU or tweaked somehow?
3. Is there any working guide how to change i9 with i7 in "About this mac" info?
Please RestrictEvents documentation page here for instructions. If you have trouble with the procedure, please let us know.

4. I am using RX 570 GPU and my app iStat Menus shows GPU 97-99% usage mostly, while iStatistica shows 0-1% usage. Any idea what's wrong here?
Please try HWMonitorSMC2 from here. In the settings page, enable IOKit Monitoring.

5. Is there anything I should know before upgrading OC to 0.7.5?
Just read the 0C 0.7.5 mini-guide first.

6. I did windows reinstall and I have installed my WIN11 to separate SSD disk with dedicated EFI partition for windows (DISK2) and I have macos DISK1 with dedicated EFI partition for mac. From now on I can't boot to Windows 11 from OC menu anymore. I can only boot to windows if I select from BIOS boot menu - Windows Boot Loader. Is it possible to make Windows DISK2 bootable from OC again? ( I mean I can see disk in OC menu, but when I select it it shows Preparing for automatic repair and just stuck there for infinite time.
Please read the first section of OC 0.7.5 mini-guide.

7. Anybody know how fast iPhone 12 Pro charging is via thunderbolt to lightning cable?
Hopefully someone can answer this. I've been charging my iPhone 13 via MagSafe connected to a wall GaN-based wall charger. I am seriously impressed by these new GaN-based charging modules.

I am using the following 100W GaN module to charge my 14" MacBook Pro, iPhone 13 Pro Max, and iPad mini 6! I carry this single item when I travel, and it's just so small. Never gets hot.


@CaseySJ which CPU and how much RAM do you have in your new MBP 14? I can't decide between 16GB and 32GB RAM for M1 Pro 16". Does 32GB for M1 Pro even an option?
I chose 32GB RAM, which is available with both M1 Pro and M1 Max. The M1 Pro chip delivers longer battery life. If 14 or 16 GPU cores are enough for your workflow, the M1 Pro with 32GB could be an option that is not only great, but excessively great! :) No other laptop provides this level of performance. If more performance is needed, it's better to wait for new iMacPro or new Mac mini or new Mac Pro!

PS. Added WiFi speed test with BCM94360CSAX WiFi Card, speed is amazing I don't thing that I ever even need IntelWiFi card to work natively :D ..
Nice!
 
Joined
Sep 11, 2011
Messages
74
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
VisionTek Radeon RX 560
Mac
  1. MacBook Pro
Mobile Phone
  1. Android

@CaseySJ

Before I go any further I would like to echo the same as posted on here, Thank You very much for all the hard work you've done here for me and the entire tonymacx86 community.

Regarding Grace Design m905:
  • Which version of macOS are you using?
  • Is this device known to work with that version of macOS?
  • Which USB port is it connected to?
  • Is it connected via a USB hub or directly into the rear IO panel of motherboard?
  • Does it help to connect it to a different USB port?
  • Which music editing software do you use? Does that software recognize the m905?

*Catalina 10.15.7
*From what I read on Grace Designs web page as of recent versions it's suppose to be plug-n-play. I had to download drivers for Windows and it works fine via USB for normal computer sounds/audio and several of my DAWs in Windows10 (This how I listen to everything from my computer). Still though I will call them tomorrow to verify.
*I have it connected to the back panel USB 2.0 port (a) which is above the USB 2.0 port (b) Q-Flash Plus port. I have tried it in another USB port but had the same results.
*Connected directly in a USB ports, no hub.
*No it doesn't help but I will try all the back panel ports and the USB ports I'm using via the USB 3.2 header on my front panel.
*I've only installed Pro Tools and yes it's shown as an available audio device but no sound. From the Mac audio device window it shows the m905 but it says no output controls and the audio symbol in the upper right hand corner is grayed out until I select a different device.
 
Joined
Oct 19, 2017
Messages
46
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Please try CMOS Reset by following the procedure in Gigabyte user manual. It will be necessary to configure BIOS parameters again afterwards, starting always with F7 (Load Optimized Defaults).

It is possible that Linux installed its boot loader onto the same EFI partition as OpenCore. In that case, Linux takes precedence because it replaces OpenCore's "BOOTx64.efi" with its own.

P.S. When installing Linux or Windows, it is always best to physically remove the macOS SSD in order to make absolutely certain that neither Linux nor Windows will corrupt the OpenCore EFI partition.

Thanks Casey. A CMOS reset seems to have helped, although I have also removed the graphics card for the time being. (I was actually borrowing the GPU from my existing, working machine. I've a new one on order so will install that when it arrives next week.)

And I think what was certainly adding to my grief was an NVME drive with a completely empty EFI partition - it seemed to not like that at all. I don't know if that's normal/expected but it was basically my fault for rushing things.

Can I just add that the instructions here are *outstanding* and the help is very much appreciated. Thank you :)
 
Top