Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,922
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
giertclausen@Gierts-iMac LaunchAgents % cd /Applications/Firefox.app/Contents/MacOS


./firefox


Assertion failed: (0), function CreateCompiler, file /Library/Caches/com.apple.xbs/Sources/GPUDriversIntel/GPUDriversIntel-14.7.18.1/GLRenderer/kbl/usc_interface.cpp, line 1676.


giertclausen@Gierts-iMac MacOS %
File uploads are still not working.

Anyway, a similar problem was reported here:

Please open your config.plist in a text editor such as TextEdit or BBEdit and scroll down to DeviceProperties (or search for this). Then post the entire section, like this:
XML:
    <key>DeviceProperties</key>
    <dict>
        <key>Add</key>
        <dict>
            <key>PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0, 0x0)</key>
            <dict>
                <key>#device-id</key>
                <data>8hUAAA==</data>
                <key>device_type</key>
                <string>Ethernet Controller</string>
                <key>model</key>
                <string>Intel i225-V</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x1F,0x6)</key>
            <dict>
                <key>AAPL,slot-name</key>
                <string>Internal@0,31,6</string>
                <key>device_type</key>
                <string>Ethernet controller</string>
                <key>model</key>
                <string>Intel I219-V</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x1F,0x3)</key>
            <dict>
                <key>#device-id</key>
                <data>cJ0AAA==</data>
                <key>AAPL,slot-name</key>
                <string>Internal@0,31,3</string>
                <key>device_type</key>
                <string>Audio device</string>
                <key>model</key>
                <string>Realtek 1220-VB</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x1C,0x2)/Pci(0x0,0x0)</key>
            <dict>
                <key>AAPL,slot-name</key>
                <string>Internal@0,28,2/0,0</string>
                <key>device_type</key>
                <string>Network controller</string>
                <key>model</key>
                <string>BCM4360 802.11ac Wireless Network Adapter</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>#AAPL,slot-name</key>
                <string>Internal@0,2,0</string>
                <key>AAPL,ig-platform-id</key>
                <data>AwCYPg==</data>
                <key>device_type</key>
                <string>Display controller</string>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>model</key>
                <string>Intel UHD 630</string>
            </dict>
        </dict>
        <key>Delete</key>
        <dict/>
    </dict>
Also, is Internal Graphics set to Enabled (not "Auto") in BIOS Setup?
 
Last edited:
Joined
Sep 19, 2018
Messages
11
Motherboard
Z370-I Gaming
CPU
i7-8700K
Graphics
UHD630 / Radeon VII
Mac
  1. iMac
How similar are BIOS between boards of the same generation from the same manufacturer? E.g., Vision D and Aorus Extreme? I have the opportunity to get an Extreme, Vision D or go small and use the ASRock PG itx/tb3 - which seems to be another already developed option.
 
Joined
Apr 4, 2013
Messages
20
Motherboard
Gigabyte Z390 DESIGNARE
CPU
i9-9900K
Graphics
Radeon VI
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
File uploads are still not working.

Anyway, a similar problem was reported here:

Please open your config.plist in a text editor such as TextEdit or BBEdit and scroll down to DeviceProperties (or search for this). Then post the entire section, like this:
XML:
    <key>DeviceProperties</key>
    <dict>
        <key>Add</key>
        <dict>
            <key>PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0, 0x0)</key>
            <dict>
                <key>#device-id</key>
                <data>8hUAAA==</data>
                <key>device_type</key>
                <string>Ethernet Controller</string>
                <key>model</key>
                <string>Intel i225-V</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x1F,0x6)</key>
            <dict>
                <key>AAPL,slot-name</key>
                <string>Internal@0,31,6</string>
                <key>device_type</key>
                <string>Ethernet controller</string>
                <key>model</key>
                <string>Intel I219-V</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x1F,0x3)</key>
            <dict>
                <key>#device-id</key>
                <data>cJ0AAA==</data>
                <key>AAPL,slot-name</key>
                <string>Internal@0,31,3</string>
                <key>device_type</key>
                <string>Audio device</string>
                <key>model</key>
                <string>Realtek 1220-VB</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x1C,0x2)/Pci(0x0,0x0)</key>
            <dict>
                <key>AAPL,slot-name</key>
                <string>Internal@0,28,2/0,0</string>
                <key>device_type</key>
                <string>Network controller</string>
                <key>model</key>
                <string>BCM4360 802.11ac Wireless Network Adapter</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>#AAPL,slot-name</key>
                <string>Internal@0,2,0</string>
                <key>AAPL,ig-platform-id</key>
                <data>AwCYPg==</data>
                <key>device_type</key>
                <string>Display controller</string>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>model</key>
                <string>Intel UHD 630</string>
            </dict>
        </dict>
        <key>Delete</key>
        <dict/>
    </dict>
Also, is Internal Graphics set to Enabled (not "Auto") in BIOS Setup?
Internal graphics is set to Enabled. The config.sys part:

</dict>
<key>DeviceProperties</key>
<dict>
<key>Add</key>
<dict>
<key>PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0, 0x0)</key>
<dict>
<key>#device-id</key>
<data>8hUAAA==</data>
<key>device_type</key>
<string>Ethernet Controller</string>
<key>model</key>
<string>Intel i225-V</string>
</dict>
<key>PciRoot(0x0)/Pci(0x1F,0x6)</key>
<dict>
<key>AAPL,slot-name</key>
<string>Internal@0,31,6</string>
<key>device_type</key>
<string>Ethernet controller</string>
<key>model</key>
<string>Intel I219-V</string>
</dict>
<key>PciRoot(0x0)/Pci(0x1F,0x3)</key>
<dict>
<key>AAPL,slot-name</key>
<string>Internal@0,31,3</string>
<key>device-id</key>
<data>cJ0AAA==</data>
<key>device_type</key>
<string>Audio device</string>
<key>model</key>
<string>Realtek 1220-VB</string>
</dict>
<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
<dict>
<key>#AAPL,slot-name</key>
<string>Internal@0,2,0</string>
<key>AAPL,ig-platform-id</key>
<data>BwCbPg==</data>
<key>device_type</key>
<string>Display controller</string>
<key>framebuffer-con0-busid</key>
<data>AQAAAA==</data>
<key>framebuffer-con0-enable</key>
<data>AQAAAA==</data>
<key>framebuffer-con0-flags</key>
<data>xwMAAA==</data>
<key>framebuffer-con0-index</key>
<data>AQAAAA==</data>
<key>framebuffer-con0-pipe</key>
<data>EgAAAA==</data>
<key>framebuffer-con0-type</key>
<data>AAQAAA==</data>
<key>framebuffer-con1-busid</key>
<data>BgAAAA==</data>
<key>framebuffer-con1-enable</key>
<data>AQAAAA==</data>
<key>framebuffer-con1-flags</key>
<data>xwMAAA==</data>
<key>framebuffer-con1-index</key>
<data>AgAAAA==</data>
<key>framebuffer-con1-pipe</key>
<data>EgAAAA==</data>
<key>framebuffer-con1-type</key>
<data>AAQAAA==</data>
<key>framebuffer-con2-busid</key>
<data>BAAAAA==</data>
<key>framebuffer-con2-enable</key>
<data>AQAAAA==</data>
<key>framebuffer-con2-flags</key>
<data>xwMAAA==</data>
<key>framebuffer-con2-index</key>
<data>AwAAAA==</data>
<key>framebuffer-con2-pipe</key>
<data>EgAAAA==</data>
<key>framebuffer-con2-type</key>
<data>AAgAAA==</data>
<key>framebuffer-con3-busid</key>
<data>AAAAAA==</data>
<key>framebuffer-con3-enable</key>
<data>AQAAAA==</data>
<key>framebuffer-con3-flags</key>
<data>IAAAAA==</data>
<key>framebuffer-con3-index</key>
<data>/////w==</data>
<key>framebuffer-con3-pipe</key>
<data>AAAAAA==</data>
<key>framebuffer-con3-type</key>
<data>AQAAAA==</data>
<key>framebuffer-patch-enable</key>
<data>AQAAAA==</data>
<key>model</key>
<string>Intel UHD Graphics 630 (Desktop 9 Series)</string>
</dict>
</dict>
<key>Delete</key>
<dict/>
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,922
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Internal graphics is set to Enabled. The config.sys part:
XML:
    </dict>
    <key>DeviceProperties</key>
    <dict>
        <key>Add</key>
        <dict>
            <key>PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0, 0x0)</key>
            <dict>
                <key>#device-id</key>
                <data>8hUAAA==</data>
                <key>device_type</key>
                <string>Ethernet Controller</string>
                <key>model</key>
                <string>Intel i225-V</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x1F,0x6)</key>
            <dict>
                <key>AAPL,slot-name</key>
                <string>Internal@0,31,6</string>
                <key>device_type</key>
                <string>Ethernet controller</string>
                <key>model</key>
                <string>Intel I219-V</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x1F,0x3)</key>
            <dict>
                <key>AAPL,slot-name</key>
                <string>Internal@0,31,3</string>
                <key>device-id</key>
                <data>cJ0AAA==</data>
                <key>device_type</key>
                <string>Audio device</string>
                <key>model</key>
                <string>Realtek 1220-VB</string>
            </dict>
            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>#AAPL,slot-name</key>
                <string>Internal@0,2,0</string>
                <key>AAPL,ig-platform-id</key>
                <data>BwCbPg==</data>
                <key>device_type</key>
                <string>Display controller</string>
                <key>framebuffer-con0-busid</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con0-index</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con0-type</key>
                <data>AAQAAA==</data>
                <key>framebuffer-con1-busid</key>
                <data>BgAAAA==</data>
                <key>framebuffer-con1-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con1-index</key>
                <data>AgAAAA==</data>
                <key>framebuffer-con1-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con1-type</key>
                <data>AAQAAA==</data>
                <key>framebuffer-con2-busid</key>
                <data>BAAAAA==</data>
                <key>framebuffer-con2-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con2-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con2-index</key>
                <data>AwAAAA==</data>
                <key>framebuffer-con2-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con2-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-con3-busid</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con3-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con3-flags</key>
                <data>IAAAAA==</data>
                <key>framebuffer-con3-index</key>
                <data>/////w==</data>
                <key>framebuffer-con3-pipe</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con3-type</key>
                <data>AQAAAA==</data>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>model</key>
                <string>Intel UHD Graphics 630 (Desktop 9 Series)</string>
            </dict>
        </dict>
        <key>Delete</key>
        <dict/>
Some comments:
  • I think you may have used config-Intel-iGPU.plist as the starting point. Because you have an AMD GPU (Radeon VII) it's best to use config-AMD-GPU.plist instead, which disables video output from the iGPU while still keeping iGPU enabled for compute tasks.
  • However, first let's follow the suggestion in the Dortania link from my previous reply and add device-id 0x3E98, which is 983E0000 in reverse byte order. Simply replace the PciRoot(0x0)/Pci(0x2,0x0) section in Device Properties with this modified version and reboot:
XML:
            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>#AAPL,slot-name</key>
                <string>Internal@0,2,0</string>
                <key>AAPL,ig-platform-id</key>
                <data>BwCbPg==</data>
                <key>device_type</key>
                <string>Display controller</string>
                <key>framebuffer-con0-busid</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con0-index</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con0-type</key>
                <data>AAQAAA==</data>
                <key>framebuffer-con1-busid</key>
                <data>BgAAAA==</data>
                <key>framebuffer-con1-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con1-index</key>
                <data>AgAAAA==</data>
                <key>framebuffer-con1-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con1-type</key>
                <data>AAQAAA==</data>
                <key>framebuffer-con2-busid</key>
                <data>BAAAAA==</data>
                <key>framebuffer-con2-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con2-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con2-index</key>
                <data>AwAAAA==</data>
                <key>framebuffer-con2-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con2-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-con3-busid</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con3-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con3-flags</key>
                <data>IAAAAA==</data>
                <key>framebuffer-con3-index</key>
                <data>/////w==</data>
                <key>framebuffer-con3-pipe</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con3-type</key>
                <data>AQAAAA==</data>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>model</key>
                <string>Intel UHD Graphics 630 (Desktop 9 Series)</string>
                <key>device-id</key>
                <data>mD4AAA==</data>
            </dict>
If this also fails, we can replace the same section with the following, which disables video output from iGPU, but keeps iGPU enabled for compute tasks:
XML:
            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>#AAPL,slot-name</key>
                <string>Internal@0,2,0</string>
                <key>AAPL,ig-platform-id</key>
                <data>AwCYPg==</data>
                <key>device_type</key>
                <string>Display controller</string>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>model</key>
                <string>Intel UHD 630</string>
            </dict>
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,922
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
How similar are BIOS between boards of the same generation from the same manufacturer? E.g., Vision D and Aorus Extreme? I have the opportunity to get an Extreme, Vision D or go small and use the ASRock PG itx/tb3 - which seems to be another already developed option.
There was considerable similarity between the Gigabyte Z390 Designare and Gigabyte Z390 AORUS Xtreme. I suspect the same is true for the Z490 Vision D and Z490 AORUS Xtreme. However:
  • The USB port map may (or may not) need a little tweaking
  • The Aquantia 10GbE Ethernet port may need a kernel patch, which is already present in the Z490 Vision D EFi, but just needs to be checked on
 
Joined
Jul 2, 2011
Messages
152
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 5700XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
When I see posts in this thread, my mind automatically thinks "Z490 Vision D" or "Z490 Vision G". This thread is primarily for these two boards.

Anyway, to adapt the SSDT to GA-Z77X-UP5-TH, please post these two files:
  • System DSDT (from MaciASL)
  • Screenshot of IORegistryExplorer
    • Simply scroll down to the section containing the Nvidia GPU (or "IONDRVFramebuffer")
    • If you use the 'search' field, click the 'x' to the right of that field after the search is done


These errors indicate a mismatch between config.plist and the version of OpenCore you're using. If OpenCore Configurator was used to edit config.plist, please look at the title bar of the app. It will tell you which version of OpenCore will be supported by the config.plist.
Hi, Casey,

Please find the attachments that you requested. I hope they contain what you were looking for.

Thanks
 

Attachments

  • System DSDT.dsl
    370.8 KB · Views: 22
  • Screen Shot 2021-09-19 at 22.24.57.png
    Screen Shot 2021-09-19 at 22.24.57.png
    546.1 KB · Views: 20

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,922
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi, Casey,

Please find the attachments that you requested. I hope they contain what you were looking for.

Thanks
Good -- no change needed to the SSDT from my previous reply!

On your board, Nvidia GPU is on PCI0.PEG0.PEGP, which is the same as Designare Z390 (slot 1).
 
Joined
Apr 4, 2013
Messages
20
Motherboard
Gigabyte Z390 DESIGNARE
CPU
i9-9900K
Graphics
Radeon VI
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Some comments:
  • I think you may have used config-Intel-iGPU.plist as the starting point. Because you have an AMD GPU (Radeon VII) it's best to use config-AMD-GPU.plist instead, which disables video output from the iGPU while still keeping iGPU enabled for compute tasks.
  • However, first let's follow the suggestion in the Dortania link from my previous reply and add device-id 0x3E98, which is 983E0000 in reverse byte order. Simply replace the PciRoot(0x0)/Pci(0x2,0x0) section in Device Properties with this modified version and reboot:
XML:
            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>#AAPL,slot-name</key>
                <string>Internal@0,2,0</string>
                <key>AAPL,ig-platform-id</key>
                <data>BwCbPg==</data>
                <key>device_type</key>
                <string>Display controller</string>
                <key>framebuffer-con0-busid</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con0-index</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con0-type</key>
                <data>AAQAAA==</data>
                <key>framebuffer-con1-busid</key>
                <data>BgAAAA==</data>
                <key>framebuffer-con1-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con1-index</key>
                <data>AgAAAA==</data>
                <key>framebuffer-con1-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con1-type</key>
                <data>AAQAAA==</data>
                <key>framebuffer-con2-busid</key>
                <data>BAAAAA==</data>
                <key>framebuffer-con2-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con2-flags</key>
                <data>xwMAAA==</data>
                <key>framebuffer-con2-index</key>
                <data>AwAAAA==</data>
                <key>framebuffer-con2-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con2-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-con3-busid</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con3-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con3-flags</key>
                <data>IAAAAA==</data>
                <key>framebuffer-con3-index</key>
                <data>/////w==</data>
                <key>framebuffer-con3-pipe</key>
                <data>AAAAAA==</data>
                <key>framebuffer-con3-type</key>
                <data>AQAAAA==</data>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>model</key>
                <string>Intel UHD Graphics 630 (Desktop 9 Series)</string>
                <key>device-id</key>
                <data>mD4AAA==</data>
            </dict>
If this also fails, we can replace the same section with the following, which disables video output from iGPU, but keeps iGPU enabled for compute tasks:
XML:
            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>#AAPL,slot-name</key>
                <string>Internal@0,2,0</string>
                <key>AAPL,ig-platform-id</key>
                <data>AwCYPg==</data>
                <key>device_type</key>
                <string>Display controller</string>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>model</key>
                <string>Intel UHD 630</string>
            </dict>
The Radeon 7 card is in my z390 hackintosh in my studio. My Z490 vison D has no external GPU card, thats why I used your intel igpu config.sys.. Using HDMI fra the motherboard
 
Joined
Jun 6, 2017
Messages
100
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10600K
Graphics
RX 580 + GTX 710
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I am constantly getting down while it sleeps. When I come at mornings, I find it crashed and down. When I turn it up, it shows me the same debug informations, at every time.
Does anyone experiencing this?

Also, I can provide stack/debug informations if anyone interested.
 
Joined
Jun 20, 2011
Messages
160
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10600K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Finally I replace my crashing 5700 XT by a 3060 Ti (for gaming).
I'm running Big Sur without acceleration. :thumbdown
I want to use the discrete with Windows and the Intel iGPU with Big Sur.
Before changing EFI files (I'm using AMD config.plist), I'm trying to boot using two cables: HDMI for macOS, DisplayPort for w10.
I updated my BIOS to F20 (for Resize-Bar), but can't see the BIOS using the HDMI (iGPU).
With the F20 BIOS, the iGPU option are limited to auto, enable, disable and can't select initial graphics card.
Any idea?
Any advice?
 
Top