Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Aug 29, 2021
Messages
5
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10850K
Graphics
UHD 630
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
The DP port on the Vision D is input only.
EDIT: I misread and mistyped: I have the Vision G!!!
This is different than the Vision G which DOES seem to have an output on the DP. I am writing this on a build using the Vision G and using a Dell monitor attached to the DP on the Vision G.
1632056757372.png
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,920
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
This is not correct. I am writing this on a build using the Vision D and using a Dell monitor attached to the DP on the Vision D.
View attachment 529239
The Z490 Vision D has:
  1. HDMI port
  2. DisplayPort In
  3. Thunderbolt/USB-C #1
  4. Thunderbolt/USB-C #2
Have you connected the Dell monitor to item 2 (DisplayPort In)?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,920
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thanks again for your advice.

Should this work on my old GA-Z77X-UP5-TH motherboard?
When I see posts in this thread, my mind automatically thinks "Z490 Vision D" or "Z490 Vision G". This thread is primarily for these two boards.

Anyway, to adapt the SSDT to GA-Z77X-UP5-TH, please post these two files:
  • System DSDT (from MaciASL)
  • Screenshot of IORegistryExplorer
    • Simply scroll down to the section containing the Nvidia GPU (or "IONDRVFramebuffer")
    • If you use the 'search' field, click the 'x' to the right of that field after the search is done

I'm trying to upgrade my Clover based High Sierra System, which is working fine with the 1070Ti using Nvidia Web Drivers, to OpenCore Big Sur. Hence I have installed a Radeon RX 570 for macOS but wish to keep the 1070Ti for Windows Gaming.

I have placed your SSDT file in the EFI ACPI folder and enabled it in my config.plist ACPI section but I get the following error.

Do I need to do anything else with your SSDT file first?
These errors indicate a mismatch between config.plist and the version of OpenCore you're using. If OpenCore Configurator was used to edit config.plist, please look at the title bar of the app. It will tell you which version of OpenCore will be supported by the config.plist.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,920
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I´m not able to launch Firefox even with Option and Cmd . Crashing.
What troubleshooting steps have you already taken?
  • Have you deleted Firefox, downloaded a new copy, and tried installing it instead?
  • Do you have any firewalls or anti-virus apps running?
  • Have you tried downloading and installing an older version of Firefox?
  • How about Google Chrome?
 
Joined
Aug 29, 2021
Messages
5
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10850K
Graphics
UHD 630
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
The Z490 Vision D has:
  1. HDMI port
  2. DisplayPort In
  3. Thunderbolt/USB-C #1
  4. Thunderbolt/USB-C #2
Have you connected the Dell monitor to item 2 (DisplayPort In)?
I made a mistake (only one cup of coffee). The OP and you are talking about the Vision D and I am on a Vision G.
My apologies
I just verified that there is only one input cable connected to the Dell S2817Q (mDP) and that cable goes to the Displayport on the back of the Z490 Vision G motherboard.
I have done the initial build outside the case right on the desk so things are a mess but let me try to attach a photo for the sake of everyone's sanity and to make sure I don't take us down a rabbit hole with this claim ;)
1632058335197.png
 
Last edited:
Joined
Apr 4, 2013
Messages
20
Motherboard
Gigabyte Z390 DESIGNARE
CPU
i9-9900K
Graphics
Radeon VI
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
First I just want to thank you for your support and splendid build guides! :)
I´ve tried both new copy and older versions of firefox. Still crashing. But Google Chrome seem to be working!:) Im not running any firewalls nor anti-virus apps.
With your other EFI-map Firefox and Safari is working great on ethernet..
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,920
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
First I just want to thank you for your support and splendid build guides! :)
I´ve tried both new copy and older versions of firefox. Still crashing. But Google Chrome seem to be working!:) Im not running any firewalls nor anti-virus apps.
With your other EFI-map Firefox and Safari is working great on ethernet..
Please try this:
  • Open a Terminal window
  • Type:
Bash:
cd ~/Library/Application\ Support
cd Firefox
ls -l Crash\ Reports
  • Copy the output and post it
  • Then do this:
Bash:
cd ~/Library/Application\ Support
rm -rf Firefox
  • This will remove the Firefox folder. Don't worry, this contains user data that can be deleted.
  • Now try running Firefox.
 
Joined
Apr 4, 2013
Messages
20
Motherboard
Gigabyte Z390 DESIGNARE
CPU
i9-9900K
Graphics
Radeon VI
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Please try this:
  • Open a Terminal window
  • Type:
Bash:
cd ~/Library/Application\ Support
cd Firefox
ls -l Crash\ Reports
  • Copy the output and post it
  • Then do this:
Bash:
cd ~/Library/Application\ Support
rm -rf Firefox
  • This will remove the Firefox folder. Don't worry, this contains user data that can be deleted.
  • Now try running Firefox.
-rw------- 1 giertclausen staff 10 Sep 19 17:15 InstallTime20210622155641

-rw------- 1 giertclausen staff 10 Sep 12 23:45 InstallTime20210903235534

-rw-------@ 1 giertclausen staff 10 Sep 19 18:08 LastCrash

drwx------ 5 giertclausen staff 160 Sep 19 17:15 events

drwx------@ 20 giertclausen staff 640 Sep 19 18:08 pending

-rw-r--r--@ 1 giertclausen staff 1220 Sep 19 12:30 submit.log

drwx------@ 3 giertclausen staff 96 Sep 19 12:17 submitted

giertclausen@Gierts-iMac Firefox %
 
Joined
Apr 4, 2013
Messages
20
Motherboard
Gigabyte Z390 DESIGNARE
CPU
i9-9900K
Graphics
Radeon VI
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Still crashing..
Please try this:
  • Open a Terminal window
  • Type:
Bash:
cd ~/Library/Application\ Support
cd Firefox
ls -l Crash\ Reports
  • Copy the output and post it
  • Then do this:
Bash:
cd ~/Library/Application\ Support
rm -rf Firefox
  • This will remove the Firefox folder. Don't worry, this contains user data that can be deleted.
  • Now try running Firefox.
still crashing..
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,920
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Still crashing..

still crashing..
What is the Firefox version number? (Applications Folder --> Firefox --> right click --> Get Info)

Another option:
  • Start macOS in "Safe Mode" as follows:
    • At OpenCore Picker, press and hold SHIFT key when selecting the macOS boot volume
    • When macOS starts up, see if Firefox will launch
 
Last edited:
Top