Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Oct 24, 2013
Messages
1,069
Motherboard
Asus ROG Z690 Formula
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
No riser board. Card is plugged directly into the first PCI slot. Using the Vision D w/ 10850K cpu. Works flawlessly with the 5700 in the same port with display port monitors. All I see is black on boot with the 6900 unless I grab a spare monitor with HDMI. Unfortunately I have no other display port monitors to test with.
Is the igpu turned on? Could the system be trying to output video via the igpu and not your 6900xt in the preboot environment? Are your displayport cables capable of DP1.4? What BIOS are you using?

My old Radeon VII from ASUS used to give me trouble sometimes with outputting video on post, sometimes on post it wouldn’t display anything or it would display a garbled image, so I’d have to reboot the system once or twice for it to stop acting up. Sometimes upon wake from s3 sleep it wouldn’t display anything so I’d have to put the system back to sleep and wake it again for an image to display. Very quirky, and I never had that problem with an nvidia card or with my 6800XT.
 
Last edited:
Joined
Aug 16, 2020
Messages
118
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
RX 6900 XT
Is the igpu turned on? Could the system be trying to output video via the igpu and not your 6900xt in the preboot environment? Are your displayport cables capable of DP1.4? What BIOS are you using?

My old Radeon VII from ASUS used to give me trouble sometimes with outputting video on post, sometimes on post it wouldn’t display anything or it would display a garbled image, so I’d have to reboot the system once or twice for it to stop acting up. Sometimes upon wake from s3 sleep it wouldn’t display anything so I’d have to put the system back to sleep and wake it again for an image to display. Very quirky, and I never had that problem with an nvidia card or with my 6800XT.
Thanks for the responce!

I used both F20 and F5 neither work. I see black all through the boot process. No BIOS no nothing. I did try disabling the internal igpu yesterday with no luck, but maybe I should try again. I cant remember which BIOS I tried that on. The monitors are 2009 24" Apple LED Cinema Displays. I cant find any documentation on them saying what version Display port standard they are. I did read that the mini-displayport was sent to 1.2 standard though on another post I read last night. Cables are permanently attached to the monitor and you can’t change them. One would think the Card should be backwards compatible with previous standards.

Id also like to flip the switch on CSM and see what happens. Hope to be able to do that here shortly...

Seems like its either the card hating the old monitors, or I need to find the magic switch in the BIOS settings...
 
Last edited:
Joined
Oct 24, 2013
Messages
1,069
Motherboard
Asus ROG Z690 Formula
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Thanks for the responce!

I used both F20 and F5 neither work. I see black all through the boot process. No BIOS no nothing. I did try disabling the internal igpu yesterday with no luck, but maybe I should try again. I cant remember which BIOS I tried that on. The monitors are 2009 24" Apple LED Cinema Displays. I cant find any documentation on them saying what version Display port standard they are. I did read that the mini-displayport was sent to 1.2 standard though on another post I read last night. Cables are permanently attached to the monitor and you can’t change them. One would think the Card should be backwards compatible with previous standards.

Id also like to flip the switch on CSM and see what happens. Hope to be able to do that here shortly...

Seems like its either the card hating the old monitors, or I need to find the magic switch in the BIOS settings...
DisplayPort version 1.4 was published March 1, 2016. If possible, try testing with another DisplayPort monitor or cable to see if it’s the card or the monitor thats having an issue. my bet would be on the monitor, given that it seems that you can display DisplayPort video output normally from the 6900xt after the OS has booted. Frustrating I know… dampens the excitement of a new graphics card.
 
Joined
Aug 16, 2020
Messages
118
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
RX 6900 XT
DisplayPort version 1.4 was published March 1, 2016. If possible, try testing with another DisplayPort monitor or cable to see if it’s the card or the monitor thats having an issue. my bet would be on the monitor, given that it seems that you can display DisplayPort video output normally from the 6900xt after the OS has booted. Frustrating I know… dampens the excitement of a new graphics card.
Yeah, it’s a bummer but maybe an excuse for some new monitors. I’ll swing by and pick up a monitor for testing this weekend. Just a strange thing to be happening. Always has to be harder then it needs to be right…
 
Joined
Oct 24, 2013
Messages
1,069
Motherboard
Asus ROG Z690 Formula
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Yeah, it’s a bummer but maybe an excuse for some new monitors. I’ll swing by and pick up a monitor for testing this weekend. Just a strange thing to be happening. Always has to be harder then it needs to be right…
Such is the world of PCs unfortunately. I’ve had systems up and running smooth sailing for weeks, then at the most inopportune time, a component crashed or the motherboard stopped posting or the video card started acting up. The most recent one was a memory DIMM died and was causing random crashes. Took me a while to debug that. It’s always something. But Corsair took good care of me, was back up and running within 5 days. Most of that time was just the slow USPS service.
 
Joined
Aug 16, 2020
Messages
118
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
RX 6900 XT
It’s okay to enable CSM Support and see if it helps.

If you have an HDMI monitor connected, does the 6900 output video only to the HDMI monitor, or do one of the DP monitors also turn on?

If a DP monitor turns on, you could try using an HDMI ghost plug. Simply search Amazon for “HDMI ghost plug”.
Set the BIOS to have internal GPU off and CSM on. Set the PCI to port 1 manually. Still not luck... Ill go buy some displayport monitors now and see if we have a change...
 
Joined
Aug 16, 2020
Messages
118
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
RX 6900 XT
@dehjomz @CaseySJ New monitors solved the issue. Thanks for the troubleshooting help and being there to run ideas past! I'm now rocking two 28" instead of the old 24"s. They are 4k vs. HD, and they emit no heat... Honestly its a win-win... Other then on the pocketbook...

Now I need to figure out where and how to mount this 5700 XT.. Doesn't look like its gonna fit inside the box well. Prob have to go eGPU... Anyone want to caution me about anything with eGPU?

This is the box Apple pushes.
https://www.amazon.com/dp/B08Q7KF1FR/?tag=tonymacx86com-20

If anyone else has experience I'm all ears.

Thanks everyone!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,446
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@dehjomz @CaseySJ New monitors solved the issue. Thanks for the troubleshooting help and being there to run ideas past! I'm now rocking two 28" instead of the old 24"s. They are 4k vs. HD, and they emit no heat... Honestly its a win-win... Other then on the pocketbook...

Now I need to figure out where and how to mount this 5700 XT.. Doesn't look like its gonna fit inside the box well. Prob have to go eGPU... Anyone want to caution me about anything with eGPU?

This is the box Apple pushes.
https://www.amazon.com/dp/B08Q7KF1FR/?tag=tonymacx86com-20

If anyone else has experience Im all ears.

Thanks everyone!
Admittedly the following is buried deep inside Post 1, but:

E91A1585-610F-4697-BB40-9721FC46D535.jpeg

Regarding eGPUs, the only way to use them reliably is by flashing the Thunderbolt firmware. The 6900 XT is a monster; the 5700 XT has no compelling reason to coexist on the same machine! :) I would not recommend an eGPU. Instead, in today’s hot GPU market, why not sell the 5700 XT instead? You can recover the money you spent on one or both of the new 28” monitors…
 
Joined
Aug 16, 2020
Messages
118
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
RX 6900 XT
Admittedly the following is buried deep inside Post 1, but:

View attachment 525346

Regarding eGPUs, the only way to use them reliably is by flashing the Thunderbolt firmware. The 6900 XT is a monster; the 5700 XT has no compelling reason to coexist on the same machine! :) I would not recommend an eGPU. Instead, in today’s hot GPU market, why not sell the 5700 XT instead? You can recover the money you spent on one or both of the new 28” monitors…

For GPU rendering in Cinema4d w/ Octane the more GPUs you have the better. Honestly Id like to have 3 6900's. Id finally be somewhat happy. But with the 6900 and the 5700 Id still have some great speeds... Every little bit helps.. Good to know about needing to flash the the thunderbolt. I'll look into that next...

If I could devise a way to get the 5700 in the case I have Id totally do it, but to add the 2cd video card, it will lay against the 6900. Im a bit worried about the cooling on the 6900. Id also cover the slot the Fenvi needs to connect as well, and Id have to beef up to a 1200-1600 PSU... Im not sure whats the worst of the two evils...

Going the eGPU rout is a 300 case that included a 750watt PSU, and if it works seems to be the easiest route... I may have to try an amazon rental and see if I can get it to work.

If I cant get this to work reliably I'll def do as you suggest and recoup some costs. Thanks @CaseySJ
 
Joined
Oct 24, 2013
Messages
1,069
Motherboard
Asus ROG Z690 Formula
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
@dehjomz @CaseySJ New monitors solved the issue. Thanks for the troubleshooting help and being there to run ideas past! I'm now rocking two 28" instead of the old 24"s. They are 4k vs. HD, and they emit no heat... Honestly its a win-win... Other then on the pocketbook...

Now I need to figure out where and how to mount this 5700 XT.. Doesn't look like its gonna fit inside the box well. Prob have to go eGPU... Anyone want to caution me about anything with eGPU?

This is the box Apple pushes.
https://www.amazon.com/dp/B08Q7KF1FR/?tag=tonymacx86com-20

If anyone else has experience Im all ears.

Thanks everyone!
Happy to hear it. Enjoy your new card and your new monitors!
 
Top