Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Incidentally, I've moved my Asus X99 post here:
 
Joined
Nov 14, 2020
Messages
43
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
hello @CaseySJ
I find my HEVC does not work on 11.4. Could you please tell me how to resolve this problem? And I notice an issue that the sound and picures of some videos are out of sync, which I think is related to HEVC.
this is screenshot:
WX20210705-173305.png
 
Joined
Oct 24, 2013
Messages
1,020
Motherboard
Asus ROG Z690 Formula
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
@CaseySJ here’s some more info on the i225-v issue: https://github.com/dortania/bugtracker/issues/213

I will try this later, but apparently we need to:
  • 1. Disable FakePCIID.kext and FakePCDID_Intel_i225-V.kext in config.plist,
  • 2. remove everything concerning i225 in DeviceProperties/Add/PciRoot...
  • 3. add "dk.e1000=0" (without quotes) to boot-args.
Also, apparently enabling Vt-d without the opencore patch disableiomapper (such that AppleVTd loads) on gigabyte boards for some reason breaks Wi-Fi and some network adapters (except the iPhone USB adapter, I also haven’t tried an aquantia adapter in this setup).
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ here’s some more info on the i225-v issue: https://github.com/dortania/bugtracker/issues/213

I will try this later, but apparently we need to:
  • 1. Disable FakePCIID.kext and FakePCDID_Intel_i225-V.kext in config.plist,
  • 2. remove everything concerning i225 in DeviceProperties/Add/PciRoot...
  • 3. add "dk.e1000=0" (without quotes) to boot-args.
I saw that yesterday and will also try it shortly. Item 3 makes me wonder if speed will drop to 1Gbps or whether that argument prevents the 1GbE driver from attaching instead of AppleIntelEthernet210.
 
Joined
Oct 24, 2013
Messages
1,020
Motherboard
Asus ROG Z690 Formula
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
I saw that yesterday and will also try it shortly. Item 3 makes me wonder if speed will drop to 1Gbps or whether that argument prevents the 1GbE driver from attaching instead of AppleIntelEthernet210.
Good question. Only way to know is to be an empiricist and test.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I saw that yesterday and will also try it shortly. Item 3 makes me wonder if speed will drop to 1Gbps or whether that argument prevents the 1GbE driver from attaching instead of AppleIntelEthernet210.

Good question. Only way to know is to be an empiricist and test.
Alas it did not work for me (Monterey), but others should still try:

Screen Shot 2021-07-05 at 5.04.25 AM.png
 
Last edited:
Joined
Feb 15, 2016
Messages
45
Motherboard
GA-170X-UD5-TH - BIOS F22g
CPU
i7-6700K
Graphics
RX 560 + HD 530
Mac
  1. iMac
  2. MacBook Pro
Hi Casey,

I just finished building my son a vision G model, using your EFI Folder for the Vision G, and these instructions. Looks like everything is working except the audio. Not sure what is wrong, but maybe you can shed some light on this. I have attached my EFi folder and my IO Reg report for you to study. Please let me know where I went wrong.

I was hoping that using the instructions and your EFI folder setup, I would not have any problems. Please let me know if you need anything else.

Hardware in build is as follows:

Gigabyte Vision G Z490 Motherboard
Intel I5-10600K Processor
32GB DDR4 Ram running at 3200 MHz
AMD Sapphire Radeon RX 580 8Gb Video Card
250G WD Black m.2 drive
750 Watt Apexgaming modular power supply

Oh, by the way, I also built myself the Vision D model about a year ago using this guide and your EFI folder and it works like a champ, no problems whatsoever. That's why I am puzzled that my son's vision G has no sound. Hopefully you can help and let me know what I did wrong.

Thanks in advance.

Wayne
 

Attachments

  • Chris’s iMac.ioreg
    12.1 MB · Views: 39
  • EFI.zip
    4.3 MB · Views: 50
  • Screen Shot 2021-07-05 at 10.57.34 AM.png
    Screen Shot 2021-07-05 at 10.57.34 AM.png
    461.5 KB · Views: 49
  • Screen Shot 2021-07-05 at 10.58.06 AM.png
    Screen Shot 2021-07-05 at 10.58.06 AM.png
    407.7 KB · Views: 47
  • Screen Shot 2021-07-05 at 10.58.30 AM.png
    Screen Shot 2021-07-05 at 10.58.30 AM.png
    411.1 KB · Views: 50

jd6

Joined
Mar 29, 2011
Messages
133
Motherboard
Gigabyte GA-Z490 Vision G
CPU
i5-11600k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi Casey,

I just finished building my son a vision G model, using your EFI Folder for the Vision G, and these instructions. Looks like everything is working except the audio. Not sure what is wrong, but maybe you can shed some light on this. I have attached my EFi folder and my IO Reg report for you to study. Please let me know where I went wrong.

I was hoping that using the instructions and your EFI folder setup, I would not have any problems. Please let me know if you need anything else.

Hardware in build is as follows:

Gigabyte Vision G Z490 Motherboard
Intel I5-10600K Processor
32GB DDR4 Ram running at 3200 MHz
AMD Sapphire Radeon RX 580 8Gb Video Card
250G WD Black m.2 drive
750 Watt Apexgaming modular power supply

Oh, by the way, I also built myself the Vision D model about a year ago using this guide and your EFI folder and it works like a champ, no problems whatsoever. That's why I am puzzled that my son's vision G has no sound. Hopefully you can help and let me know what I did wrong.

Thanks in advance.

Wayne
try alcid=7
in boot-args under NVRAM instead of alcid=11

that's what I did in mine to get it to work 11 is not working in vision G.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi Casey,

I just finished building my son a vision G model, using your EFI Folder for the Vision G, and these instructions. Looks like everything is working except the audio. Not sure what is wrong, but maybe you can shed some light on this. I have attached my EFi folder and my IO Reg report for you to study. Please let me know where I went wrong.

I was hoping that using the instructions and your EFI folder setup, I would not have any problems. Please let me know if you need anything else.

Hardware in build is as follows:

Gigabyte Vision G Z490 Motherboard
Intel I5-10600K Processor
32GB DDR4 Ram running at 3200 MHz
AMD Sapphire Radeon RX 580 8Gb Video Card
250G WD Black m.2 drive
750 Watt Apexgaming modular power supply

Oh, by the way, I also built myself the Vision D model about a year ago using this guide and your EFI folder and it works like a champ, no problems whatsoever. That's why I am puzzled that my son's vision G has no sound. Hopefully you can help and let me know what I did wrong.

Thanks in advance.

Wayne
Hello Wayne,

Please try enabling FakePCIID_Intel_HDMI_Audio shown in the screenshot, and reboot. If this works I'll make this change in OpenCore 0.7.1 which was released just an hour ago.

Screen Shot 2021-07-05 at 10.13.18 AM.png
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,119
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
** OpenCore 0.7.1 EFI for Z490 Vision D **
Supports Catalina, Big Sur, and Monterey
Please do not quote this post in its entirely. Use a link instead.


Update to OpenCore 0.7.1 using HackinDROM App
Available for both Broadcom WiFi/BT and OpenIntelWireless WiFi/BT


If making manual changes to OpenCore config.plist, please ensure that OpenCore Configurator is set to either 0.7.1 Development Version or 0.7.1 Release Version


This update includes:

1. OpenCore 0.7.1
2. VirtualSMC 1.2.5
3. NVMeFix 1.0.9
4. AppleALC 1.6.2
5. IntelMausi 1.0.7
6. Lilu 1.5.4
7. NVMeFix 1.0.9
8. WhateverGreen 1.5.1
9. RestrictEvents 1.0.3 (added, but not enabled; this is for MacPro7,1 users)

Changes to config.plist:
  • Booter Quirks have been changed to recommended settings.
    • EnableWriteUnprotector --> disabled
    • ProtectUefiServices --> enabled
    • SetupVirtualMap --> enabled
  • FakePCIID kexts for HDMI Audio and i225-V Ethernet port apply to Catalina and Big Sur, but will not be injected in Monterey.
    • FakePCIID uses the now deprecated IOPCIDevice API instead of the newer PCIDriverKit.
  • SSDT-DMAC has been added (Direct Memory Access Controller).
  • Boot Argument dart=0 has been removed. Don't worry, however, because DisableIoMapperis still turned on, which means VT-d (AppleVTD) will not be enabled by default.
    • Anyone who needs AppleVTD should uncheck DisableIoMapper and enable VT-d in BIOS.
OpenIntelWireless Version:
  • Includes latest 2.0.0-alpha WiFi drivers from OpenIntelWireless
  • Also includes the 2.0.0-alpha WiFi driver for Monterey
  • Includes version 1.1.3 of Intel Bluetooth driver and BlueToolFixup.kext (for Monterey)

Reminder:
  • Radeon VII users must disable boot argument agdpmod=pikera. Vega user may need to do the same.

If using OpenCore Configurator, please ensure it is set to 0.7.1 Development Version or 0.7.1 Release Version.


For manual update purposes, the ZIP files are attached below.
  • File on left is for Broadcom WiFi/BT (4.3 MB).
  • File on right is for Intel WiFi/BT (61 MB).

Catalina Users Only: Please make the change shown below to enable the i225-V Ethernet port (it will run at 1GbE speeds, however).
Screen Shot 2021-07-17 at 6.01.48 PM.png

Updates:
  • 6 July 2021: Replaced the OpenIntelWireless EFI.
    • If you downloaded this earlier, please replace with the new version, which is also available from HackinDROM App.
    • Uses OpenIntelWireless BluetoothFirmware 1.1.3 (version 2.0.0 RC1 is not reliable in Monterey).
    • Uses BlueToolFixup.kext for Monterey.
    • Commented out "AAPL,slot-name" from iGPU to fix HEVC problem.
  • 6 July 2021: Replaced the standard OC 0.7.1 EFI as well.
    • Commented out "AAPL,slot-name" from iGPU to fix HEVC problem.
  • 7 July 2021: Replaced Intel Wireless EFI to fix Realtek ALC1220 audio issue.
    • This problem existed only in the Intel Wireless EFI.
  • 18 July 2021: USBInjectAll was mistakenly left unchecked in the OpenIntelWireless AMD-GPU version of config.plist (config-AMD-GPU.plist). This has been fixed.
 

Attachments

  • OC-071-VISION-D.zip
    4.3 MB · Views: 198
  • OC-071-Intel-Wireless-VISION-D.zip
    61 MB · Views: 87
Last edited:
Top