Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Jul 14, 2020
Messages
198
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 6800
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Is anyone else experiencing random skips in their audio with a USB interface? There doesn't seem to be any pattern that I can tell, but occasionally I get skipping audio, either when watching a video (in VLC for example) or editing (Premiere Pro/Davinci Resolve). It only seems to happen with my audio interface (Apogee Duet 2) so I think it might be a USB issue. The video doesn't skip, just the audio. Doesn't seem to happen when I have my headphones plugged directly into the computer either.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,493
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Is anyone else experiencing random skips in their audio with a USB interface? There doesn't seem to be any pattern that I can tell, but occasionally I get skipping audio, either when watching a video (in VLC for example) or editing (Premiere Pro/Davinci Resolve). It only seems to happen with my audio interface (Apogee Duet 2) so I think it might be a USB issue. The video doesn't skip, just the audio. Doesn't seem to happen when I have my headphones plugged directly into the computer either.
It may be a good idea to review this Best Practices guide for USB audio devices:
 
Joined
May 30, 2016
Messages
983
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
Is anyone else experiencing random skips in their audio with a USB interface? There doesn't seem to be any pattern that I can tell, but occasionally I get skipping audio, either when watching a video (in VLC for example) or editing (Premiere Pro/Davinci Resolve). It only seems to happen with my audio interface (Apogee Duet 2) so I think it might be a USB issue. The video doesn't skip, just the audio. Doesn't seem to happen when I have my headphones plugged directly into the computer either.
Nothing to report here, I spend 8+ hours a day on my system with sound being send to an RME ADI-2 Pro (USB2.0) and haven’t had any audio skipping.

edit: after reading @CaseySJ ’s post above, I should note that my audio
Interface is plugged into the motherboard directly on a USB2.0 only port.
 
Last edited:
Joined
Jun 2, 2020
Messages
147
Motherboard
Gigabyte Z490 Vision G
CPU
i7-10700K
Graphics
UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Is anyone else experiencing random skips in their audio with a USB interface? There doesn't seem to be any pattern that I can tell, but occasionally I get skipping audio, either when watching a video (in VLC for example) or editing (Premiere Pro/Davinci Resolve). It only seems to happen with my audio interface (Apogee Duet 2) so I think it might be a USB issue. The video doesn't skip, just the audio. Doesn't seem to happen when I have my headphones plugged directly into the computer either.
Please, try to set fixed 100.00 MHz (not "Auto") your "CPU Base Clock" in BIOS:
 
Joined
Jul 14, 2020
Messages
198
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 6800
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
It may be a good idea to review this Best Practices guide for USB audio devices:

Thanks Casey, I’ll have a read of that.

Nothing to report here, I spend 8+ hours a day on my system with sound being send to an RME ADI-2 Pro (USB2.0) and haven’t had any audio skipping.

edit: after reading @CaseySJ ’s post above, I should note that my audio
Interface is plugged into the motherboard directly on a USB2.0 only port.
My interface is plugged into the motherboard, however it’s in a USB3 port. I’ll try one of the USB2 ports.


Please, try to set fixed 100.00 MHz (not "Auto") your "CPU Base Clock" in BIOS:
Thanks for this. I’ve made that change in the BIOS and will see how I get on. Fingers crossed!
 
Joined
Jun 9, 2021
Messages
308
Motherboard
Gigabyte Z690 Aero D
CPU
i9-12900K
Graphics
RX 6950 XT
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@CaseySJ, Because of the current issues that my Asus B560-F keeps giving in regards to sound etc, i purchased a Gigabyte Z490 Vision D which is the exact same board as yours. When this arrives would i just be be able to copy your EFI in and all should be good. I would also like to use my i7 11700K cpu in there as it cost me alot to buy and do not want to buy another cpu. I have a few questions
1. What changes will need to be made to your EFI for this CPU
2. Would i have IGPU or should i still use the AMD RX580 for graphics
3. I see this board has S/PDIF for sound out as well- would this work connected to my Samsung TV
4. The board takes 3 x M.2 Drives, Can i use a M+B Key M.2 in here?

Thank You

Screen Shot 2021-07-01 at 4.54.54 PM.png
 
Last edited:
Joined
Jun 2, 2020
Messages
147
Motherboard
Gigabyte Z490 Vision G
CPU
i7-10700K
Graphics
UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks for this. I’ve made that change in the BIOS and will see how I get on. Fingers crossed!
How is it going?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,493
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ, Because of the current issues that my Asus B560-F keeps giving in regards to sound etc, i purchased a Gigabyte Z490 Vision D which is the exact same board as yours. When this arrives would i just be be able to copy your EFI in and all should be good. I would also like to use my i7 11700K cpu in there as it cost me alot to buy and do not want to buy another cpu.
Yes it should be as easy as that.

I have a few questions
1. What changes will need to be made to your EFI for this CPU
No changes for this CPU. But I will, however, make a change next week with the release of OpenCore 0.7.1 that should address a possible issue with HDMI Audio.

2. Would i have IGPU or should i still use the AMD RX580 for graphics
We can drive a display monitor either through iGPU (okay for temporary use) or with AMD Radeon GPU (best for long term). Please see Post 1, Step 4 for details on choosing the right config file.

3. I see this board has S/PDIF for sound out as well- would this work connected to my Samsung TV
Yes it should work.

4. The board takes 3 x M.2 Drives, Can i use a M+B Key M.2 in here?
We can use both SATA M.2 and PCIe M.2 drives in those slots. But please refer to motherboard owner's manual for important side-effects when all three M.2 slots are populated (e.g. you lose some SATA ports and you lose 2 of 4 PCIe lanes from the bottom long slot).
 
Joined
Jun 9, 2021
Messages
308
Motherboard
Gigabyte Z690 Aero D
CPU
i9-12900K
Graphics
RX 6950 XT
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Yes it should be as easy as that.


No changes for this CPU. But I will, however, make a change next week with the release of OpenCore 0.7.1 that should address a possible issue with HDMI Audio.


We can drive a display monitor either through iGPU (okay for temporary use) or with AMD Radeon GPU (best for long term). Please see Post 1, Step 4 for details on choosing the right config file.


Yes it should work.


We can use both SATA M.2 and PCIe M.2 drives in those slots. But please refer to motherboard owner's manual for important side-effects when all three M.2 slots are populated (e.g. you lose some SATA ports and you lose 2 of 4 PCIe lanes from the bottom long slot).
Thanks Mate, I really appreciate that you took the time to respond to me. I should have the board by July 7 as per DHL and then I will start with it.
 
Top