Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Jul 14, 2020
Messages
198
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 6800
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi,
I have a problem with my sound output,
When I connect my speakers to the green output in the back, they appear as "Internal Speakers" and work fine, but when I plug my headphones in the front, "Headphones" overrides "Internal Speakers". Meaning "Internal Speakers" disappears and "Headphones" appear.
I know I can simply switch to another sound input in the back but then the speakers won't be recognized by Windows.
Is there a solution for this?
Thanks
Does your monitor have a headphone output?
 

nss

Joined
Sep 16, 2019
Messages
99
Motherboard
Z490 Vision D
CPU
i7-10700
Graphics
RX 5700 XT
Mobile Phone
  1. Android
Does your monitor have a headphone output?
Yes, but no microphone jack, therefore it's not useful for me.
Besides I have to turn off the screen and then turn it back on in order for it to show up in sound preferences
 
Joined
Jun 2, 2020
Messages
147
Motherboard
Gigabyte Z490 Vision G
CPU
i7-10700K
Graphics
UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
"And one more thing..."

I STRONGLY recommend to set "CPU Base Clock" ("Tweaker" page in BIOS Setup) to 100.00 MHz, NOT "Auto".
With "Auto" setting my system starts with base clock "99.95" MHz (you can check it in "System Info" in your BIOS Setup) and I have some issues (clicks, "digital noise" like "sound of a broken synthesizer", etc.) with my USB audio interface, because the CPU base clock clock (I don't know why) affects the audio sampling process in USB devices. I think, macOS uses CPU base clock for USB audio interfaces syncronization.
 
Last edited:
Joined
Dec 31, 2013
Messages
802
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. iOS
Hi all, @CaseySJ

I have a question Thunderbolt 3 related.
Motherboard MSI Z490-A PRO
Gigabyte PCIe Thunderbolt 3 Titan Ridge 2.0
Audio Card UAD Arrow Thunderbolt 3
I use the SSDT downloaded from HackinDROM
MacOS Catalina 10.15.7

Hot Plug works but there's something annoying that doesn't work.
Whenever the PC goes in Sleep Mode after Wake from Sleep the Audio Card is not seen anymore. If I reboot the Audio Card is still not seen. To have it working again I have to unplug the cable, reboot and then reconnect the cable. The Audio Card is seen on any subsequent reboot until the PC doesn't sleep again. At that point, as said, I have to unplug, reboot, replug.

Ideal would be that sleep doesn't interfere and the Audio Card works at any Wake from Sleep.
Can anyone help solve this issue?
Thanks a lot!
 
Last edited:
Joined
Jun 9, 2021
Messages
309
Motherboard
Gigabyte Z690 Aero D
CPU
i9-12900K
Graphics
RX 6950 XT
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi @CaseySJ, I replaced the Intel Core i7-10700k with an i7-11700k. No problems whatsoever with either OC .6.7 or .6.8. I have been pleasantly surprised with the results. Boot times are much faster and cpu temperature is much better than on the 10700k. Here are some benchmarks. Overclocking is on advance with multicore enhancement on auto. GPU Radeon 5700XT, Vision D Z490, NVME PCIE Samsung SSD 970 EVO 2TB, Big Sur 11.2.3.

The machine also feels much faster. Sleep seems to work fine.

View attachment 51512111.2.3
View attachment 515123

View attachment 515125
How did you manage to get that speeds, I am using an SSD M.2 and mine cannot even get past 160 read/write. What must I change to get those speeds.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,495
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi all, @CaseySJ

I have a question Thunderbolt 3 related.
Motherboard MSI Z490-A PRO
Gigabyte PCIe Thunderbolt 3 Titan Ridge 2.0
Audio Card UAD Arrow Thunderbolt 3
I use the SSDT downloaded from HackinDROM
MacOS Catalina 10.15.7

Hot Plug works but there's something annoying that doesn't work.
Whenever the PC goes in Sleep Mode after Wake from Sleep the Audio Card is not seen anymore. If I reboot the Audio Card is still not seen. To have it working again I have to unplug the cable, reboot and then reconnect the cable. The Audio Card is seen on any subsequent reboot until the PC doesn't sleep again. At that point, as said, I have to unplug, reboot, replug.

Ideal would be that sleep doesn't interfere and the Audio Card works at any Wake from Sleep.
Can anyone help solve this issue?
Thanks a lot!
Hello @zzmadd,

Alas our options for dealing with such problems are limited. Here's what I can suggest:
  • If your motherboard has Thunderbolt Header, connect GC-Titan Ridge to that header. Then go to BIOS Setup and look for Thunderbolt Boot Support. Select "Boot Once" if it's available. If not, try each of the settings one to one.
  • Another option is to flash the firmware on GC-Titan Ridge. I actually recommend NVM33 from Designare Z390 (it's in the Repository -- see Section 8 of Quick Reference spoiler in Post 1 of the Z390 Designare golden build thread).
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,495
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
  • Like
Reactions: nss
Joined
Nov 13, 2011
Messages
142
Motherboard
Gigabyte Vision D
CPU
i9 10850K
Graphics
Nvidia GT 710
Getting ready to get back into this and update from OC 0.6.1 to 0.7.0. for my audio workstation.
Still on Catalina with nvidia GT710 GPU. (not intending to update to Big Sur)

0.6.1 is the last I was following this thread.... are there any pitfalls/major changes I should watch out for?

Wifi and Bluetooth are working now - that's awesome.

Is there still thermal issues with Samsung M.2 SSD's (been using a EVO Plus without issues for past 8 months but yeah its controller gets hot!).

Is the CPU temps load line calibration already in 0.7.0 download?

Any other things I should watch out for?

thanks
 
Joined
Jun 2, 2020
Messages
147
Motherboard
Gigabyte Z490 Vision G
CPU
i7-10700K
Graphics
UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
"And one more thing..."

I STRONGLY recommend to set "CPU Base Clock" ("Tweaker" page in BIOS Setup) to 100.00 MHz, NOT "Auto".
With "Auto" setting my system starts with base clock "99.95" MHz (you can check it in "System Info" in your BIOS Setup) and I have some issues (clicks, "digital noise" like "sound of a broken synthesizer", etc.) with my USB audio interface, because the CPU base clock clock (I don't know why) affects the audio sampling process in USB devices. I think, macOS uses CPU base clock for USB audio interfaces syncronization.

Some information about bus clock or "CPU Base Clock", from Clover documentation:
BusSpeedkHz
<key>BusSpeedkHz</key>
<string>133330</string>
Bus speed in kHz. Very important value for a stable system. It is passed from the boot loader to the kernel. If this value is not correct, the kernel will not start at all. If it is slightly incorrect, clock issues may arise and the system will behave in a strange way.
(c) https://sourceforge.net/p/cloverefiboot/wiki/CPU/

On my very-old system in 2010-2012 (Core 2 Duo) I had the same issues with USB audio interface, I fixed them by setting this parameter correctly in Clover config.
 
Joined
Oct 24, 2013
Messages
1,160
Motherboard
Asus ROG Z690 Formula
CPU
i9-13900K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
For those who want to run Windows 11, you must enable Intel Platform Trust Technology in the Gigabyte BIOS. Secure Boot doesn't appear to be needed at this time.
 
Top