Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

Joined
Nov 24, 2012
Messages
37
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 570
Mac
  1. iMac
  2. Mac Pro
Hello @supaMac,

I assume you're using a Broadcom WiFi/Bluetooth module instead of the on-board Intel module. If so, please try the following:
  • Enter your Hackintosh serial number on Apple's support page here:
    • https://checkcoverage.apple.com/
    • If the website replies in red that the serial number is invalid, then you are okay to use it
    • If the website replies that the serial number is valid or has a support contract, then do not use that serial number and switch to another one (and test it)
  • If serial number is okay to use, then log out of iCloud on the Hackintosh
    • System Preferences --> Apple ID --> Overview --> Sign Out...
  • Also log out of iCloud on the iOS device
  • Now reboot the Hackintosh
  • Shutdown and restart the iOS device
  • Log in to iCloud on iOS device
  • Log in to iCloud on Hackintosh
  • Test AirDrop once again...
Hello @supaMac,

I assume you're using a Broadcom WiFi/Bluetooth module instead of the on-board Intel module. If so, please try the following:
  • Enter your Hackintosh serial number on Apple's support page here:
    • https://checkcoverage.apple.com/
    • If the website replies in red that the serial number is invalid, then you are okay to use it
    • If the website replies that the serial number is valid or has a support contract, then do not use that serial number and switch to another one (and test it)
  • If serial number is okay to use, then log out of iCloud on the Hackintosh
    • System Preferences --> Apple ID --> Overview --> Sign Out...
  • Also log out of iCloud on the iOS device
  • Now reboot the Hackintosh
  • Shutdown and restart the iOS device
  • Log in to iCloud on iOS device
  • Log in to iCloud on Hackintosh
  • Test AirDrop once again...
Actually Im using the onboard Intel WiFi 6 AX201 module. Most everything is working Serial checked out and I using iMac 19.1 system definition. I'm assuming I'd have to log out on all my iCloud devices phone iPad other Mac computers and Hackintosh's?
Again, sincerely thanks for the guide and the work you put in. It took me a few try's and a few days to get to here but your guide really has everything you need. I advise others just keep reading the answers are already here!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,807
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Actually Im using the onboard Intel WiFi 6 AX201 module. Most everything is working Serial checked out and I using iMac 19.1 system definition. I'm assuming I'd have to log out on all my iCloud devices phone iPad other Mac computers and Hackintosh's?
Again, sincerely thanks for the guide and the work you put in. It took me a few try's and a few days to get to here but your guide really has everything you need. I advise others just keep reading the answers are already here!
AirDrop does not work with Intel WiFi/BT modules. The OpenIntelWireless driver does not support AirDrop and most other Continuity features at this time. Only the following are supported:
  • Handoff
    • Open web page in Safari on iOS device and you'll see notification in macOS dock (and vice-versa)
  • Continuity Clipboard
    • Copy some information to clipboard on iOS device and paste it in macOS (and vice-versa)
 
Joined
May 18, 2021
Messages
17
Motherboard
ASRock X570 Phantom Gaming-ITX/TB3
CPU
Ryzen 9 3900X
Graphics
RX 590
Mac
  1. MacBook Pro
  2. Mac Pro
For some odd reason, I'm always using the latest OC. :)

1. In BIOS be sure to set Thunderbolt Security to No Security, and power on the UAD device before turning on the computer.
2. Yes, I'm also using the latest UAD 9.14.1.
3. You can also try the DTGP.aml and TB3.aml that you can find from Hackindrom site. It might work better for you. I'm also using the latest BIOS for this board, I believe its the 3.10.
4. Enjoy and start making music! :)
I will, Thanks!

I was curious about my Mac Pro 5,1 so I tried the previous methods I used with the Ryzen (the Titan Ridge and custom NVM23). Installed OC 0.6.8, Mac Pro SSDT-TB3.

Interestingly It shows up in IOreg, but doesn't show up in PCI.
 

Attachments

  • Screen Shot 2021-05-21 at 9.11.30 PM.png
    Screen Shot 2021-05-21 at 9.11.30 PM.png
    556.5 KB · Views: 22
Joined
May 18, 2021
Messages
17
Motherboard
ASRock X570 Phantom Gaming-ITX/TB3
CPU
Ryzen 9 3900X
Graphics
RX 590
Mac
  1. MacBook Pro
  2. Mac Pro
Have you tried to insert the devices in Device Properties?

l'm not sure how you got "com_uaudio_driver..." to show up or how to insert the devices in Device Properties.

My PCI section is only the titan ridge on Mac Pro and Ryzen.

For the Mac Pro I just put SSDT-TBOLT3.aml in ACPI in OC folder and enabled with OC configurator. I tried with this machine because others have gotten TR 2.0 to work. Possibly it's the PCI card? I verified the ROM on blue chip.

One thing to add: I couldn't find the TB3.aml on the Hackindrom site. I'll try without TB3 SSDT.aml in a few days when the AsRock arrives.
 
Last edited:
Joined
Feb 18, 2021
Messages
28
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900
Graphics
Radeon RX 580 8 GB
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hi everyone.
Is there a way to make an Apple Magic Keyboard work AGAIN on OpenCore boot menu (0.6.9 release)? Currently, I have to use my Magic Mouse to select any other than the default OS. The keyboard was working with OC 0.6.6 (same BIOS), and I do not know if it broke with the update to OC 0.6.7 or OC 0.6.9. I am using the Fenvi T919 card, macOS 10.15.7 (19H1030), BIOS F20b.
Thanks in advance!
 
Last edited by a moderator:
Joined
Feb 10, 2019
Messages
315
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Did you check the drop-down menu?

Screen Shot 2021-05-22 at 12.27.08.png
 
Joined
Jan 6, 2016
Messages
159
Motherboard
Gigabyte Z490 Vision G
CPU
i7-10700
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. 128K
  2. 512K
  3. Plus
  4. Portable
  5. Power Mac
Mobile Phone
  1. iOS
@CaseySJ,

I haven't moved the WiFi/BT PCIe card from the old system to the new system yet so it's not that and I don't have any of the other types of sleep deprivation components you mention either ....

Was really just looking to get confirmation if Z490 Vision G sleeps ok with OC 0.69 + OSX 11.3.1 ? as both yourself and @Justcurious1 reported sleep not working with this combo a few pages back in this thread.

Other than the sleep issue the system is running well ... slowly migrating software from my old Haswell system to this new one :crazy:

Cheers
Jay
Still no resolution with sleep on my end. I think it’s the old hibernation issue. It actually does go to sleep and I can successfully wake it as long as I don’t wait too long. Could it be hibernation?
 
Top