Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,800
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I can confirm that adding the kernel patch provided by Vit9696 on the dortania guide posted earlier, FakePCIID.kext + FakePCIID_Intel_I225-V.kext are no longer needed (MacOs 11.3). The AppleIntel210Ethernet kext is loaded (v2.3.1) but I cannot test 2.6GBE speeds as I have no devices. (I'm on Vision-G)

Cheers!

I can confirm that the speed is 2.5 Gbps when following the dortania guide and removing the FakePCIID.kext + FakePCIID_Intel_I225-V.kext.

I'm on Z490 Vision D and Big Sur 11.3
Just to avoid any confusion:
  • The kernel patch by vit9696 is equivalent to using FakePCIID. We can use either the patch or the kext.
  • However, vit9696 states that Big Sur 11.4 beta natively supports the i225-V with device ID 0x12F3. This means turning off all patches and FakePCIID kexts. However, when we do this, Big Sur 11.4 attaches the 1GbE driver instead of the 2.5GbE driver, so either the kernel patch or FakePCIID kext is still needed.
  • Let's hope that 11.4 release version supports device ID 0x12F3 natively.
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,800
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ and others, do you guys know if there is an WiFi card - apart from the onboard Intel AX201 - that supports AX mode and is compatible with our system?
I have the combo BT+WiFi (original Apple module + PCIe x1 adapter) which supports up to AC.
I recently changed my router and got an Asus GT-AX11000 tri-band but somehow the current WiFi card does not work anymore. The card can join the network and get an IP address but somehow I don't have access to the Internet even if in the network status it is stated that I can. There is an option in the router to enable AX/WiFi 6 mode which I turned on (since I am planning to use the onboard Intel one later one), and there is a warning that some WiFi card might not work. Just wondering if there was a cheap AX WiFi card or USB dongle that I could install while waiting for the onboard Intel one to fully support AX.
Thanks.
This Fenvi AX200 PCie card is compatible with the OpenIntelWireless drivers. It supports WiFi 6 and Bluetooth 5.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,800
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi @CaseySJ, do you know why sidecar is so laggy? My hack connected via Ethernet and iPad mini connected to 5.8GHz network. It works, but totally unusable.
Some questions:
  • Which version of macOS are you running?
  • What is your system product name? (iMac19,1?)
  • Is your on-board WiFi turned off?
  • If you are connected via wired Ethernet, is it a 1 gigabit Ethernet all the way to the router?
  • When did you first notice the Sidecar laggy behavior?
  • How long was the system running fine with no lagginess?
  • Give this procedure a try, but don't forget to answer the above questions.
 
Joined
Oct 18, 2020
Messages
89
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
USB 3 devices will connect everywhere, but USB 2 devices won’t connect to red ports. If we use the new SSDT coming next week then USB 2 devices will not connect to Thunderbolt ports either. Again, USB 3 will connect everywhere.

In your opinion, will it affect also the combination Vision G + GC-Titan Ridge 2.0 + Ultrafine 5k Alpine Ridge ?
Not sure you remember when I mentioned it to you, but I found out that booting the system with the USB 2.0 header disconnected wouldn't let the Ultrafine monitor to turn on.


On a side note, I have been having troubles trying to export x264 videos using Premiere Pro and my Hack using hardware encoding. Videos are full of artifacts. I have tried a few solutions but still no luck.
From what I can see, according to Adobe, Premiere uses Intel QuickSync to export x264 (iGPU), and my Hack is configured as iMac20,2, Vision G, 10900k, 5700 XT, Big Sur 11.4 beta #1. I haven't tested it when I was on 11.2.3, so not sure how to go to the root of the problem.
I might start with a fresh install of Big Sur, using the same configuration, then I'll see.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,800
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
$1200 for 6 GHz are they crazy? With those prices, they must think it’s a GPU, Lol. Early adopter tax. I will be waiting.

My Ax210 isn’t going anywhere.
I've been itching to upgrade my home wireless network from WiFi 5 to WiFi 6E, but I can also wait. OpenIntelWireless 2.0.0-alpha supposedly supports WiFi 6, but I haven't been able to see that listed under PHY Modes (yet). Anyway, it seems we should soon be able to run our Hackintoshes on WiFi 6. All of Apple's new products in 2021 support WiFi 6.
 
Joined
May 30, 2016
Messages
987
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
Just to avoid any confusion:
  • The kernel patch by vit9696 is equivalent to using FakePCIID. We can use either the patch or the kext.
  • However, vit9696 states that Big Sur 11.4 beta natively supports the i225-V with device ID 0x12F3. This means turning off all patches and FakePCIID kexts. However, when we do this, Big Sur 11.4 attaches the 1GbE driver instead of the 2.5GbE driver, so either the kernel patch or FakePCIID kext is still needed.
  • Let's hope that 11.4 release version supports device ID 0x12F3 natively.
Correct. My personal preference is the kernel patch, as less kexts are required, and Rehabman’s FakePCIID is (to my knowledge) no longer maintained. :)
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,800
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
In your opinion, will it affect also the combination Vision G + GC-Titan Ridge 2.0 + Ultrafine 5k Alpine Ridge ?
Not sure you remember when I mentioned it to you, but I found out that booting the system with the USB 2.0 header disconnected wouldn't let the Ultrafine monitor to turn on.
Fortunately you can safely continue to use USB 2.0 and USB 3.0 devices on the GC-Titan Ridge because it has its own USB controller. The 15-port limit applies to each controller. The GC-Titan Ridge has only 4 logical USB ports (two USB 2.x and two USB 3.x), which is well under the 15-port limit.

On a side note, I have been having troubles trying to export x264 videos using Premiere Pro and my Hack using hardware encoding. Videos are full of artifacts. I have tried a few solutions but still no luck.
From what I can see, according to Adobe, Premiere uses Intel QuickSync to export x264 (iGPU), and my Hack is configured as iMac20,2, Vision G, 10900k, 5700 XT, Big Sur 11.4 beta #1. I haven't tested it when I was on 11.2.3, so not sure how to go to the root of the problem.
I might start with a fresh install of Big Sur, using the same configuration, then I'll see.
If the iGPU is configured properly (IORegistryExplorer --> iGPU@2 --> AppleIntelFramebuffer) then the problem might be due to an Adobe-specific setting. Maybe some Adobe experts can chime in...
 
Joined
Oct 18, 2020
Messages
89
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Fortunately you can safely continue to use USB 2.0 and USB 3.0 devices on the GC-Titan Ridge because it has its own USB controller. The 15-port limit applies to each controller. The GC-Titan Ridge has only 4 logical USB ports (two USB 2.x and two USB 3.x), which is well under the 15-port limit.
Phew. Good to know.

If the iGPU is configured properly (IORegistryExplorer --> iGPU@2 --> AppleIntelFramebuffer) then the problem might be due to an Adobe-specific setting. Maybe some Adobe experts can chime in...
Uhm, could you please help me to understand whether it's configured properly or not?

Oh, CaseySJ, here you said there were a few adjustments to be made. What does it involve? And should it be done also if changing platform? Because I am asking myself if I am missing anything important by not asking someone to do it... like... "is it necessary?".
 

Attachments

  • AppleIntelFramebuffer.png
    AppleIntelFramebuffer.png
    1.1 MB · Views: 50

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,800
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Phew. Good to know.


Uhm, could you please help me to understand whether it's configured properly or not?

Oh, CaseySJ, here you said there were a few adjustments to be made. What does it involve? And should it be done also if changing platform? Because I am asking myself if I am missing anything important by not asking someone to do it... like... "is it necessary?".
iGPU is configured properly. Please run Hackintool and see whether VDA Decoder is Fully Supported, as such:
Screen Shot 2021-05-02 at 3.34.13 PM.png
 
Top